Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Обновление сертификатов браузера без подъема его версии  (Прочитано 829 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн muslimgauze

  • Автор темы
  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
Возможна ли такая странная вещь, как обновление сертификатов SSL/TLS в браузере без обновления самого браузера?
По ряду причин, основной браузер у меня "настоящая опера", но она давно умерла в развитии, не обновляясь лет так пять.
Оно максимально удобно и привычно, я не нашел даже близкого по функциональности современного аналога, не считая кривенького Вивальди.
Но вот все больше и больше сайтов (это и понятно) пишут при попытке зайти туда по https-протоколу что-то вроде:

"Не удалось квитировать соединение, так как сервер не принимает доступные версии протокола SSL/TLS."

Собственно сабж!

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25311
    • Просмотр профиля
Это с каким сайтом такая проблема?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн muslimgauze

  • Автор темы
  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
Это с каким сайтом такая проблема?

С массой из тех, кто использует современные протоколы в https.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25311
    • Просмотр профиля
Может, стоило сразу тему создать в "разговоры обо всём" ?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн muslimgauze

  • Автор темы
  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
Может, стоило сразу тему создать в "разговоры обо всём" ?

Этот не разговор обо всем, а конкретная проблема с конкретным браузером. У конкретного пользователя. :)

И мне важно то, что я спросил (сам факт возможности такого), а не на каких сайтах проблемы - текст сообщения может быть разным, но проблема остается - нет доступа без поддержки новых версий. То есть, в старой Опере выдаются ошибки, а в новых браузерах оно работает без проблем:

Безопасное подключение: критическая ошибка (49)
https://webmoney.ru/

Безопасное подключение: критическая ошибка (70) с сервера
https://phreaker.pro/

Безопасное подключение: критическая ошибка (40) с сервера
https://legalno.info/
Ошибка подключения к серверу. Возможно, методы шифрования, поддерживаемые сервером, не включены в настройках безопасности.

Собственно, я и начал думать. прочитав комментарий к последней ошибке.



Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25311
    • Просмотр профиля
ВМ открывается, остальные нет.
Пошукал по сусекам, могу только посочувствовать. В 12.18 они это исправили, но под Linux её не выпустили.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн muslimgauze

  • Автор темы
  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
ВМ открывается, остальные нет.
Пошукал по сусекам, могу только посочувствовать. В 12.18 они это исправили, но под Linux её не выпустили.

У меня, увы:

Версия:
12.16
Сборка:
1860

Пользователь добавил сообщение 19 Февраль 2018, 02:44:31:
ВМ открывается, остальные нет.

С ВМ проще оказалось, это я ступил, заблокировал их сертификат.
С остальным проблема осталась.

Пользователь добавил сообщение 19 Февраль 2018, 02:49:54:
Пошукал по сусекам, могу только посочувствовать. В 12.18 они это исправили, но под Linux её не выпустили.

Что интересно, про "квитировать" люди и в 2009 году спрашивали.
« Последнее редактирование: 19 Февраль 2018, 02:49:54 от muslimgauze »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25311
    • Просмотр профиля
В 12.16 полностью отсутствует поддержка шифров на базе эллиптических кривых (Elliptic Curves, шифры "ec…").
Даже если библиотека их предоставляет, браузер их использовать не будет.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн muslimgauze

  • Автор темы
  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
В 12.16 полностью отсутствует поддержка шифров на базе эллиптических кривых (Elliptic Curves, шифры "ec…").
Даже если библиотека их предоставляет, браузер их использовать не будет.

Скачал виндовую 12.18, скопировал настройки... всё пашет, но это жуткий костыль с вайном.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25311
    • Просмотр профиля
Ждём, когда допилят Vivaldi … без вариантов :(
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн muslimgauze

  • Автор темы
  • Участник
  • *
  • Сообщений: 159
    • Просмотр профиля
Ждём, когда допилят Vivaldi … без вариантов :(

Я не доживу до этого ;)

Пользователь добавил сообщение 20 Февраль 2018, 22:15:29:
Хотя, посмотрел последнюю версию Вивальди и понял, что мне кроме "скина под настоящую оперу" надо только пункт закладки в меню файл-помощь, остальное более-менее привычно выглядит и устраивает.
« Последнее редактирование: 20 Февраль 2018, 22:15:29 от muslimgauze »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 1032
    • Просмотр профиля
Цитировать
Версия:
12.16
Сборка:
1860
...максимально удобно и привычно, я не нашел даже близкого по функциональности современного аналога
muslimgauze, полностью поддерживаю.
Цитировать
в старой Опере выдаются ошибки, а в новых браузерах оно работает без проблем...
Из тех сайтов, которыми приходится пользоваться мне:
Secure connection: fatal error (40) from server. https://farmanager.com/download.php?l=ru Failed to connect to server. The reason may be that the encryption methods supported by the server are not enabled in the security preferences.
В таких местах приходится использовать vivaldi.
Цитировать
мне кроме "скина под настоящую оперу" надо только пункт закладки в меню файл-помощь...
Такие мелочи я бы стерпел.
Но он буквально грузится на порядок дольше.
Оперативы требует на порядок больше.
Любое действие, на любом сайте требует на порядок больше времени.
Цитировать
Ждём, когда допилят Vivaldi...
Исходя из перечисленного они не пилят, а лепят... горбатого.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25311
    • Просмотр профиля
Ну так добавьте памяти, что вы тут бедного родственника строите…
У меня оно максимум пару-тройку гигов ест - ровно столько, сколько и Опера.
Оба 64-бит.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.069 секунд. Запросов: 19.