Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: не запускается Ubuntu . initramfs  (Прочитано 29498 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
не запускается Ubuntu . initramfs
« : 10 Ноябрь 2010, 18:47:34 »
В общем дело было так:
На компьютере стоит два жестких диска.На одном(250гб) винХР и мусорка и второй(640гб) стояла Ubuntu 10,10 х32 ,мусорка и еще одна Ubuntu 9,04(использовал раньше для экспериментов,но она осталась до сих пор  :) ) .
Вот у меня зашумел кулер на жестком диске,я выключил компьюетр,отключил жесткие диски,снял их,смазал кулер.Потом запустил компьютер без жестких дисков (Что бы проверить как крутится кулер.Из-за этого скорей всего все и произошло). Потом поставил все на место и включил компьютер.
Теперь суть проблемы:
Перестали запускаться убунты обе .ВинХР запускается и работает. Даже не запускалась Ubuntu ливСД.





Если через некоторое время написать exit то загружалась Ubuntu,но после пары раз начало выдавать кернел паник.Пробовал сбрасывать биос-не помогло .Гуглил,находил подобные проблемы,но решений конкретных нет.Пробовал в грубе менять UUID на /dev/sdb* -тоже не помогало.

Вот сейчас удалось запустить ЛивСД Ubuntu 10,10 х64 .Снес все убунты,поставил Ubuntu х64 (раздел /home оставил старый) .Все установилось без ошибок.Запускаю-то же самое,но только если написать через несколько минут exit,то запускается Ubuntu и все работает нормально.Запускал в убунте fsck -не помогло.
Так же пробовал менять ЖД местами,подключал другим кабелем.
Что делать?  :)

Пользователь решил продолжить мысль 12 Ноябрь 2010, 13:50:24:
up... :(
« Последнее редактирование: 12 Ноябрь 2010, 13:50:24 от Bogd@n »

Оффлайн eerome

  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #1 : 27 Апрель 2011, 15:57:36 »
Вот столкнулся с подобной проблемой. Есть кто может помочь с решением?

Оффлайн yorik1984

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 1592
  • Кто не хочет, ищет причины
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #2 : 28 Апрель 2011, 02:54:27 »
Пробовал в грубе менять UUID на /dev/sdb* -тоже не помогало.
каким образом?
пожалуйста выхлоп
sudo blkidи еще cat /etc/fstab для файлов установленной убунты, а не лайв сиди

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #3 : 08 Май 2011, 22:51:20 »
bogdan@LinuxPC:~$ sudo blkid
(Нажмите, чтобы показать/скрыть)

bogdan@LinuxPC:~$ cat /etc/fstab
(Нажмите, чтобы показать/скрыть)


так же вот недавно поставил начисто на этот же диск 11.04 -все тоже самое,также вываливается в шел,но ничего не видно из-за фиолетовой заставки,если через 3 минуты в слепую написать exit  то продолжает грузится. Вернулся обратно на 10.10 по причине нестабильности 11.04, проблема осталась .

Оффлайн es1840

  • Активист
  • *
  • Сообщений: 283
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #4 : 09 Май 2011, 00:17:58 »
У вас не совпадает uuid загрузочного (root) диска в /boot/grub/grub.cfg. (Это если Grub2 стоит)
Проверьте этот файл.
Если нужно, исправьте, но не делайте update-grub.
Лучше в recovery mode
# nano /boot/grub/grub.cfg
# init 6


После удачной загрузки, сделайте
$ sudo update-grub
А при установке, наверное, неправильно сделали монтирование дисков... Да и Grub. то есть Grub2, надо было переустановить.
« Последнее редактирование: 09 Май 2011, 00:26:54 от es1840 »

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #5 : 09 Май 2011, 20:17:38 »
да вроде бы совпадает

/boot/grub/grub.cfg
(Нажмите, чтобы показать/скрыть)

Оффлайн es1840

  • Активист
  • *
  • Сообщений: 283
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #6 : 09 Май 2011, 20:46:50 »
Сделайте вывод
# dpkg --get-selections|grep grub
PS 
У вас на фото указан диск, которого нет в указанных вами конфигах.
Где у вас установлен grub2?
Может, у вас вообще их два?
В смысле от 9.04 на sda остался grub, а где-нибудь на sda2 - grub2?
« Последнее редактирование: 09 Май 2011, 21:08:55 от es1840 »

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #7 : 09 Май 2011, 21:38:23 »
Цитировать
PS
У вас на фото указан диск, которого нет в указанных вами конфигах.
тема была создана в том году,за это время я пару раз переустанавливал систему.
Цитировать
Где у вас установлен grub2?
/dev/sda

Цитировать
Может, у вас вообще их два?
как узнать?

bogdan@LinuxPC:~$ sudo dpkg --get-selections|grep grub

grub-common install
grub-pc install

Оффлайн es1840

  • Активист
  • *
  • Сообщений: 283
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #8 : 09 Май 2011, 23:58:20 »
В прошлом году....?
А сейчас что?
Дайте информацию на сегодня....
Что установлено? Какая версия системы?
$ sudo fdisk -l$ cat /boot/grub/grub.cfgsudo blkid cat /etc/fstab

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #9 : 10 Май 2011, 00:30:35 »
я тему открывал в ноябре 2010 года,но на сегодняшний день ситуация так и не изменилась.Стоит та же Ubuntu 10.10 (пробовал 10.04, 11.04 )ошибка та же,просто UUID отображается другой(завтра постараюсь сфотографировать ).
fdisk -l
(Нажмите, чтобы показать/скрыть)

 cat /boot/grub/grub.cfg
(Нажмите, чтобы показать/скрыть)
blkid
(Нажмите, чтобы показать/скрыть)
/etc/fstab
(Нажмите, чтобы показать/скрыть)

Оффлайн es1840

  • Активист
  • *
  • Сообщений: 283
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #10 : 10 Май 2011, 00:54:53 »
А в BIOS какой загрузочным стоит?
Ну и фото шлите.

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #11 : 10 Май 2011, 14:53:20 »
в биосе стоит тот же /dev/sda



процесс загрузки :
1. http://www.sendspace.com/file/epjvtv
2.прошло 3 минуты http://www.sendspace.com/file/jeb3ut

Оффлайн es1840

  • Активист
  • *
  • Сообщений: 283
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #12 : 10 Май 2011, 17:02:38 »
Все посмотрел, слов нет.
Единственное,что можно попробовать, наверное... может, особенности motherboard...

Попробуйте в файле /etc/default/grub добавить параметр ядра

Найдите
Цитировать
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
и добавьте туда all_generic_ide
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash all_generic_ide"
После добавления сохранить и обновить Grub
$ sudo update-grub
И выложите, еще при нынешнем состоянии /var/log/kern.log
только засеките время старта загрузки и обрежьте файл, ну и под спойлер...

Оффлайн Bogd@n

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #13 : 10 Май 2011, 21:11:17 »

видно что лог пошел в 20.00.50 ,но компьютер был включен в 19.59 и в это же время он вывалился в initramfs ,в 20.00.50 я написал exit и он начал свою обычную загрузку.


Пользователь решил продолжить мысль 10 Май 2011, 21:19:07:
Цитировать
>Попробуйте в файле /etc/default/grub добавить параметр ядра
не помогло (

Напомню что это началось после того как я отключил жесткий диск на котором находилась Ubuntu,включил компьютер без жесткого диска,затем вставил его на место и после этого все началось .Что можно в биосе поклацать?Я его после этого еще сбрасывал до первоначального состояния доставанием батарейки-не помогло.
« Последнее редактирование: 10 Май 2011, 21:19:07 от Bogd@n »

Оффлайн es1840

  • Активист
  • *
  • Сообщений: 283
    • Просмотр профиля
Re: не запускается Ubuntu . initramfs
« Ответ #14 : 10 Май 2011, 22:32:11 »
Честно говоря, мне не нравится в логе свистопляска с 707 строки.
Проверьте правильность включения дисков в разъемы SATA,
желательно, начиная с первого SATA.
Проверьте настройку дисков в BIOS, соответствие дисков разъемам, порядок загрузки и т.д.
И я бы оставил тоько один диск с флагом загрузки, у вас на обоих загрузочные разделы....
но это только мое личное мнение.
Руководство к мат.плате всегда есть на сайте производителя, по BIOS - то же самое.

 

Страница сгенерирована за 0.131 секунд. Запросов: 24.