Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: "Информация об обновлениях устарела" (проблемы с ключами?)  (Прочитано 28994 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Helg Schneider

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Приветствую, коллеги!
Вынужден задавать вопрос, ибо гугл с яндексом не помогли и сам не осилил.
Итак:
Установлена 11.10. После долгого отсутствия нормального канала и неустановки обновлений, само собой, вылезла иконка с красным треугольником и восклицательным знаком: "Информация об обновлениях устарела"... Я ее не замечал, ибо знал, что устарела наверняка.
Сейчас включил канал на полную мощность, начал обновлять. А треугольник не пропадает.
Подробности:

sudo apt-get update -o Acquire::http::No-Cache=True
(Нажмите, чтобы показать/скрыть)
Оба глючных ключа удалял, ставил заново:
$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
(Нажмите, чтобы показать/скрыть)
- не помогло. Удаляет, ставит, но все равно ругается.
Пытался напрямую слить ключ и экспортировать: ключ с extras не захотел ставится, сказал, что в файле нет данных OpenPGP.

С чем связан глюк -  не пойму... но этот глюк на двух разных ноутах, живших в этой сети. На остальных компах стоят другие сборки / ОС... Что посоветуете? Может у кого было такое ? (похожее было у многих, яндекс упоминает это часто, но все решения, которые помогали другим, мне не помогли. Не помогло менять сервер обновлений, ничего не помогло, из того, что я нашел.)



« Последнее редактирование: 26 Апрель 2013, 11:53:22 от Ancle »

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
У меня подобные глюки и ещё ворох других наблюдается в локалке за корпоративным фаерволом/контент-фильтром esafe.

Обычно решается (но иногда не с первого раза) следующим образом:
sudo rm -f /var/cache/apt/archives/{partial/,}* /var/lib/apt/lists/{partial/,}*
sudo apt-get update

Оффлайн Helg Schneider

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
arcfi, да, да, да. Решено. (конечно, строка удаления файлов несколько иначе пишется, но это уже не важно)

Итак, решение, действительно в РУЧНОЙ ОЧИСТКЕ листов и кэша. Грустно мне, грустно. Сам должен был дойти...
СПАСИБО ОГРОМНОЕ!

Оффлайн moneycan

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Helg Schneider, у меня возникла такая же проблема. Не могли бы вы по подробней описать решение проблемы?
Спасибо

Оффлайн formatcft

  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Цитировать
Helg Schneider, у меня возникла такая же проблема. Не могли бы вы по подробней описать решение проблемы?
Спасибо
Прсто удали 2 папки /var/cache/apt/archives/partial/  и /var/lib/apt/lists/partial/
потом sudo apt-get updateСпасибо, вроде помагло щас обновляться буду.Тему бы закрепить повыше, как актуальную.

Оффлайн SergheiLS

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
конечно, строка удаления файлов несколько иначе пишется, но это уже не важно)
А как она пишется???...

P.S. Новичок...

Оффлайн Userboy

  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
У меня подобные глюки и ещё ворох других наблюдается в локалке за корпоративным фаерволом/контент-фильтром esafe.

Обычно решается (но иногда не с первого раза) следующим образом:
sudo rm -f /var/cache/apt/archives/{partial/,}* /var/lib/apt/lists/{partial/,}*
sudo apt-get update
У меня при запуске этих комманд вылазиет.
Цитировать
rm: невозможно удалить «/var/cache/apt/archives/partial/»: Это каталог
rm: невозможно удалить «/var/cache/apt/archives/»: Это каталог

Цитировать
rm: невозможно удалить «/var/lib/apt/lists/partial/»: Это каталог
rm: невозможно удалить «/var/lib/apt/lists/»: Это каталог

 Обновлялся недавно. А в менеджере обновлений написанно что 68 дней назад.
Пробую обновится через менеджер обновлений, выскакивает ошибка.
Цитировать
W:GPG error: http://packages.medibuntu.org oneiric InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783, W:Failed to fetch cdrom://Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007.1)/dists/maverick/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007.1)/dists/maverick/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, E:Some index files failed to download. They have been ignored, or old ones used instead.


Оффлайн Wess

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
а у меня просто во время каждого обновления пишет, что сколько-то дней назад было обновление( но при этом обновляет.
Это тоже надо очищать вручную по вышеописанной схеме?
« Последнее редактирование: 31 Январь 2012, 22:51:11 от Wess »

Оффлайн EgorVitebsk

  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
У меня была подобная проблема. Менеджер обновления сигналил красным треугольником и ругался за отсутствие обновлениq/ При попытки обновления выдавал ошибку интернет соединения. А в подробностях следующее:
(Нажмите, чтобы показать/скрыть)

Пытался удалять папки-   /var/cache/apt/archives/partial/  и /var/lib/apt/lists/partial/ не помогло. Попробовал следующее: открыл Источники приложений и во вкладке Другое П/О снял для пробы отметки с конфликтующих приложений. Проблема вроде отвалилась.  :)

Оффлайн AngryBird

  • Активист
  • *
  • Сообщений: 259
    • Просмотр профиля
удалил 2 папки /var/cache/apt/archives/partial/  и /var/lib/apt/lists/partial/
потом sudo apt-get update
(Нажмите, чтобы показать/скрыть)

Такая вот беда у меня в Минте Двенадцатом.

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 26 Апрель 2012, 22:37:05 от AngryBird »
Toshiba Satellite C670 A2K

Оффлайн skaspy

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
у меня такая же проблема с ключами , только не получилось никак решить , еще ни один гуру линукса не помог, а систему не могу переустановить

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн skaspy

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Nikki1993
у меня не ставится эта програма

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
skaspy,
какая ошибка вылазиет если ты пытаешься установить программу?





First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн skaspy

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
sudo add-apt-repository ppa:webupd8team/y-ppa-manager:

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.vwuoSQSYJT --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 7B2C3B0889BF5709A105D03AC2518248EEA14886
gpg: запрашиваю ключ EEA14886 с hkp сервера keyserver.ubuntu.com
gpg: ключ EEA14886: "Launchpad VLC" не изменен
gpg: Всего обработано: 1
gpg:              неизмененных: 1
 
насколько я понимаю у меня что то с ключами, походу они весят от прошлой версии, или что то с  соурс листом , ноя не пойму как его редактировать
« Последнее редактирование: 24 Июнь 2012, 12:10:38 от skaspy »

 

Страница сгенерирована за 0.737 секунд. Запросов: 23.