Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: [HOWTO] Подключение принтеров Canon LBP, работающих с драйвером CAPT  (Прочитано 166765 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3003
    • Просмотр профиля
так почитал бы скрипт, там нет и намека на вмешательство в гуй системы.
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad ;ядро: linux-zen

Оффлайн su_cpp

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
так почитал бы скрипт, там нет и намека на вмешательство в гуй системы.

я не знаю что он там за пакеты заменял но грошнул кучу стандартных пакетов вместе с кучей программ


Пользователь добавил сообщение 10 Январь 2018, 18:31:31:
sudo apt install gimp

> Пакеты, имеющие неудовлетворённые зависимости:
> gimp : Зависит: libgegl-0.3-0 (>= 0.3.0) но он не будет установлен

sudo apt install libgegl-0.3-0

> Пакеты, имеющие неудовлетворённые зависимости:
> libgegl-0.3-0 : Зависит: libumfpack5.7.1 но он не будет установлен

sudo apt install libumfpack5.7.1

> Пакеты, имеющие неудовлетворённые зависимости:
> libumfpack5.7.1 : Зависит: libcholmod3.0.6 но он не будет установлен

sudo apt install libcholmod3.0.6

> Пакеты, имеющие неудовлетворённые зависимости:
> libcholmod3.0.6 : Зависит: liblapack3 но он не будет установлен

sudo apt install liblapack3

> Пакеты, имеющие неудовлетворённые зависимости:
> liblapack3 : Зависит: libgfortran3 (>= 4.6) но он не будет установлен

sudo apt install libgfortran3

> Пакеты, имеющие неудовлетворённые зависимости:
> libgfortran3 : Зависит: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) но 5.4.0-6ubuntu1~16.04.5 будет установлен
> E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Финиш.
Как это исправить?
sudo dpkg --configure -a
не срабатывает!
« Последнее редактирование: 10 Январь 2018, 18:31:31 от su_cpp »

Оффлайн Anaferon

  • Участник
  • *
  • Сообщений: 106
    • Просмотр профиля
Господа, добрый день, перестал работать LBP 2900 на 16.04.3
раньше всё было нормально, драйвера ставил руками, попробовал снести всё и поставить скриптом, успеха не принесло, снёс и опять поставил руками ни чего не помогает, печать уходит в задания в статус "обработка".
После включения принтера физически, в /dev/usb/ на пару секунд появляется lp1 и исчезает.
captstatusui просит проверить конфиг - Check the <Printer ***> of /etc/ccpd.conf   , но там вроде бы всё в норме.

P.S.
Не знаю как, но эта штука снова заработала...
« Последнее редактирование: 16 Январь 2018, 14:23:08 от Anaferon »

Оффлайн Джим

  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Всем привет!
Перешел с Ubuntu 17.04 на 17.10. В 17.10 не захотел работать мой  LBP-1120. При запуске скрипта Кодена canon_lbp_setup.sh, возникает ошибка "команда не найдена". Установка  вручную также не дала результата. Пробная страница становится в очередь на печать, но не печатается. Если кто понимает в чём тут дело, прошу помочь.

Ура! После недолгих танцев с бубном, удалось запустить скрипт Кодена с журналированием и он всё сделал. Однако повторно запустить скрипт не удаётся.
Всё. Справился и с этим
« Последнее редактирование: 19 Январь 2018, 20:41:39 от Джим »

Оффлайн Snaut

  • Любитель
  • *
  • Сообщений: 71
  • Гномофил-кедерастоненавистник
    • Просмотр профиля
    • Фельдшер Ру
Ура! После недолгих танцев с бубном, удалось запустить скрипт Кодена с журналированием и он всё сделал. Однако повторно запустить скрипт не удаётся.
Всё. Справился и с этим

Можно за Вас порадоваться, но не будете ли столь любезны описать каким убразом решили свою проблему? :)
Чтобы правильно задать вопрос, надо знать бОльшую часть ответа.

Оффлайн Джим

  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Можно за Вас порадоваться
Спасибо, Snaut
я сам толком не разобрался как мне это удалось. Как я писал ранее, мне не удавалось запустить скрипт Кодена и я ошибочно предполагал, что этот скрипт не находит какой-то файл в системе. Позже я понял, что неправильно вызываю на исполнение сам скрипт и стал вызывать его вот так:
sudo logsave log.txt ./canon_lbp_setup.sh
Скрипт начал работать без проблем и заработал мой принтер. Вот и всё.
PS
Сегодня переустановил свой принтер в Ubuntu 18.04. Скрипт Кодена отработал безукоризненно.
« Последнее редактирование: 05 Май 2018, 12:34:30 от Джим »

Оффлайн DIK13

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
На Ubuntu 16.04 LTS (64 бит) исправно трудится Canon LBP2900.
Обновил до 16.10 и уставится libpng16, а cndrvcups-capt требует libpng12, которого нет.
Подскажите как можно вернуться на LTS или как можно создать симлинк на 16ю версию.
Проблема, так полагаю, и с teamviewer будет.

Пользователь добавил сообщение 19 Ноябрь 2016, 17:56:36:
Сам спросил - сам ответил. Нашел пакет libpng12-0 : Yakkety (16.10) amd64
тут -> http://packages.ubuntu.com/xenial/amd64/libpng12-0/download
dpkg --install libpng12-0_1.2.54-1ubuntu1_amd64.deb далее по инструкции ./canon_lbp_setup.sh

И CAPT установился и принтер заработал.
Скачал и установил вручную https://packages.ubuntu.com/xenial/libs/libpng12-0
Тоже делал для своего ubuntu-mate 18.04 lts. Canon lbp3010 работает.

 

Страница сгенерирована за 0.229 секунд. Запросов: 23.