Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Использование davfs2 для монтирования облаков по WebDav  (Прочитано 17301 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6942
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
spiritabsolute, как монтируешь?

Оффлайн vkapas

  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
А кто-нибудь смог побороть жесточайшие тормоза всего графического интерфейса при использования подмонтированного каталога через mount -t davfs.

Аналогичная проблема с Яндекс.Диском.

Во-первых, само монтирование (из консоли или через Nautilus по клику на сетевом диске) происходит около 1 минуты.
При копировании начинаются просто чудовищные тормоза, чтобы через mc просто вызвать диалог копирования (по F5) приходится уже ждать 20-30 секунд, после чего ещё столько же нужно ждать появления прогресс-бара mc. Само копирование может идти 3-5-10 минут для файла размером меньше мегабайта (!), а иногда не удаётся скопировать даже и это: в самом начале копирования счётчик просто замирает и дальше уже не двигается.
И отдельная проблема: при просмотре папки с 100-200+ файлами она как будто бы пустая. Хотя при просмотре через веб-интерфейс все файлы очень даже на месте.

При работе от суперпользователя всё тоже самое.

Кто-нибудь сталкивался с подобным?

davfs2 1.4.5-1

P.S. Перешёл на davfs, т.к. на днях в Ubuntu 10.04 подключение через gvfs перестало работать (из-за перехода Яндекс.Диска с SSL на TSL).
« Последнее редактирование: 19 Ноябрь 2014, 15:50:55 от vkapas »

Оффлайн ottomax

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Добрый день! Пытаюсь смонтировать яндекс диск в Raspberrian, все по инструкции, однако автомонтирование не работает. В ручную команда mount /home/pi/yandexs.disk монтирует, однако демонтировать не получается требует root. Прошу совета!

Оффлайн garynych2010

  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
А кто-нибудь смог побороть жесточайшие тормоза всего графического интерфейса при использования подмонтированного каталога через mount -t davfs.

Аналогичная проблема с Яндекс.Диском.

по davfs2 не возможно юзать ... из за кэширования система зависает на долго а то и намертво
единственный выход юзать fusedav http://rec.data-flow.ru/articles/2014/1/fusedav-in-fstab.html

Оффлайн Devolutheist

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Мало того, что я нуб, так я еще и некромант.

При помощи мануала таки удалось смонтировать раздел с ЯД. Читать файлы со смонтированного отдела может любой встречный и поперечный пользователь, а вот менять что-то, можно только под суперюзером, так и с Наутилусом. Если из под gksu захожу можно и редактировать файлы и добавлять новые. Чуть подтормаживает, но это не так страшно. И демонтировать раздел не всегда получается. umount ругается, мол, занято устройство, даже с флагом -f не дает отключить раздел.

Оффлайн vkapas

  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Devolutheist, попробуйте в fstab добавить ключ user.

У меня в системе с одним пользователем («user») работало вот так:
https://webdav.yandex.ru:443 /media/Yandex.Disk           davfs   user,uid=user,gid=user,rw,_netdev 0       0Правда в последствие от ключа user пришлось всё-таки отказаться — из-за него некорректно работал rsync (отдавал ошибку failed to set permissions).

Оффлайн Devolutheist

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Devolutheist, попробуйте в fstab добавить ключ user.

У меня в системе с одним пользователем («user») работало вот так:
https://webdav.yandex.ru:443 /media/Yandex.Disk           davfs   user,uid=user,gid=user,rw,_netdev 0       0Правда в последствие от ключа user пришлось всё-таки отказаться — из-за него некорректно работал rsync (отдавал ошибку failed to set permissions).

Вот что сейчас у меня имеется в fstab:

https://webdav.yandex.ru:443 /media/YandexDrive davfs user,rw,noauto 0 1

Разве uid и gid не числовые переменные?

Оффтоп: здесь всегда такой анти-спам стоял жуткий? Или это только для тех у кого сообщений немного?

Добавил uid и gid в числовых значениях, заработало. Спасибо. Но почему в мануале то про GID и UID не написано?
« Последнее редактирование: 03 Март 2017, 12:16:17 от Devolutheist »

Оффлайн vkapas

  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
Разве uid и gid не числовые переменные
У меня заработало так. У вас указание текстом не сработало?

Оффтоп: здесь всегда такой анти-спам стоял жуткий? Или это только для тех у кого сообщений немного?
М.б. IP спамный? Я не припомню капч или других защит, тем более зверских, даже в самом начале после регистрации.

Оффлайн Devolutheist

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Разве uid и gid не числовые переменные
У меня заработало так. У вас указание текстом не сработало?

Нет, сработало только с циферками. Спасибо еще раз, в мануале не нашел строчки подобной, в целом понятно для чего это, но не понятно, почему без этой записи не работает. А если мне надо группе дать доступ? По логике вещей:

https://webdav.yandex.ru:443 /media/YandexDrive davfs group,gid=1001,rw,noauto 0 1

Не так ли?

Оффтоп: здесь всегда такой анти-спам стоял жуткий? Или это только для тех у кого сообщений немного?
М.б. IP спамный? Я не припомню капч или других защит, тем более зверских, даже в самом начале после регистрации.

Оффтоп: Не знаю, возможно, живу в глуши сижу с местного мелкого провайдера за NAT может и сыпется отсюда что-то. Но у меня для отправки каждого сообщения требует капчу победить и ответить на три вопроса.

Оффлайн eNdiD

  • Участник
  • *
  • Сообщений: 188
    • Просмотр профиля
Пробую настроить Deja Dup для яндекса. Вот так заполняю:



Но при нажатии на кнопку "создать резервную копию" получаю ошибку:



Печально.

Ubuntu 16.04.2
Версия deja-dup: 34.2
« Последнее редактирование: 19 Март 2017, 18:19:07 от eNdiD »

Оффлайн Absalon

  • Активист
  • *
  • Сообщений: 250
    • Просмотр профиля
eNdiD, а если галку снять с HTTPS?

Оффлайн eNdiD

  • Участник
  • *
  • Сообщений: 188
    • Просмотр профиля
ZloyTeHb, пробовал - ничего не дало. Но вот что странно: я поставил сохранение копий в резервную папку - выдало ту же ошибку (как так?). Потом вернул обратно на webdav и процесс пошел. Магия, не иначе. Я абсолютно уверен, что оба раза вводил одно и то же.

Но блин, какой-то он тугой. Я пол дня пытаюсь сделать бэкап. Сначала он загрузил несколько архивов и потом все удалил и начал загружать заново. Потом произошел сбой и загрузка началась по новой. А затем я оставил ноут и он перешел в ждущий режим. Результат: опять все заново. Никакой проверки уже загруженного не делается, получается. Бэкап либо сделан полностью, либо не сделан. В общем, мне не подходит. Я не могу весь день ждать, пока загрузятся мои ~20 Гб и не отходить от машины. И не факт, что все пройдет успешно. Он еще и мои папки продублировал отчего-то. Которые нужно бэкапить. В любом случае есть ощущение очень сырого продукта.

Буду альтернативы искать. Проще уже rsync в крон закинуть.

UPD. Да, тормозит оно жутко. Пробую через rsync синхронизировать свои файлы - это что-то. В момент отправки большого файла ФС зависает намертво, так что даже ls ничего не может показать. При этом, открытые программы работают нормально. Нагрузки на ЦП нет, и что странно - iotop не показывает практически никакой существенной IO активности. Только фоновая работа системы (торренты, вот это все). Индикатор накопителя на корпусе так же вяло мигает.

Так что, это вообще не вариант.

Вот такая вот засада.
« Последнее редактирование: 20 Март 2017, 00:58:12 от eNdiD »

 

Страница сгенерирована за 0.124 секунд. Запросов: 23.