Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: После обновления не работает и не ставится VLC media player и Sopcast player  (Прочитано 1055 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ferret

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Сегодня утром пришло 4 важных обновления. Во время их установки было заявлено, что некоторые пакеты устарели и их можно удалить. После перезагрузки удалился vlc и sopcast player. При попытке переустановить vlc выдает ошибки о неразрешимых зависимостях. Ставить пытался через Центр приложений, консоль и позже установил Synaptic.

Ответ Центра приложений: Зависимости пакета не могут быть разрешены.
Следующие пакеты имеют неудовлетворённые зависимости:

vlc: Depends: fonts-freefont-ttf но он не будет установлен
     Depends: vlc-nox (= 2.0.3+git20121005+r392-0~r42~precise1) но 2.0.3+git20121005+r392-0~r42~precise1 должен быть установлен
     Depends: libavcodec-extra-53 (>= 4:0.8-1~) но 4:0.8.3ubuntu0.12.04.1 должен быть установлен
     Depends: libavutil-extra-51 (>= 4:0.8-1~) но 4:0.8.3ubuntu0.12.04.1 должен быть установлен
     Depends: libc6 (>= 2.15) но 2.15-0ubuntu10.2 должен быть установлен
     Depends: libfreetype6 (>= 2.2.1) но 2.4.8-1ubuntu2 должен быть установлен
     Depends: libgcc1 (>= 1:4.1.1) но 1:4.6.3-1ubuntu5 должен быть установлен
     Depends: libqtcore4 (>= 4:4.8.0) но 4:4.8.1-0ubuntu4.2 должен быть установлен
     Depends: libqtgui4 (>= 4:4.7.0~beta1) но 4:4.8.1-0ubuntu4.2 должен быть установлен
     Depends: libstdc++6 (>= 4.6) но 4.6.3-1ubuntu5 должен быть установлен
     Depends: zlib1g (>= 1:1.2.3.3.dfsg) но 1:1.2.3.4.dfsg-3ubuntu4 должен быть установлен

Ответ синаптика

Тут видно, что vlc-nox вроде как установлен.

Ответ консоли:
ferret@Ferret:~$ sudo apt-get install vlc
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 vlc : Зависит: fonts-freefont-ttf но он не может быть установлен
       Рекомендует: vlc-plugin-notify (= 2.0.3+git20121005+r392-0~r42~precise1) но он не будет установлен
       Рекомендует: vlc-plugin-pulse (= 2.0.3+git20121005+r392-0~r42~precise1) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Еще я пробовал удалять через консоль, но vlc нету:
ferret@Ferret:~$ sudo apt-get remove vlc
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет vlc не установлен, поэтому не может быть удалён
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.


Ну, а sopcast в свою очередь ссылается на то, что без vlc он не работает. Собственно вопрос: "Что делать?"
« Последнее редактирование: 06 Октябрь 2012, 12:44:43 от Ferret »

Оффлайн ArcFi

  • Заслуженный пользователь
  • Герой
  • *
  • Сообщений: 14236
    • Просмотр профиля
    • aetera.net
Ferret, если пользуетесь оф. репами, то надо откатывать обновление.
Ставить более раннюю версию пакета, для которой есть все необходимые зависимости.
Ждать, пока новые версии зависимостей попадут в репы.
Если у вас есть левые репы с конфликтующими зависимостями, то их лучше отключить.

Оффлайн Ferret

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Если у вас есть левые репы с конфликтующими зависимостями, то их лучше отключить.

Да, был левый репозиторий с Sopcast player после отключения которого установился vlc. Затем была найдена рабочая альтернатива сопкасту (TV-MAXE). Спасибо за помощь.

Оффлайн CyrusEugene

  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
Премного благодарю за то, что пролили свет на решение данной проблемы ::) Сам сегодня с подобной проблемой столкнулся, только разница в том, что VLC обновился аж до 2.1.0 и перестал запускаться вовсе. Я предположил, что причиной был добавленный репозиторий ppa:videolan/master-daily, удалил его, также удалил и поставил снова репозиторий ppa:videolan/stable-daily. Но проблема этим не решилась - при попытке установки VLC любым способом показывались ошибки, смысл которых состоял в том, что должен быть установлен 2.1.0. Попробовал отключать репозитории в источниках приложений (вкладка "Другое ПО", даже все отключал там), но эта ошибка не уходила. Тогда "методом тыка" попробовал в синаптике удалить пакеты VLC с индексом 2.1.0 и после этого смог установить VLC через центр приложений (оставив в источниках приложений галку только напротив репозитория ppa:videolan/stable-daily/ubuntu precile main и восстановив все галки как было после решения проблемы).

 

Страница сгенерирована за 0.537 секунд. Запросов: 21.