Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Viber для Linux  (Прочитано 93287 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sevnixguru

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Viber для Linux
« Ответ #240 : 20 Ноябрь 2017, 10:20:21 »
Что в новой версии не могу уменьшить масштаб методом как в старой, через config.db.
Аналогично. Есть у кого старая версия? Поделитесь, пожалуйста. (

Оффлайн minuser

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Viber для Linux
« Ответ #241 : 22 Ноябрь 2017, 12:24:42 »
Присоединяюсь... А то никакого решения пока нет а работать невозможно  :-\

Оффлайн vig-vig

  • Любитель
  • *
  • Сообщений: 89
    • Просмотр профиля
Re: Viber для Linux
« Ответ #242 : 22 Ноябрь 2017, 13:34:39 »
Запуск строкой: env QT_SCREEN_SCALE_FACTORS=0.7 /opt/viber/Viber %u &
помогает, но как то не всегда. Иногда надо полностью перезагружать систему, что бы сработал строка.

Оффлайн minuser

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Viber для Linux
« Ответ #243 : 22 Ноябрь 2017, 14:33:45 »
Запуск строкой: env QT_SCREEN_SCALE_FACTORS=0.7 /opt/viber/Viber %u &
Спасибо большое! На 16.04 сработало :)

Оффлайн Cruelty398

  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Viber для Linux
« Ответ #244 : 24 Ноябрь 2017, 20:39:46 »
Аналогично. Есть у кого старая версия? Поделитесь, пожалуйста. (
[/quote]
Есть. Лови. https://yadi.sk/d/6fFOlCbL3PzyuJ

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 1735
    • Просмотр профиля
Re: Viber для Linux
« Ответ #245 : 25 Ноябрь 2017, 10:34:21 »
Приветствую, коллеги.

Кто-нибудь пробовал устанавливать и затем пользовать Viber 7.0.0.1035 на Ubuntu 14.04 ?

Я вот попробовал...
Установить таки получилось, но только по sudo dpkg -i viber.deb, т.к. ни Центр приложений, ни Gdebi с этой задачей не справились (с их точки зрения - пакет не deb)

А вот с использованием не сложилось... не запускается эта версия на Ubuntu 14.04, при запуске из терминала, ругается:$ /opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Location.so.5)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicui18n.so.52)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicuuc.so.52)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5WebEngineCore.so.5)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5Qml.so.5)
/opt/viber/Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Core.so.5)
...пакеты libstdc++6 и libstdc++6:i386 установлены, как впрочем и все libQt5*

Может кто знает(нашел) решение, поделитесь  :)

Оффлайн z-user

  • Активист
  • *
  • Сообщений: 596
  • Ubuntu User
    • Просмотр профиля
Re: Viber для Linux
« Ответ #246 : 25 Ноябрь 2017, 11:04:55 »
Может кто знает(нашел) решение, поделитесь
Я решил возвратом на старую версию ... при чем скачал с официального сайта через сервис ВебАрхив.
https://web.archive.org/

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 1735
    • Просмотр профиля
Re: Viber для Linux
« Ответ #247 : 25 Ноябрь 2017, 11:27:31 »
Я решил возвратом на старую версию
- дык, я Ж тоже сейчас на 14.04 пользую 6.5.5(которую, кстати казать, тут почемуто рассматривали исключительно как версию для 16.04), но хочется таки актуальную... но и отказываться от OEM-версии Ubuntu тоже както не хочется ::)

Оффлайн NickCool

  • Новичок
  • *
  • Сообщений: 8
  • Ubuntu 14.04
    • Просмотр профиля
Re: Viber для Linux
« Ответ #248 : 07 Январь 2018, 17:03:10 »
Я решил возвратом на старую версию
- дык, я Ж тоже сейчас на 14.04 пользую 6.5.5(которую, кстати казать, тут почемуто рассматривали исключительно как версию для 16.04), но хочется таки актуальную... но и отказываться от OEM-версии Ubuntu тоже както не хочется ::)
Мне помог совет из ubuntuforums. org/showthread.php?t=2380320

Код: Bash
  1. sudo add-apt-repository ppa:ubuntu-toolchain-r/test
  2. sudo apt update
  3. sudo apt install gcc-4.9
  4. sudo apt install libstdc++6

Затем при
Код: Bash
  1. strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX_3.4

Должно вывести следующее (больше версии 3.4.19):
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_3.4.21
GLIBCXX_3.4.22
GLIBCXX_3.4.23
GLIBCXX_3.4.24

 

Страница сгенерирована за 0.176 секунд. Запросов: 23.