Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: установка LAMP на Ubuntu 16.04 (обсуждение публикации)  (Прочитано 10390 раз)

0 Пользователей и 1 Гость просматривают эту тему.

surfer

  • Автор темы
  • Гость
« Последнее редактирование: 09 Май 2016, 13:58:36 от surfer »

Оффлайн MAlexey

  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
За инструкцию спасибо!
Пригодится в ближайшее время.

Вы наверное привыкли к Apt-get, а Ubuntu 16 понимает более короткое написание - Apt

Цитировать
Apt-get можете использовать и дальше, но начинайте переходить на команду apt. Apt понимает все ключи, что вы использовали ранее с apt-get, но умеет ещё больше. То есть можно использовать apt install вместо apt-get install и apt search вместо apt-cache search. Грубо говоря, не нужно запоминать множество команды apt-* и у кого какие есть ключи.
Почему для Linux мало вирусов? Бессмысленная затея писать вирус для Linux - он как и половина программ перестаёт работать после установки очередного обновления :)

surfer

  • Автор темы
  • Гость
За инструкцию спасибо!
Пригодится в ближайшее время.

Вы наверное привыкли к Apt-get, а Ubuntu 16 понимает более короткое написание - Apt

Цитировать
Apt-get можете использовать и дальше, но начинайте переходить на команду apt. Apt понимает все ключи, что вы использовали ранее с apt-get, но умеет ещё больше. То есть можно использовать apt install вместо apt-get install и apt search вместо apt-cache search. Грубо говоря, не нужно запоминать множество команды apt-* и у кого какие есть ключи.
спасибо, что-то я упустил этот момент, надо будет подправить

Оффлайн gavarus

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Добрый день
установка модуля apache2-mpm-itk
вызывает вопросы
он не ставиться даже если
a2dismod mpm_event
apt-get install -f

surfer

  • Автор темы
  • Гость
Добрый день
установка модуля apache2-mpm-itk
вызывает вопросы
он не ставиться даже если
a2dismod mpm_event
apt-get install -f
что пишет? какая версия Ubuntu?
если в 16.04 надо ставить libapache2-mpm-itk
http://packages.ubuntu.com/xenial/libapache2-mpm-itk

Оффлайн gavarus

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
спасибо за подсказку. попробую отпишусь
для phpmyadmin
если не запускается, то нужно применить
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo /etc/init.d/apache2 reload
помогает.
В предудыщих сборках, как только вышел 16.04-мне имено эти помогло, сейчас встало без этой записи...
========
libapache2-mpm-itk
помог, Спасибо
« Последнее редактирование: 26 Май 2016, 17:25:23 от gavarus »

Оффлайн WAYFARER1987

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Подскажите, а как установить с php5.6?

surfer

  • Автор темы
  • Гость
Подскажите, а как установить с php5.6?
подключить старые репозитории и из них поставить 5.6

Оффлайн gavarus

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Подскажите, а как установить с php5.6?
sudo apt purge `dpkg -l | grep php| awk '{print $2}' |tr "\n" " "`
sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt install php5.6 libapache2-mod-php5.6 php5.6-mcrypt php5.6-mysql
=======
но это не выход..
phpmyadmin все равно подставляет 7 версию...соотвествено показывает белую страницу..
надо и phpmyadmin более старую версию ставить
« Последнее редактирование: 17 Июнь 2016, 14:42:12 от gavarus »

Оффлайн kuld

  • Любитель
  • *
  • Сообщений: 71
    • Просмотр профиля
Не ставится PHP7. Система почти чистая, из сторонних репозториев только http://ppa.launchpad.net/webupd8team/java/ubuntu
Делаю sudo apt install php libapache2-mod-php php-mcrypt php-mysql
(Нажмите, чтобы показать/скрыть)

Последовательность никакой роли не играет, можно ставить пакеты php  php-mcrypt php-mysql, можно не ставить, результат будет один:
Цитировать
dpkg: зависимости пакетов не позволяют настроить пакет libapache2-mod-php:
 libapache2-mod-php зависит от libapache2-mod-php7.0, однако:
  Пакет libapache2-mod-php7.0 пока не настроен.

Что не так?

Оффлайн n2011all

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
В дополнение детали по мускулу
Начиная с Ubuntu 16.04  - в связи с тем, что в мускуле теперь защищенный режим включен по дефолту
для работы многих вебприложений надо изменить конфигурацию mysql-сервера версии 5.7
Подробно суть вопроса описана на этом ресурсе
https://laravel.ru/posts/357
В файле /etc/mysql/mysql.conf.d/mysqld.cnf
в строке
sql_mode=NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUB... итак далеемне хватило отключение  этих двух опции
-STRICT_TRANS_TABLES
-ONLY_FULL_GROUP_BY
после этого работают множество распространенных вебприложений (например piwigo glpi и т.п.)

Оффлайн rusbal

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
В линуксе я новичок и прошу помощи. Установил сначала 14.04 server, все установил точно по инструкции
 http://help.ubuntu.ru/wiki/lamp_на_ubuntu_server_16.04, после этого установил еще
 ffmpeg gpak mediainfo, phpmyadmin не устанавливал а просто скопировал с другого компа.
 При попытке установить сайт clipbucket 2.8.3 он встал криво, ничего не работало, я снес его и
 установил снова, встал нормально но не принял мой юзер и пароль. После изучения проблемы я обнаружил
 что в базе отсутствуют некоторые таблицы, я скопировал недостающие таблицы с другого компа и сайт
 заработал. При попытке установить DLE работает только первая страница, меню сайта не работает,
 на другом компе с windows и appserv все эти скрипты работают нормально.
 Подскажите кто нибудь, в чем может быть проблема, где искать ?

 

Страница сгенерирована за 0.126 секунд. Запросов: 23.