Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не запускается phatch  (Прочитано 448 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн StarCor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Не запускается phatch
« : 17 Октябрь 2016, 14:32:12 »
Здравствуйте, коллеги!
Перестал запускаться phatch :( Зависает на картинке глазика с шестеренкой. В системном мониторе процесс висит, но ничего не происходит. Пробовал полное удаление и переустановку, но не помогло.
Может быть не только у меня такие проблемы? Кто-то уже решил?
Ubuntu 16.04.1 LTS 64-бит

Оффлайн Constantinero

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
    • dt3.ru
Re: Не запускается phatch
« Ответ #1 : 27 Октябрь 2016, 12:55:43 »
в Ubuntu 16.04

Лечится относительно просто.
Выполнить в терминале sudo gedit /usr/share/phatch/phatch/lib/pyWx/wxPil.py
Заменить в этом файле все строки "fromstring" на "frombytes" и все "tostring" на "tobytes".
Сохранить, закрыть gedit.
Запустить phatch.

Оффлайн StarCor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: Не запускается phatch
« Ответ #2 : 28 Октябрь 2016, 13:10:48 »
Спасибо! Заработало!

Оффлайн BSB

  • Участник
  • *
  • Сообщений: 239
  • Сама Справедливость
    • Просмотр профиля
Re: Не запускается phatch
« Ответ #3 : 01 Октябрь 2017, 22:36:22 »
Они снова его сломали!
Ошибки:
/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py:8196: GtkWarning: gtk_disable_setlocale() must be called before gtk_init()
  return _core_.PyApp__BootstrapApp(*args, **kwargs)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 16765, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/share/phatch/phatch/pyWx/gui.py", line 1218, in show_frame
    frame = Frame(self.filename, None, -1, ct.TITLE)
  File "/usr/share/phatch/phatch/pyWx/gui.py", line 327, in __init__
    frame.Frame.__init__(self, *args, **keyw)
  File "/usr/share/phatch/phatch/pyWx/wxGlade/frame.py", line 141, in __init__
    self.tree = Tree(self, -1, style=wx.TR_HAS_BUTTONS|wx.TR_NO_LINES|wx.TR_FULL_ROW_HIGHLIGHT|wx.TR_HIDE_ROOT|wx.TR_DEFAULT_STYLE|wx.SUNKEN_BORDER)
  File "/usr/share/phatch/phatch/pyWx/wxGlade/frame.py", line 26, in __init__
    set_dirty   = parent.set_dirty,
  File "/usr/share/phatch/phatch/lib/pyWx/treeEdit.py", line 96, in __init__
    self.CreateImageList(icon_size)
  File "/usr/share/phatch/phatch/lib/pyWx/treeEdit.py", line 111, in CreateImageList
    self._AddFormToImageList(form, icon_size, icon_disabled)
  File "/usr/share/phatch/phatch/lib/pyWx/treeEdit.py", line 120, in _AddFormToImageList
    wx_image = pil_wxImage(wxImage_pil(wx_image).resize(icon_size,\
  File "/usr/share/phatch/phatch/lib/pyWx/wxPil.py", line 45, in wxImage_pil
    image = Image.new('RGB', size)
  File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 2051, in new
    _check_size(size)
  File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 2027, in _check_size
    raise ValueError("Size must be a tuple")
ValueError: Size must be a tuple
(Ubuntu 17.04)

 

Страница сгенерирована за 0.1 секунд. Запросов: 24.