Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установка Wine под Xubuntu 16.04 - проблемы с зависимостями  (Прочитано 1763 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ARTGALGANO

  • Старожил
  • *
  • Сообщений: 1034
    • Просмотр профиля

это всё???
подключайте основные репы
настройки--> программы и обновления--> 1вкладка
(ток не добавляйте proposed)
и реп вайна куде делся? подключайте снова, и апдейт-апгрейд, инсталл вайн.

« Последнее редактирование: 05 Февраль 2017, 15:21:31 от ARTGALGANO »

Оффлайн Arbaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
это всё???
подключайте основные репы
настройки--> программы и обновления--> 1вкладка

ARTGALGANO, Большое спасибо за помощь, но после пары дней ковыряний прийдется сознаться в своем окончательном нубизме.
Вот первая вкладка:
(Нажмите, чтобы показать/скрыть)
Вот вторая:
(Нажмите, чтобы показать/скрыть)

Я заменил Украинский главный репозиторий на USA-шный, ставил галочку на разрешение загрузки софта canonical partners, но
вот где найти "основные репы" и как понять что из них безопасно подключать, а что нет нагуглить никак не получается -
везде говорят, что основные репы на которых лежит безопасный код соответствующий сорцам это(ну и локали):
http://archive.ubuntu.com/ubuntu xenial main restricted
http://archive.ubuntu.com/ubuntu xenial universe
http://archive.ubuntu.com/ubuntu xenial multiverse

Пробовал искать что такое "proposed"-репозитории и что такое не "proposed"-репозитории, тоже не могу нагуглить список
не "proposed" репозиториев, который если не через GUI, то хотя-бы вручную можно было бы подключить - везде все
подкючают только нужные им репозитории по одной штуке - типа как мы Вайновский репозиторий подключаем.

Ещё раз извиняюсь за свой нубизм и ещё раз спасибо за помощь.

 
« Последнее редактирование: 08 Февраль 2017, 14:00:57 от Arbaz »

Оффлайн Morisson

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 2448
    • Просмотр профиля
Arbaz, Canonical Partners отметьте.
И пробуй установить просто:
sudo apt install wine
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad / XFCE4+Compiz; ядро: linux-zen

Оффлайн Arbaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Morisson,
спасибо за совет - уже пробовал - упираюсь в ту же "лапшу зависимостей", что и в самом начале:
wine требует wine1.6, который требует wine1.6-i386, который требует вот этот ужас(каждый компонент которого требует что-то ещё):
The following packages have unmet dependencies:
 wine1.6-i386:i386 : Depends: libglu1-mesa:i386 but it is not going to be installed or
                              libglu1:i386
                     Depends: libgphoto2-6:i386 (>= 2.5.9) but it is not going to be installed
                     Depends: libgphoto2-port12:i386 (>= 2.5.9) but it is not going to be installed
                     Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                     Depends: libxml2:i386 (>= 2.9.0) but it is not going to be installed
                     Recommends: libasound2-plugins:i386 but it is not going to be installed
                     Recommends: libcups2:i386 but it is not going to be installed
                     Recommends: libdbus-1-3:i386 but it is not going to be installed
                     Recommends: libfontconfig1:i386 but it is not going to be installed or
                                 libfontconfig:i386
                     Recommends: libgnutls30:i386 but it is not going to be installed
                     Recommends: libosmesa6:i386 but it is not going to be installed
                     Recommends: libpulse0:i386 but it is not going to be installed
                     Recommends: libsane:i386 but it is not going to be installed
                     Recommends: libxslt1.1:i386 but it is not going to be installed
                     Recommends: libxt6:i386 but it is not going to be installed
                     Recommends: p11-kit-modules:i386 but it is not going to be installed
 

Оффлайн Morisson

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 2448
    • Просмотр профиля
1) ты обновился, как галочку поставил.
2) подключи 32-х битные библиотеки
sudo dpkg --add-architecture i386sudo apt-get updateТ.е. Сначала либы добавь, потом обновись
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad / XFCE4+Compiz; ядро: linux-zen

Оффлайн Arbaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Да, обновился и подключил 32-х битные библиотеки.
на всякий случай проделал все заново - эффект тот же. :(

Оффлайн ARTGALGANO

  • Старожил
  • *
  • Сообщений: 1034
    • Просмотр профиля
Arbaz,
что -то не то совсем
arch
sudo dpkg --print-foreign-architectures
apt search wine1.*
можно попробовать поставить из основного репа вайна,


Оффлайн Arbaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
ARTGALGANO,
Выдает следующее:
x86_64
i386
Sorting... Done
Full Text Search... Done
wine1.4/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (dummy package)

wine1.4-amd64/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (dummy package)

wine1.4-dbg/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (dummy package)

wine1.4-dev/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (dummy package)

wine1.4-i386/xenial 1:1.6.2-0ubuntu14 i386
  Microsoft Windows Compatibility Layer (dummy package)

wine1.6/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (Binary Emulator and Library)

wine1.6-amd64/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (64-bit support)

wine1.6-dbg/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (debugging symbols)

wine1.6-dev/xenial 1:1.6.2-0ubuntu14 amd64
  Microsoft Windows Compatibility Layer (Development files)

wine1.6-i386/xenial 1:1.6.2-0ubuntu14 i386
  Microsoft Windows Compatibility Layer (32-bit support)

Оффлайн ARTGALGANO

  • Старожил
  • *
  • Сообщений: 1034
    • Просмотр профиля
немного расширим поиск
apt search wineи если попробовать поставить   1.6?
apt install wine1.6

Оффлайн Arbaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
ARTGALGANO,
apt search wine выдает вот это:
(Нажмите, чтобы показать/скрыть)

apt install wine1.6 выдает вот это:
(Нажмите, чтобы показать/скрыть)

Т.е. те же проблемы с зависимостями "wine1.6-i386" и "fonts-droid", которые были раньше

« Последнее редактирование: 10 Февраль 2017, 13:56:25 от Arbaz »

Оффлайн ARTGALGANO

  • Старожил
  • *
  • Сообщений: 1034
    • Просмотр профиля
идеи закончились у меня, при том, что на чистой ОС все норм.
еще вариант отключить поддержку i386
sudo dpkg --remove-architecture i386

Оффлайн Arbaz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Всем спасибо за советы и помощь - наконец-то решил проблему, правда "методом тыка".
Проблема решилась очень по-дурацки, когда все солюшены "из интернета" кончились - пошёл втупую тыкать на все варианты настроек в Settings->Software and Updates включая и отключая их.
1. На третьей вкладке отменил галочки(они были включены с момента установки Xubunt-ы):
  "Important security updates"
  "Recommended updates"
  "Unsupported updates"
2. Применил эти изменения - проблема осталась.
3. Заново включил эти 3 галочки, применил опять эти изменения - и вуаля всё с полпинка заработало.

Ещё раз спасибо за помощь и за терпение с объяснениями, потому как когда оно так легко работает и тянет километры зависимостей без проблем пытаться понять почему о очередного нуба оно так по-дурацки кривит и косит нужно много терпения.

P.S. Всем у кого проблемы с unmet-зависимостями рекомендую прочесть эту ветку, в ней очень много солюшенов:
http://askubuntu.com/questions/140246/how-do-i-resolve-unmet-dependencies-after-adding-a-ppa

 

Страница сгенерирована за 0.172 секунд. Запросов: 23.