Форум русскоязычного сообщества Ubuntu


Автор Тема: LTSP клиент и hp-setup (hp-plugin), Сканер на толстом ltsp клиенте  (Прочитано 337 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dilo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Доброго времени суток.
Возможно мой вопрос покажется глупым, но перепробовав множество вариантов и статей не к чему прийти не смог. Пытаюсь развернуть ltsp сервер с толстыми клиентами.

Установлена lubuntu 16.04.2 (amd64) как сервер и толстые клиенты на той же оболочке(i386 и amd64).
К некоторым клиентам подключены mfp от HP(пример HP Pro m1132 mfp). Принтеры проброшены и вопросов нет, но как быть со сканером? =)Для работы сканера требуется установить hp-plugin.
Если hp-plugin установить на ЗАПУЩЕННОМ клиенте то всё начинает работать и ошибок при установке нет, но после перезагрузки клиента измненения сбрасываются.
Если устанавливать hp-plugin в примонтированом образе то вываливаются ошибки:
sudo ltsp-chroot --arch i386
cd tmp/
wget https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.16.3-plugin.run
wget https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.16.3-plugin.run.asc
hp-plugin -i -g

HP Linux Imaging and Printing System (ver. 3.16.3)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: It is not recommended to run 'hp-plugin' in a root mode.

HP Linux Imaging and Printing System (ver. 3.16.3)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

hp-plugin[7527]: debug: Locking: /var/hp-plugin.lock
error: PolicyKit support requires DBUS or PolicyKit support files missing
hp-plugin[7527]: debug: Unable to open file /var/lib/hp/hplip.state for reading.
hp-plugin[7527]: debug: Unable to open file /var/lib/hp/hplip.state for reading.
(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


-----------------------------------------
| PLUG-IN INSTALLATION FOR HPLIP 3.16.3 |
-----------------------------------------

  Option      Description                                       
  ----------  --------------------------------------------------
  d           Download plug-in from HP (recommended)           
  p           Specify a path to the plug-in (advanced)         
  q           Quit hp-plugin (skip installation)               

Enter option (d=download*, p=specify path, q=quit) ? p       
Enter the path to the 'hplip-3.16.3-plugin.run' file (q=quit) :

---------------
| COPY PLUGIN |
---------------

Downloading plug-in from: file:///tmp/hplip-3.16.3-plugin.run
Downloading plug-in: [\                                                                                                                                                                                             ] 0%     hp-plugin[7527]: debug: Unable to open file installer/distros.dat for reading.
hp-plugin[7527]: debug: []
100%hp-plugin[7527]: debug: File error page score: 0.000000
100%hp-plugin[7527]: debug: File error page score: 0.000000
hp-plugin[7527]: debug: Validating /home/dmitriy/.hplip/hplip-3.16.3-plugin.run with /home/dmitriy/.hplip/hplip-3.16.3-plugin.run.asc signature file
Receiving digital keys: /usr/bin/gpg --homedir /home/dmitriy/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
hp-plugin[7527]: debug:

error: Unable to recieve key from keyserver
Do you still want to install the plug-in? (y=yes, n=no*, q=quit) ? y
----------------------
| INSTALLING PLUG-IN |
----------------------

Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.16.3 Plugin Self Extracting Archivedf: Предупреждение: не удалось прочитать таблицу смонтированных файловых систем: Нет такого файла или каталога
................................................

HP Linux Imaging and Printing System (ver. 3.16.3)
Plugin Installer ver. 3.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.16.3
Installed HPLIP version: 3.16.3
Number of files to install: 42

You must agree to the license terms before installing the plug-in:
................

Do you accept the license terms for the plug-in (y=yes*, n=no, q=quit) ? y
Plugin installation failed
error: Plugin installation failed

Done.
hp-plugin[7527]: debug: Removing ./plugin_tmp cmd = rm -rf ./plugin_tmp
hp-plugin[7527]: debug: Failed to remove=./plugin_tmp
hp-plugin[7527]: debug: Cache miss: hp_laserjet_professional_m1212nf_mfp
hp-plugin[7527]: debug: Reading file: /usr/share/hplip/data/models/models.dat
hp-plugin[7527]: debug: Searching for section [hp_laserjet_professional_m1212nf_mfp] in file /usr/share/hplip/data/models/models.dat
hp-plugin[7527]: debug: Found section [hp_laserjet_professional_m1212nf_mfp] in file /usr/share/hplip/data/models/models.dat
hp-plugin[7527]: debug: Cache miss: hp_laserjet_professional_m1214nfh_mfp
hp-plugin[7527]: debug: Reading file: /usr/share/hplip/data/models/models.dat
hp-plugin[7527]: debug: Searching for section [hp_laserjet_professional_m1214nfh_mfp] in file /usr/share/hplip/data/models/models.dat
hp-plugin[7527]: debug: Found section [hp_laserjet_professional_m1214nfh_mfp] in file /usr/share/hplip/data/models/models.dat
hp-plugin[7527]: debug: Exception: 4 (Unknown/invalid device-uri field)

Done.
hp-plugin[7527]: debug: Unlocking: /var/hp-plugin.lock


Пробую на образе i386
Подозрение что при ltsp-chroot не все монтируется.
Подскажите как грамотно установить hp-plugin в образ.
Заранее спасибо.

Оффлайн oS_a

  • Участник
  • *
  • Сообщений: 202
    • Просмотр профиля
Подожди. По моему сканирование стоит запускать при помощи sane? У sane есть определенные модели которые поддерживаются. Если твоей модели там нет - 99% вероятность того что твой не заведется.
/usr/share/doc/ltsp/LTSPManual.html - Нормальный мануал, посмотри может там что то есть.
А так на сколько помню - в конфиге lts.conf надо указать на каком терминале сканер публикуется. И при помощи sane на терминальном сервере этот сканер отлавливать.
P.s. я бы не стал hp-plugin в образ вмонтировать)
« Последнее редактирование: 03 Март 2017, 18:03:11 от oS_a »

Оффлайн Dilo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Да, работа со сканером также через sane. Sane его видит, но при попытке распечатать выдаёт ошибку ввода вывода. В интернете натыкался на статью что сканеры hp работают "по своему" и просто sane с ними не справляется. Требуется дорабатывать напильником. Везде пишут что напильник это дравишки от hp (hp-setup). Удалось выяснить что из всего ПО hp достаточно запустить "напильник" hp-plugin (при условии что установлено hplip). Ну а далее ступор :(
Конечно мне также не хочется утяжелять образ всяким мусором, но что именно делает hp-plugin для исправления выяснить не удалось.
Публиковать сканер не требуется. Пусть работает хотя бы на пк к которому подключен.
В целом, после запуска толстого клиента и установки hp-plugin  на без дисковой машине всё начитает работать, но до перезагрузки :(
Больше идей как решить не нашёл, решил спросить.

Оффлайн Vened

  • Участник
  • *
  • Сообщений: 160
    • Просмотр профиля
Удалось победить проблему?

 

Страница сгенерирована за 0.173 секунд. Запросов: 23.