Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: [Решено] virtualbox 5.0.36 и virtualbox 5.1.18  (Прочитано 380 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Виктор Перестукин

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2106
    • Просмотр профиля
[Решено] virtualbox 5.0.36 и virtualbox 5.1.18
« : 20 Март 2017, 09:06:26 »
Будет ли выпущен какой нибудь пакет со скриптом, который позволит сменить версии или всё надо самому делать?

PS
Предлагает скачать версию 5.1.18, скачал, но при установке ошибка. Не привожу здесь, потому что читал на сайте virtualbox, что версии не совместимы и требуются определённые действия для установки 5.1.18.
« Последнее редактирование: 20 Март 2017, 11:10:19 от Виктор Перестукин »

Оффлайн Vikonrob

  • Участник
  • *
  • Сообщений: 245
    • Просмотр профиля
Re: virtualbox 5.0.36 и virtualbox 5.1.18
« Ответ #1 : 20 Март 2017, 10:06:48 »
Если виртуалбокс установлен правильно, по всем рекомендациям с сайта виртуалбокс, то никаких дополнительных действий для установки версии 5.1 не требуется. Просто командой
sudo apt install virtualbox-5.1ставится новая версия, которая в свою очередь удаляет старую, подхватывая при этом все виртуальные машины со старой версии.

Оффлайн Виктор Перестукин

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2106
    • Просмотр профиля
Re: virtualbox 5.0.36 и virtualbox 5.1.18
« Ответ #2 : 20 Март 2017, 11:09:55 »
Спасибо, через терминал установил!

А вот с помощью dpkg не устанавливалась. Текст ошибки:
Цитировать
Ошибка: Конфликтует с установленным пакетом "virtualbox-5.0": 'virtualbox'. Но '/home/user/Загрузки/virtualbox-5.1_5.1.18-114002~Ubuntu~trusty_amd64.deb' доступен через 'virtualbox'

Оффлайн Vikonrob

  • Участник
  • *
  • Сообщений: 245
    • Просмотр профиля
Re: [Решено] virtualbox 5.0.36 и virtualbox 5.1.18
« Ответ #3 : 20 Март 2017, 11:15:45 »
А вот с помощью dpkg не устанавливалась. Текст ошибки:
В Ubuntu 16.04 \ 16.10 \ 17.04 скачанный .deb пакет можно устанавливать еще через apt:
sudo apt install /путь к пакету/пакет.debНо все же правильнее прописать репозитарий, ипортировать ключ, и ставить пакетным менеджером онлайн. (там и обновления виртуалбокса будут прилетать автоматом)

Оффлайн Виктор Перестукин

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2106
    • Просмотр профиля
Re: [Решено] virtualbox 5.0.36 и virtualbox 5.1.18
« Ответ #4 : 20 Март 2017, 11:31:43 »
Но у меня и подключён репозиторий Oracle. Я всё ждал, когда же он мне предложит обновиться до 5.1. Не предложил. :-\

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1257
  • ubuntu 16.04
    • Просмотр профиля
Re: [Решено] virtualbox 5.0.36 и virtualbox 5.1.18
« Ответ #5 : 20 Март 2017, 17:12:12 »
Обновлений между ветками нет.
Тоесть, если стоит 5.0.34, то она обновится до 5.0.36 и так далее. Но на 5.1 сама не побежит.
Так же сразу нельзя поставить 5.0 и 5.1 одновременно. Надо удалить, если стоит уже другая.
« Последнее редактирование: 20 Март 2017, 17:15:12 от soarin »

 

Страница сгенерирована за 0.106 секунд. Запросов: 23.