Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: bananapi m2+ & ubuntu+mysql=проблема  (Прочитано 489 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн myordo

  • Автор темы
  • Участник
  • *
  • Сообщений: 140
  • 12.04 LTS
    • Просмотр профиля
bananapi m2+ & ubuntu+mysql=проблема
« : 18 Июнь 2017, 10:20:18 »
Здравствуйте.есть банана пи м2+ надо накатить мускуль версии 5.5 собственно нашол деб пакет,пробую установить командой sudo dpkg -i  mysql-server-5.5_5.5.28+dfsg-1_armhf.deb ответ терминала:
dpkg: regarding mysql-server-5.5_5.5.28+dfsg-1_armhf.deb containing mysql-server-5.5, pre-dependency problem:
 mysql-server-5.5 pre-depends on mysql-common (>= 5.5.28+dfsg-1)
  mysql-common is not installed.

dpkg: error processing archive mysql-server-5.5_5.5.28+dfsg-1_armhf.deb (--install):
 pre-dependency problem - not installing mysql-server-5.5
Errors were encountered while processing:
 mysql-server-5.5_5.5.28+dfsg-1_armhf.deb

при установке apt-get install mysql-server-5.5 ответ:
root@bpi-iot-ros-ai:/home/pi/Downloads# apt-get install mysql-server-5.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mysql-server-5.5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  percona-xtradb-cluster-server-5.6 percona-server-server-5.6 mysql-testsuite-5.7
  mariadb-server-10.0 mysql-server-5.7 mysql-common

E: Package 'mysql-server-5.5' has no installation candidate

если ставить apt-get install mysql-server то накатывается версия 5.7 а нужна 5.5
собственно в линуксах не особо разбираюсь,компилировать из исходников не умею,подскажите простое решение для нуба.спс
вывод uname -a
Linux bpi-iot-ros-ai 3.4.39-BPI-M2P-Kernel #1 SMP PREEMPT Fri Nov 18 00:54:47 UTC 2016 armv7l armv7l armv7l GNU/Linux
« Последнее редактирование: 18 Июнь 2017, 10:23:08 от myordo »

Оффлайн mikekon

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: bananapi m2+ & ubuntu+mysql=проблема
« Ответ #1 : 08 Июль 2017, 13:11:26 »
вопрос еще актуален?

Оффлайн myordo

  • Автор темы
  • Участник
  • *
  • Сообщений: 140
  • 12.04 LTS
    • Просмотр профиля
Re: bananapi m2+ & ubuntu+mysql=проблема
« Ответ #2 : 28 Сентябрь 2017, 15:41:02 »
актуален

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: bananapi m2+ & ubuntu+mysql=проблема
« Ответ #3 : 30 Сентябрь 2017, 21:11:17 »
mysql-common тоже должен быть соответствующей версии.

 

Страница сгенерирована за 0.13 секунд. Запросов: 23.