Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Установка драйвера АМД и последующее использование видеокарты  (Прочитано 2211 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
А как теперь вот это через консоль, на дискретной видеокарте запустить?
Так и запустить

DRI_PRIME=1 ~/Загрузки/WarThunder/launcher
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1104
  • Ubuntu 14.04 LTS
    • Просмотр профиля
А я вижу. Была бы карта поприличнее - разница была бы существенная.
Может быть, и так. Но если карты сопоставимы, то смысла нет

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
VladimirTurunen,
Если результат устроит, то не обязательно через консоль каждый раз запускать. Можно прописать DRI_PRIME=1 для приложений.

Пользователь добавил сообщение 07 Июль 2017, 21:57:08:
Только так может не заработать. Надо наверное сделать так:

cd ~/Загрузки/WarThunder
DRI_PRIME=1 launcher
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн VladimirTurunen

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Мда. Это я так понимаю, не лечится?
https://1drv.ms/i/s!AmJMRUEJL4vmxVShoCtlYgf1PSB6

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
Мда. Это я так понимаю, не лечится?
Это видимо вызвано не той что нужно версией шейдеров или OpenGL на свободном драйвере. Где-то в сети была табличка что там поддерживается. Может быть и допилили. Хотя вряд ли кто-то старые карты пилит.

AMD поддержку забросила для новых версий линукса для этих карт, а люди тоже уже новыми пользуются на amdgpu.
« Последнее редактирование: 07 Июль 2017, 22:06:27 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1104
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Мда. Это я так понимаю, не лечится?
https://1drv.ms/i/s!AmJMRUEJL4vmxVShoCtlYgf1PSB6
Это что? Запуск на AMD? Если да, то только надеяться, что драйвер допилят и поставить новую версию дистрибутива. Ну либо пользоваться Intel.

Оффлайн VladimirTurunen

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
Игру получилось запустить на режиме совместимости со старыми видеокартами, но это боль для глаз. красные деревья и ландшафт цвета райдуги.
Весь терминал пестрит.
EE ../../../../../../src/gallium/drivers/r600/r600_state_common.c:787 r600_shader_select - Failed to build shader variant (type=1) -1
EE ../../../../../../src/gallium/drivers/r600/r600_shader.c:183 r600_pipe_shader_create - translation from TGSI failed !
EE ../../../../../../src/gallium/drivers/r600/r600_state_common.c:787 r600_shader_select - Failed to build shader variant (type=1) -1
EE ../../../../../../src/gallium/drivers/r600/r600_shader.c:183 r600_pipe_shader_create - translation from TGSI failed !
EE ../../../../../../src/gallium/drivers/r600/r600_state_common.c:787 r600_shader_select - Failed to build shader variant (type=1) -1


Пользователь добавил сообщение 07 Июль 2017, 22:13:09:
Ну, как система мне все равно линукс больше нравится. Так, что останусь на ней и в ближайшее время ждите море вопросов. Ну а винду все равно пришлось бы ставить, хоть для какого-то вменяемого гейминга.
И еще вопрос: а как узнать когда драйвер обновится???
« Последнее редактирование: 07 Июль 2017, 22:13:09 от VladimirTurunen »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
Ну а винду все равно пришлось бы ставить, хоть для какого-то вменяемого гейминга.
Я не большой геймер, но у меня винды нет. Играю в steam на Nvidia. На фпс не жалуюсь. Для АМД, особенно старых, так не получится.

И еще вопрос: а как узнать когда драйвер обновится???
Да он особо не обновится на этом дистрибутиве. Надо смотреть сайт по mesa и смотреть какие версии чего на вашей карте поддерживаются.
Если увидите серьезное изменение, то можно и руками обновить. Но в 17.04 совсем свежая mesa.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн VladimirTurunen

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
В смысле 17.04?????
А разве есть что то свежее 16.04????

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
В смысле 17.04?
Ну последняя версия Ubuntu вообще-то 17.04.

Пользователь добавил сообщение 07 Июль 2017, 22:30:40:
Правда ставить ее особого смысла нет, так как вы можете поставить ядро и графику от нее в 16.04 хоть прямо сейчас. Кстати это имеет смысл попробовать, так как ваша карта поддерживает OpenGL 4.5, тогда как система только 3.3 обеспечивает.

Может быть это ничего не даст, но перевод с ядра 4.8 на 4.10 и иксов соответственно сам собой произойдет очень скоро.
« Последнее редактирование: 07 Июль 2017, 22:31:22 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн VladimirTurunen

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
http://ubuntu.ru/get
Я чего-то не вижу.
Ладно, в любом случае ставить ее не буду, так как еще раз переустановку всех приложений не выдержу.
Объясните пожалуйста, как поставить ядро и графику от нее?

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1104
  • Ubuntu 14.04 LTS
    • Просмотр профиля
VladimirTurunen, кардинальные изменения всё равно вряд ли будут. R600 считается одним из самых допиленных открытых драйверов для   карт AMD старых серий.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
Я чего-то не вижу.
Ну не обновляет этот сайт никто. Уже было и 16.10, и 17.04. Может это и специально, чтобы новички не-LTS не ставили.

Графики пока нет в репах. У вас и так последняя практически Mesa 17.2.0-devel.

А вот ядро я бы попробовал.

sudo apt install linux-generic-hwe-16.04-edge
После перезагрузки ядро должно стать 4.10.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн VladimirTurunen

  • Автор темы
  • Любитель
  • *
  • Сообщений: 58
    • Просмотр профиля
VladimirTurunen, кардинальные изменения всё равно вряд ли будут. R600 считается одним из самых допиленных открытых драйверов для   карт AMD старых серий.
Да мне интересно просто, где ее взять. Скачал же вроде последнюю, а тут есть еще. А что значит приписка ЛТС?
Ну как я уже говорил - линь для меня идеальная система и можно руками много чего допилить, но для нормального гейминга нужно будет ставить винду. Увы. Сомневаюсь, что 1080 будет нормально работать на лине.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 10825
    • Просмотр профиля
А что значит приписка ЛТС?
Вообще с такими вопросами лучше в гугл обращаться. LTS -  это релизы с длинной поддержкой 5 лет. Остальные поддерживаются 9 месяцев и не рекомендуются для повседневного использования в большинстве случаев.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.136 секунд. Запросов: 23.