Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Неудовлетворённые зависимости пакета  (Прочитано 197 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Slava247

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Вчера при обновлении системы произошел скачек питания. UPSа нет, к сожалению.
Теперь при любой попытке установки пакета или обновления вот  такая картинка:

Пакеты, имеющие неудовлетворённые зависимости:
 libsnmp30:i386 : Зависит: libperl5.22:i386 (>= 5.22.1) но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.



Испытал все способы, которые нагуглил. Ничего не помогает. Перезаливать систему не хочется, много настроек.
Может есть решение?

« Последнее редактирование: 12 Октябрь 2017, 17:08:52 от Slava247 »

Оффлайн renzrv

  • Старожил
  • *
  • Сообщений: 1743
    • Просмотр профиля
Re: Уважаемые знатоки! Нужна ваша помощь.
« Ответ #1 : 12 Октябрь 2017, 16:57:12 »
Ничего не помогает
Вывод ошибки показывай

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4818
    • Просмотр профиля
Re: Уважаемые знатоки! Нужна ваша помощь.
« Ответ #2 : 12 Октябрь 2017, 17:02:30 »
Цитировать
Правила форума
2. На форуме ЗАПРЕЩЕНО
2.6. Создавать темы с неинформативным названием, например «Помогите», «Пара вопросов», «Настройка Интернета» и т. п.

Переименуйте тему в соответствии с сутью вопроса, например "Неудовлетворённые зависимости пакета".

--БТР

Оффлайн Slava247

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Неудовлетворённые зависимости пакета
« Ответ #3 : 12 Октябрь 2017, 17:09:59 »
~$ sudo apt upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libsnmp30:i386 : Зависит: libperl5.22:i386 (>= 5.22.1) но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
~$

Цитата: Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.

--БТР
« Последнее редактирование: 12 Октябрь 2017, 17:16:40 от БТР »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4818
    • Просмотр профиля
Re: Неудовлетворённые зависимости пакета
« Ответ #4 : 12 Октябрь 2017, 17:14:19 »
sudo apt-get -f install

Оффлайн Slava247

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Неудовлетворённые зависимости пакета
« Ответ #5 : 12 Октябрь 2017, 17:17:32 »
 Не помогает.
:~$ sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-4.10.0-32 linux-headers-4.10.0-32-generic linux-headers-4.4.0-96 linux-headers-4.4.0-96-generic linux-image-4.10.0-32-generic linux-image-4.4.0-96-generic linux-image-extra-4.10.0-32-generic linux-image-extra-4.4.0-96-generic
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libperl5.22:i386
НОВЫЕ пакеты, которые будут установлены:
  libperl5.22:i386
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 4 пакетов.
Необходимо скачать 3 007 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 15,5 MB.
Хотите продолжить? [Д/н] д
Пол:1 http://ru.archive.ubuntu.com/ubuntu xenial/main i386 libperl5.22 i386 5.22.1-9 [3 007 kB]
Получено 3 007 kБ за 11с (267 kБ/c)                                                                                                                                                                                                                                           
(Чтение базы данных … на данный момент установлено 311625 файлов и каталогов.)
Подготовка к распаковке …/libperl5.22_5.22.1-9_i386.deb …
Распаковывается libperl5.22:i386 (5.22.1-9) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libperl5.22_5.22.1-9_i386.deb (--unpack):
 попытка перезаписать общий «/usr/share/doc/libperl5.22/changelog.Debian.gz», который отличается от других экземпляров пакета libperl5.22:i386
Обрабатываются триггеры для man-db (2.7.5-1) …
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libperl5.22_5.22.1-9_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
~$
Цитата: Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.

--БТР

« Последнее редактирование: 12 Октябрь 2017, 17:27:28 от БТР »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4818
    • Просмотр профиля
Re: Неудовлетворённые зависимости пакета
« Ответ #6 : 12 Октябрь 2017, 17:26:24 »
cd /var/cache/apt/archives
sudo dpkg -i --force-all libperl5.22_5.22.1-9_i386.deb

Оффлайн Slava247

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Неудовлетворённые зависимости пакета
« Ответ #7 : 12 Октябрь 2017, 17:33:14 »
Большое спасибо! Помогло!

 

Страница сгенерирована за 0.09 секунд. Запросов: 23.