Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Как устновить необходимую библиотеку?  (Прочитано 107 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ввысь

  • Автор темы
  • Участник
  • *
  • Сообщений: 182
    • Просмотр профиля
Здравствуйте.

Есть исполняемый файл (достался по наследству). Я его запускал, он работал и все были счастливы. Но нужно обновлять систему, скачал, запустил на виртуалке. При запуске ловлю это

./a.out
bash: ./a.out: cannot execute binary file: Exec format error

полез читать, нашел это

file a.out
a.out: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=221f79b9bbcfec0ed960cd221be3273f2c82d073, not stripped

а что дальше не могу въехать. Как эту библиотеку(и главное нужно ли) ее устаналивать что запустить файл?

Linux ubuntu 4.4.0-87-generic #110-Ubuntu SMP Tue Jul 18 12:54:58 UTC 2017 i686 i686 i686 GNU/Linux

файл исполняемый)

или дело в разрядности и я сам себе злой буратино?

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4891
    • Просмотр профиля
Re: Как устновить необходимую библиотеку?
« Ответ #1 : 07 Декабрь 2017, 19:27:11 »
вы запускаете 64-битное приложение в 32-разрядной системе.

Оффлайн Ввысь

  • Автор темы
  • Участник
  • *
  • Сообщений: 182
    • Просмотр профиля
Re: Как устновить необходимую библиотеку?
« Ответ #2 : 07 Декабрь 2017, 19:28:58 »
БТР, понял. Была такая мысль, но лучше убедиться. Спасибо.

 

Страница сгенерирована за 0.115 секунд. Запросов: 23.