Форум русскоязычного сообщества Ubuntu


Автор Тема: Не устанавливается Google SDK из-за (held) битых пакетов.  (Прочитано 375 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kirillmaster4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Здраствуйте! У меня возникла проблема при установке Google SDK. Вот инфромация с терминала:
(Нажмите, чтобы показать/скрыть)
Помогите мне пожалуйста.
Создал отдельную тему, т.к. такой же проблемы на форуме не нашёл.

P.s. проблема решена, подробнее смотреть ниже  :).
« Последнее редактирование: 07 Январь 2018, 14:55:31 от kirillmaster4 »

Оффлайн ALiEN175

  • Старожил
  • *
  • Сообщений: 1833
  • X-9000SC
    • Просмотр профиля
покажите под спойлером
grep -Rv '^#.*\|^$' /etc/apt/source*
45100

Оффлайн kirillmaster4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
grep -Rv '^#.*\|^$' /etc/apt/source*
Не помогло. Всё ещё такая же проблема.
(Нажмите, чтобы показать/скрыть)

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1492
    • Просмотр профиля
kirillmaster4, да чтож вы намешали из репов. и debian и precise и даже lucid.
удалите

Оффлайн kirillmaster4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
да чтож вы намешали из репов. и debian и precise и даже lucid.
удалите
подскажите как пожалуйста, а то я просто новичок, и не сильно в этом разбираюсь.

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1492
    • Просмотр профиля
sudo sed -i '/\(debian\|lucid\|precise\)/d' /etc/apt/sources.list
sudo apt update
sudo apt install default-jre
вам что нужно -- jre или jdk ?

Оффлайн kirillmaster4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
JDK, но я сам догадаюсь просто поменяв -jr на jdk. Спасибо, завтра попробую.
вам что нужно -- jre или jdk ?
Мне нужно JDK. Я догадаюсь просто заменить --jre на JDK, спасибо. Завтра попробую.

Пользователь добавил сообщение 06 Январь 2018, 12:40:33:
вам что нужно -- jre или jdk ?
Не получается
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 06 Январь 2018, 12:40:33 от kirillmaster4 »

Оффлайн ALiEN175

  • Старожил
  • *
  • Сообщений: 1833
  • X-9000SC
    • Просмотр профиля
Я догадаюсь просто заменить --jre на JDK, спасибо
не догадались)
sudo apt install default-jdk
у вас почему-то пробел вместо дефиса
45100

Оффлайн kirillmaster4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
не догадались)
sudo apt install default-jdk
у вас почему-то пробел вместо дефиса
Код: [Выделить]

sudo sed -i '/\(debian\|lucid\|precise\)/d' /etc/apt/sources.list
sudo apt update
sudo apt install default-jre

вам что нужно -- jre или jdk ?

Спасибо вам обоим большое! Помогло!

 

Страница сгенерирована за 0.134 секунд. Запросов: 24.