Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: видеокарта не работает, после обновления системы  (Прочитано 748 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ubbuntu

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
  • --мята x64 LTS 16.04, 18.04
    • Просмотр профиля
Прив.

Установил обновления, там в процессе была какая-то ошибка. Не обратил на неё внимания, отменил "отправку отчета". Всё установилось, а после перегрузки, он мне говорит что не работает видеоадаптер.  :o
Захожу в "Nvidia X Server.." там стоит карта интел, меняю на Nvidia, делаю релог. И там опять стоит интел.

Как это победить?

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1402
  • Kubuntu 12.04, 16.04, 18.04
    • Просмотр профиля
Прив.
И тебе того же.
Может для начала лучше бы конкретно сообщить о версии своей системы и что на что обновлялось по Nvidia?
Я странен, а не странен кто ж? (С)

Оффлайн Ubbuntu

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
  • --мята x64 LTS 16.04, 18.04
    • Просмотр профиля
Может для начала лучше бы конкретно сообщить о версии своей системы и что на что обновлялось по Nvidia?
С начала, так с начала.

Версия Ubuntu 16.04.03-MATE x64.
Без понятия что там обновлялось по нвидии, просто зашел в Система>>Администрирование>>Обновление приложений. И там вывалился такой список, огромный.  Нажал установить.
Всё.

Если подвести мышу к знаку стоп, вверху в трее, то там написанно Active graphics card: unknown  :(
« Последнее редактирование: 13 Январь 2018, 04:40:21 от Ubbuntu »

Оффлайн sergey_g_e

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Добрый день, поддерживаю оратора, вчера обновил систему, фильм смотрел, ничего не заметно было, сегодня в танчики полез через portwine играть - ругается на незнакомую видеокарту и не запускается, и другие игры в бутылках playonlinux Wine ругаются аналогично, зато пошла дьябла2 в полноэкранном режиме - а раньше только в окошке шла. пытался перейти на другие дрова в дополнительных драйверах(Стоял nvidia 304.135 - качает, переходит, но толку нет, что 340.102, что x.org x server)
« Последнее редактирование: 13 Январь 2018, 08:50:29 от sergey_g_e »

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 1770
    • Просмотр профиля
sergey_g_e, Ubbuntu, видеокарты nvidia у вас какие?
Intel Core i3-3220 3.30GHz, GeForce 8800 GT, MSI H61M-P20, 6GB RAM, SAMSUNG_MZMPC032- Kubuntu 17.10-х64

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1408
  • ubuntu 16.04
    • Просмотр профиля
С патчем против meltdown разломали старые Nvidia драйвера
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/+bug/1741671
« Последнее редактирование: 13 Январь 2018, 10:16:38 от soarin »

Оффлайн sergey_g_e

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
sergey_g_e, Ubbuntu, видеокарты nvidia у вас какие?
Geforce 9600GT

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 1770
    • Просмотр профиля
С патчем против meltdown разломали старые Nvidia драйвера
Похоже так и есть.
Решение, пока запускаться на предыдущих ядрах.
Intel Core i3-3220 3.30GHz, GeForce 8800 GT, MSI H61M-P20, 6GB RAM, SAMSUNG_MZMPC032- Kubuntu 17.10-х64

Оффлайн Ubbuntu

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
  • --мята x64 LTS 16.04, 18.04
    • Просмотр профиля
видеокарты nvidia у вас какие?
Да Nvidia
GT 520MX


Похоже так и есть.
Решение, пока запускаться на предыдущих ядрах.
А можно поподробней как это сделать?

ОФФтопик

(Нажмите, чтобы показать/скрыть)

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 2890
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
А можно поподробней как это сделать?
При загрузке зажимаете Shift (если до этого у вас не отображалось меню загрузки Grub)
Выбираете 2 пункт (Что-то с Advanced options или дополнительными параметрами)
Выбираете предыдущее Ubuntu с предыдущим ядром
Почему у меня версия ядра не 4.4.0-108-generic а 4.13.0-26-generic. 
Начнем с того, что даже у тех, у кого ветка ядер 4.4 нет ядра 4.4.0-108) Ибо оно было с багом, кто успел поставить - получил краши (тут есть даже тема) или другие проблемы, после чего ядро было убрано из обновлений и вышло 4.4.0-109.
А 4.13.0-26 у вас потому, что у Вы устанавливали сразу Ubuntu 16.04.2 или 16.04.3 уже с hwe ядрами. И после прекращения поддержки одной ветки вы "переезжаете" автоматом на другую. В патчноутах для Meltdown сказано, что ветки 4.10 не будет, все у кото такая ветка переюдут на ветку 4.13
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн Ubbuntu

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
  • --мята x64 LTS 16.04, 18.04
    • Просмотр профиля
Ясно, понятно.  :)
Тогда ждем исправлений.

Оффлайн Vir0id

  • Участник
  • *
  • Сообщений: 239
  • Выкини комп из окна или окна из компа
    • Просмотр профиля
Прив.

Установил обновления, там в процессе была какая-то ошибка. Не обратил на неё внимания, отменил "отправку отчета". Всё установилось, а после перегрузки, он мне говорит что не работает видеоадаптер.  :o
Захожу в "Nvidia X Server.." там стоит карта интел, меняю на Nvidia, делаю релог. И там опять стоит интел.

Как это победить?
Может покажешь хоть какие-то логи? Например
cat /var/log/apt/term.logcat/var/log/gpu-manager.logили
cat /var/log/syslogну и наконец
cat /var/log/Xorg.0.logи еще
lspci -knn | grep -i vga -A3и опять
inxi -Fxz
« Последнее редактирование: 15 Январь 2018, 13:43:54 от Vir0id »

Оффлайн Ubbuntu

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
  • --мята x64 LTS 16.04, 18.04
    • Просмотр профиля
Цитировать
Может покажешь хоть какие-то логи? Например

Не дает вставить, даже под спойлером.. говорит сильно длинные.  :o

Вот последнее:
System:    Host: ps Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.12.1 (Gtk 2.24.30) Distro: Ubuntu 16.04 xenial
Machine:   System: SAMSUNG product: 300E4A/300E5A/300E7A/3430EA/3530EA v: 0.1
           Mobo: SAMSUNG model: 300E4A/300E5A/300E7A/3430EA/3530EA v: FAB1
           Bios: Phoenix v: 09QA date: 11/02/2012
CPU:       Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9977
           clock speeds: max: 3100 MHz 1: 2494 MHz 2: 2494 MHz 3: 2494 MHz
           4: 2494 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: NVIDIA GF119M [GeForce GT 520MX] bus-ID: 01:00.0
           Display Server: X.Org 1.19.5 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.07hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card-1: Intel Centrino Wireless-N 130
           driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 200.1GB (30.3% used)
           ID-1: /dev/sda model: Hitachi_HTS54168 size: 80.0GB
           ID-2: /dev/sdb model: KINGSTON_SV300S3 size: 120.0GB
Partition: ID-1: / size: 104G used: 51G (52%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 6.35GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 191 Uptime: 9:17 Memory: 1007.3/5874.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Оффлайн Dr.LinRus

  • Любитель
  • *
  • Сообщений: 53
  • the Doctor
    • Просмотр профиля
Ubbuntu,  и чего мы скачем из темы в тему? http://forum.ubuntu.ru/index.php?topic=295405.0
Моя плавно переросла в твой вопрос, но с нюансами.
Lenovo Yoga 3-1170: Intel® Core™ M-70, DDR3L 4Gb, SSD 128Gb, Bluetooth 4.0, Wi-Fi 802.11 A/C, GIGA LAN, 2*USB 3.0-[1 combined AC USB 2.0], JBL® (Waves Audio) / Kubuntu 16.04LTE 64bit, Windows 10 64bit

Оффлайн Ubbuntu

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
  • --мята x64 LTS 16.04, 18.04
    • Просмотр профиля
Ubbuntu,  и чего мы скачем из темы в тему? http://forum.ubuntu.ru/index.php?topic=295405.0
Моя плавно переросла в твой вопрос, но с нюансами.

Где обсуждают там и скачем, а вообще показалась тема и проблема похожая.

 

Страница сгенерирована за 0.176 секунд. Запросов: 24.