Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблема с указателем мыши после установки Ubuntu  (Прочитано 478 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн denvol96

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Доброго времени суток!

Относительно недавно купил новый ноутбук и решил на него сразу поставить Ubuntu последней версии. Но после установки возникает проблема: после некоторого времени нормальной работы перестает работать клик мыши, будь то на элементах окна (банально не могу закрыть окно), либо на панели unity. Сам курсос двигается, но клик не срабатывает вообще (проверял как на тачпадае, так и на разных мышках).
При запуске системы с флешки, например, все работает нормально, видимо, проблема с моим железом.
Аналогичная проблема происходит после установки Ubuntu 16.04, 14.04, Linux Mint 18 версии (точный номер версии не могу сказать).
На Windows 10 все работает нормально, как и на той-же виртуальной машине на VirtualBox.

Есть какое-нибудь решение данной проблемы или кто-то, если сталкивался с такими, нашел решение? Или мое железо не поддерживается (в плане нормальной работы)?
Заранее, всех благодарю за помощь.

Спецификация ноутбука:
Lenovo IdeaPad 510-15IKB
Экран 15.6" IPS (1920x1080) Full HD
Intel Core i5-7200U (2.5 - 3.1 ГГц)
RAM 8 ГБ
nVidia GeForce 940MX, 2 ГБ
* если нужны какие-то дополнительные сведения, постараюсь ответить, как можно быстрее.

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 434
    • Просмотр профиля
Сам курсос двигается, но клик не срабатывает вообще...
Проблема не с устройствами ввода. Система фризится. И скорее всего из-за драйверов на видеокарту. В терминале выполните команду и покажите нам ее вывод:
lspci -k| grep -EA2 'VGA|3D'

Оффлайн denvol96

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Спасибо, что откликнулись.
Поставил Ubuntu 16.04 последней версии рядом с Windows 10.
Вывод команды:
$ lspci -k| grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
    Subsystem: Lenovo Device 39f1
    Kernel driver in use: i915
--
03:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
    Subsystem: Lenovo GM108M [GeForce 940MX]
    Kernel driver in use: nouveau


Сам курсос двигается, но клик не срабатывает вообще...
Проблема не с устройствами ввода. Система фризится. И скорее всего из-за драйверов на видеокарту. В терминале выполните команду и покажите нам ее вывод:
lspci -k| grep -EA2 'VGA|3D'

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 434
    • Просмотр профиля

Оффлайн denvol96

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Установил проприетарный драйвер от nvidia, проблема не исчезла, к сожалению.
$ lspci -k| grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
    Subsystem: Lenovo Device 39f1
    Kernel driver in use: i915
--
03:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
    Subsystem: Lenovo GM108M [GeForce 940MX]
    Kernel driver in use: nvidia

Есть какое-то другое решение данной проблемы? Спасибо.


denvol96, установите проприетарный драйвер для видеокарты Nvidia

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 434
    • Просмотр профиля
denvol96, покажите еще /var/log/syslog и /var/log/Xorg.0.log (прикрепите указанные файлы к своему сообщению)

Оффлайн denvol96

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Прикрепляю файлы. Если дополнительно еще нужен файл Xorg.0.log.old, прикреплю его в следующем сообщении. Запаковал в архив из-за ограничений в размере файлов.

покажите еще /var/log/syslog и /var/log/Xorg.0.log

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 434
    • Просмотр профиля
denvol96, либо отключите SecureBoot в UEFI, либо выполните рекомендации форумчанина Pilot6 в этой теме.

Оффлайн denvol96

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Попробовал оба варианта - к сожалению, не помогло. Видимо, Ubuntu не встанет нормально на ноутбук.
SecureBoot в BIOS не нашел, а, как советовал Pilot6, выполнить команду не получилось.
Результат выполнения:
EFI variables are not supported on this system
denvol96, либо отключите SecureBoot в UEFI, либо выполните рекомендации форумчанина Pilot6 в этой теме.

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 434
    • Просмотр профиля
EFI variables are not supported on this system
Значит система установлена в режиме CSM (Legacy BIOS). Да и совет из предыдущего моего сообщения ничего не дал бы. Пересмотрел сегодня еще раз лог файл. Обратил внимание на следующее:
Цитировать
Mar  4 17:10:42 Denis kernel: [    0.000000] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x52 (or later)
В сети рекомендуют доустановить пакет intel-microcode. К тому же не повредило бы обновить BIOS.
Сам курсор двигается, но клик не срабатывает вообще (проверял как на тачпаде, так и на разных мышках).
Обычно когда система фризится, система не реагирует в ответ на действия пользователя. А у Вас курсор перемещается! Клавиатура при этом работает (Alt+TAB, Alt+F4, TAB для перевода фокуса ввода между элементами пользовательского интерфейса и т.д.)? Насторожила также и такая запись:
(Нажмите, чтобы показать/скрыть)
Обратите особое внимание на последнюю строку. Возможны проблемы с управлением питанием USB-портов. Здесь дается более развернутый ответ по этой теме.
Можно пойти еще одним путем. Перейдите по этой ссылке и выполните команды пункта 2. Результаты предоставьте на форум. Кроме того при наличии системы Windows, рекомендую отключить быстрый запуск.
« Последнее редактирование: 09 Март 2018, 14:49:41 от archuser »

 

Страница сгенерирована за 0.138 секунд. Запросов: 23.