Форум русскоязычного сообщества Ubuntu


Автор Тема: Flatpak и его runtime  (Прочитано 165 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tjn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Flatpak и его runtime
« : 11 Май 2018, 23:04:02 »
Пробую тут Flatpak, возник один вопрос по принципу его работы, надеюсь кто поможет разобраться.

Многие приложения требуют для установки пакет runtime, я так понимаю с зависимостями. Например org.gnome.Calendar/x86_64/stable из репозитория flathub требует для работы runtime c библиотеками Gnome org.gnome.Platform/x86_64/3.28

Но вот захотел я установить Калькулятор, а он требует предыдущую версию рантаймов, 3.26

Вопрос: устанавливаю я калькулятор, он тянет за собой запакованный гном 3.26. Потом в процессе обновления, если обновят этот самый калькулятор на версию из 3.28, достаточно ли умен flatpak, чтобы удалить ненужный более рантайм с платформой 3.26? Или же он так и останется в системе мертвым грузом? Будут ли приложения нормально потом обновляться до следующих версий, например из 3.30, тянуть за собой зависимости и удалять ненужные рантаймы?


 

Страница сгенерирована за 0.112 секунд. Запросов: 23.