Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Ошибка обновления ядра  (Прочитано 772 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Ошибка обновления ядра
« : 10 Июль 2018, 20:58:06 »
Доброго времени суток! У меня возникла проблема при обновлении ядра 4.13 на 4.17. Делал по инструкци с этого сайта https://losst.ru/obnovlenie-yadra-linux-do-4-4 но не хватало какойто библиотеки. Скачал ее, скачал еще дополнительно linux-modules с сайта из этой статьи, вроде написало что обновило ядро, но uname -r показывает 4.13. Также появился красный значок "стоп" в правом верхнем угул экрана. Фото прилагаю. Я пробовал кучу всяких команд типа -f install, autoclean, upgrade, всегда что-то делает, а значок не уходит и ядро не обновляется. Буду благодарен за помощь. Фото ошибки https://dropmefiles.com/dIJBy

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5009
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #1 : 10 Июль 2018, 21:06:17 »
 с какой целью проводилось обновление?

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1568
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #2 : 10 Июль 2018, 21:12:52 »
PaulKovalov, лучше покажите
sudo apt install -fи вывод в текстовом виде

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #3 : 10 Июль 2018, 23:17:15 »
с какой целью проводилось обновление?
Новые ядра содержат оптимизацию, улучшение работы, и т.д. Ранее, до переустановки системы, на этот ноутбук ставил 4.17 работал от батареи дольше на 20-30%.

Пользователь добавил сообщение 10 Июль 2018, 23:19:13:
PaulKovalov, лучше покажите
sudo apt install -fи вывод в текстовом виде
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 40 not upgraded.
« Последнее редактирование: 10 Июль 2018, 23:19:13 от PaulKovalov »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1428
  • Kubuntu 12.04, 16.04, 18.04, 18.10
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #4 : 11 Июль 2018, 00:45:19 »
PaulKovalov, ядро 4.17 уже является штатным на *ubuntu будущего релиза 18.10. Если имеется такая необходимость и желание к новизне, то почему бы сразу не переместиться туда?
Я странен, а не странен кто ж? (С)

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2544
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #5 : 11 Июль 2018, 01:51:13 »
PaulKovalov, AlexBKost говорил дело. Тем более этого намного проще чем самому разбираться с ядром. Если же вы хотите использовать самые самые свежие релизные версии ядра, то предпочтительней использовать дистрибутивы которые по умолчанию предоставляют такую возможность, это обычно любые дистрибутивы с моделью роллинг релизов (например Arch). К слову даже обычная Fedora такую возможность предоставляет по умолчанию, хотя речь не идёт в данной ситуации о роллинг модели. В Ubuntu ядро почти никогда не является свежим, и мажорная версия не обновляется в рамках одного релиза. (LTS порты не в счёт).

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #6 : 11 Июль 2018, 11:11:58 »
PaulKovalov, AlexBKost говорил дело. Тем более этого намного проще чем самому разбираться с ядром. Если же вы хотите использовать самые самые свежие релизные версии ядра, то предпочтительней использовать дистрибутивы которые по умолчанию предоставляют такую возможность, это обычно любые дистрибутивы с моделью роллинг релизов (например Arch). К слову даже обычная Fedora такую возможность предоставляет по умолчанию, хотя речь не идёт в данной ситуации о роллинг модели. В Ubuntu ядро почти никогда не является свежим, и мажорная версия не обновляется в рамках одного релиза. (LTS порты не в счёт).

Ну можно же и на 16.04 сидеть и ставить ядра. Я уже поставил 16.04, утановил весь нужный софт, переустанавливать не хочу, долго потом буду настраивать систему

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2544
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #7 : 11 Июль 2018, 11:14:12 »
PaulKovalov, Можно всё. Мы вам разрешаем. Но ответственность за свои действия на вас самих.

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #8 : 11 Июль 2018, 11:16:40 »
PaulKovalov, Можно всё. Мы вам разрешаем. Но ответственность за свои действия на вас самих.
Спасибо. И все таки кто-то знает как устранить эту проблему? https://dropmefiles.com/dIJBy

Пользователь добавил сообщение 11 Июль 2018, 11:17:13:
А заодно и ядро до 4.17 обновить

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5009
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #9 : 11 Июль 2018, 11:22:40 »
Я пробовал кучу всяких команд типа -f install, autoclean, upgrade, всегда что-то делает

скопируйте вывод выполнения в сообщение:
sudo apt update
sudo apt-get dist-upgrade

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #10 : 11 Июль 2018, 11:32:09 »
sudo apt update

Reading package lists... Done
Building dependency tree       
Reading state information... Done
41 packages can be upgraded. Run 'apt list --upgradable' to see them.

sudo apt-get dist-upgrade

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 imagemagick-6.q16 : Depends: libmagickcore-6.q16-2 (>= 8:6.8.8.2) but it is not going to be installed
                     Depends: libmagickwand-6.q16-2 (>= 8:6.8.8.2) but it is not going to be installed
                     Recommends: libmagickcore-6.q16-2-extra
                     Recommends: ghostscript
 libgphoto2-6 : Depends: libgd3 (>= 2.1.0~alpha~) but it is not going to be installed
 libkf5waylandclient5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                                 libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
 libosgi-compendium-java : Depends: libgeronimo-jpa-2.0-spec-java but it is not going to be installed
 libpango-1.0-0 : Depends: fontconfig (>= 2.1.91)
 libqmenumodel0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                           libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
 libqt5multimedia5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed or
                              libqt5gui5-gles (>= 5.2.0) but it is not going to be installed
 libqt5multimediaquick-p5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                                     libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                            Depends: libqt5quick5 (>= 5.4.0) but it is not going to be installed or
                                     libqt5quick5-gles (>= 5.4.0) but it is not going to be installed
 libubuntugestures5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                               libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                      Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or
                               libqt5quick5-gles (>= 5.0.2) but it is not going to be installed
 libubuntutoolkit5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                              libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
 qml-module-io-thp-pyotherside : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                                          libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                                 Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or
                                          libqt5quick5-gles (>= 5.0.2) but it is not going to be installed
 qml-module-ubuntu-layouts : Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or
                                      libqt5quick5-gles (>= 5.0.2) but it is not going to be installed
 qtwayland5 : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or
                       libqt5gui5-gles (>= 5.5.0) but it is not going to be installed
              Depends: libqt5waylandclient5 (>= 5.5.0) but it is not going to be installed
 tk : Depends: tk8.6 (>= 8.6.0-2)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


Пользователь добавил сообщение 11 Июль 2018, 11:35:55:
Правда непохоже чтоб это к ядру относилось
« Последнее редактирование: 11 Июль 2018, 11:35:55 от PaulKovalov »

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1568
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #11 : 11 Июль 2018, 11:40:57 »
PaulKovalov, список репов подключенных давайтеgrep -v '^$\|^#' /etc/apt/sources.list{,.d/*.list}

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #12 : 11 Июль 2018, 12:07:10 »
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial main restricted
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial universe
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial-updates universe
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial multiverse
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
/etc/apt/sources.list:deb http://ua.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu xenial universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security main
/etc/apt/sources.list.d/atareao-ubuntu-telegram-xenial.list:deb http://ppa.launchpad.net/atareao/telegram/ubuntu xenial main
/etc/apt/sources.list.d/google-chrome.list:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/ubuntu-desktop-ubuntu-ubuntu-make-xenial.list:deb http://ppa.launchpad.net/ubuntu-desktop/ubuntu-make/ubuntu xenial main
/etc/apt/sources.list.d/vscode.list:deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1568
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #13 : 11 Июль 2018, 13:32:18 »
ещеapt policy  libqt5gui5 libgd3  libgeronimo-jpa-2.0-spec-java libmagickcore-6.q16-2

Оффлайн PaulKovalov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: Ошибка обновления ядра
« Ответ #14 : 11 Июль 2018, 16:00:29 »
ARTGALGANO,
(Нажмите, чтобы показать/скрыть)

Цитата: Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.

--toZen

« Последнее редактирование: 11 Июль 2018, 16:03:28 от τοΖεη »

 

Страница сгенерирована за 0.138 секунд. Запросов: 23.