Форум русскоязычного сообщества Ubuntu


Автор Тема: Звук в наушниках и колонках одновременно в ubuntu 8.04 на ноутбуке  (Прочитано 47091 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dim.

  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Benq s32b Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
ничего не помогло... стоит новая альса

Оффлайн alecsartania

  • Старожил
  • *
  • Сообщений: 1552
  • УМка.
    • Просмотр профиля
а это у меня ноут такой особенный - на регуляторе громкости(микшере) правой кнопкой-> открыть регулятор громкости->переключатели->hydrophone sense гадлочку поставил и все следится ?
Дома Linux mint 15 ||  Ubuntu 14.04  / Ubuntu 8.04
Работа: Linux Mint 18(Ub 16.04)

Оффлайн Fildy

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
такая же проблема, звук из спикеров и в наушниках. ноут asus m50vn, система Ubuntu 8.10
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

cat /proc/asound/card0/codec#0 | grep Codec
Codec: Realtek ALC663
в /etc/modprobe.d/alsa-base прописал это:
options snd-hda-intel model=3stack-dig position_fix=0]
облазил несколько форумов, все равно не пашет :(

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
1. With alsa =<1.0.17. Partial, use options snd-hda-intel model=3stack-dig (edit file /etc/modprobe.d/alsa-base). Inserting headphones doesn't mute speakers. Sound over hdmi doesnt work.
2. With alsa >=1.0.18a. Fedora 10 and Ubuntu 8.10 sound is fine. Option “snd-hda-intel model=3stack-dig” need to be removed.

Это Вам ни о чем не говорит?

Оффлайн Kaktus3000

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
такая же проблема, звук из спикеров и в наушниках. ноут asus m50vn, система Ubuntu 8.10
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

cat /proc/asound/card0/codec#0 | grep Codec
Codec: Realtek ALC663
в /etc/modprobe.d/alsa-base прописал это:
options snd-hda-intel model=3stack-dig position_fix=0]
облазил несколько форумов, все равно не пашет :(

Ребята, помогите, пожалуйста, точно такая же проблема...Весь инет перекопал, ничего не помогает:(

Оффлайн Jmentus

  • Новичок
  • *
  • Сообщений: 3
  • Женёк
    • Просмотр профиля
Здравствуйте, я перерыл гуглу, почитал тут посты, никаких здвигов, все делал как написано и ничего...

Есть встроенные колонки и есть подключённые наушники. Винда программно отключает колонки, когда в порт наушников что-то подключено. Как такого же добиться в ЛИнуксе? постоянно звук в колонках и в наушниках играет...

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)


(Нажмите, чтобы показать/скрыть)

1. Галочка это колонки...
2. Наушники...
3. Фронт...

Сначало пробывал отключить 1, и затем включить 2 и 3
Потом пробывал отключить 2 и затем включить 1 и 3
Затем пробывал 3 отключать и 1 и 2 оставить,
ноль на массу... эфект тот же самый играет и в наушниках и в колонках, из репозиториев попытался установить новый миксер, для управления громкостью, установил, там тоже проверял, и ничего не выходило...

Что мне делать в ту сторону что писали выше, в те ссылки я капал и эфект нулевой...

ноутбук Fujitsu-Siemens Amilo Pi2540 Ubunta 8.10
Бояться нужно не смерти, а пустой жизни.

Оффлайн Systo

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
У меня ноутбук Fujitsu-Siemens Amilo Pa-1538, наушники и колонки работают абсолютно корректно (Ubuntu/Kubuntu  с версий 7.04 и по 9.04 (alfa естественно), OpenSUSE 11.1, FreeBSD 6.0-7.1). Просто в этом ноутбуке классический разъем для наушников с механическим контактом на отключение встроенных динамиков. А вот у жены ноутбук Toshiba U300-131. При покупке на нем стояла Vista и все работало отлично. Естественно Vista была очень быстро снесена и поставлена Ubuntu (8.04 еще тогда, сейчас 8.10, 9.04 alfa 6 тоже пробовал). И вот тут то выяснилось, что на этом ноутбуке в разъеме нет механического контакта! Факт подключения наушников определяется сопротивлению меньше 100 Ом (если точно вспомнил) электроникой. Причем с такими разъемами я уже сталкивался раньше, но только на видеокамерах (Panasonic). И получалась такая ситуация, что если при загрузке наушники уже были подключены, то звук идет и в них, и во встроенные динамики. Vista при загрузке как то проверяла это факт и отключала встроенные динамики, а Ubuntu нет. Пробовал OpenSUSE, но все было точно так же. Никакие шаманства не помогали, хотя перекопал кучу вариантов с разных форумов. Но если наушники подключить к уже загруженному ноутбуку (причем надо уже быть и залогиненным), то звук начинает идти только в наушники, а колонки отключаются (скорее всего аппаратно звуковой картой, раз нет механического контакта). Помогает и простое отключение наушников на 1-2 секунды и их повторное подключение. В ноутбуке стоит 965 чипсет с уже упоминающимся тут ICH8. Могу предположить, что механический контакт отсутствует не только в этом ноутбуке. Так что отключение/подключение может помочь. Понятно, что решение кривое, но другого пока найти не смог.

P.S. На этом ноутбуке еще глючит колесико регулировки громкости (аппаратное). Что бы избавиться от глюков надо просто сменить горячие клавиши регулировки на любые другие. Колесико просто перестанет работать (и глючить соответственно).
« Последнее редактирование: 19 Март 2009, 07:45:53 от Systo »
FreeBSD (2.2.6 - 8.0), Kubuntu (7.04 - 9.10), Ubuntu (8.04 - 9.04), OpenSUSE (11.1-11.2)

Оффлайн YoS

  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
у меня на 8,04  все нормально работало : наушники вставил, внутренний звук пропал, вытащил, появился. в  8.10 никак не могу разобратся в чем проблемма.... а вот с "Помогает и простое отключение наушников на 1-2 секунды и их повторное подключение" надо будет сегодня попробовать.

Оффлайн Jmentus

  • Новичок
  • *
  • Сообщений: 3
  • Женёк
    • Просмотр профиля
А я пробывал повторное отключение и включения, толку ноль, всегда подключал наушники где-то после перезагрузки, когда уже был под рутом, иногда даже где-то через час даже загрузки ноута... Спасибо большое за доступный ответ... Все это странно... Но хотелось бы чтоб оно все работало, ато так не удобно... Уже даже не знаю что и попробывать...
Бояться нужно не смерти, а пустой жизни.

Оффлайн daFy

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
работает практически на всех М50 ноутах (у меня m50sr, всё работает прекрасно):

в терминале набираем

sudo nano /etc/modprobe.d/alsa-base

добавляем в конец:

options snd-hda-intel model=haier-w66

сохраняем, выходим

перегружаемся и всё работает прекрасно !!

оригинал: http://seethisnowreadthis.com/2008/05/19/how-to-install-ubuntu-804-hardy-heron-on-the-asus-m50sv-a1/#more-70

у меня Ubuntu 8.10

Оффлайн klaim

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
2 daFy,
Спасибо огромное! Помогло.
Ubuntu 9.04, Asus M50Sr.

Оффлайн Goldman

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Привет всем.
У меня Asus F3E. Установил Ubuntu. Дрова от ALC 660VD.
Такая же проблема: не выключаются динамики при подключении наушников.
Две недели искал в интернет решения - ничего не помогло. Случайно забрел на какой-то форум Ubuntu (оригинал внизу) и нашел тот драгоценный код.

Решение: открываем в терминалe sudo gedit /etc/modprobe.d/alsa-base.conf  вписываем в этот файл (в конце где-нибудь)
 options snd-hda-intel enable=1 index=0 model=lenovo , перезагружаем, и все работает!

P.S. Не пытайтесь решить проблему с помощью options snd-hda-intel model=модель компа. Я туда вписал все возможные варианты - не работает.

Оригинал:
Hi there

I'm trying to fix a friend of mine's Asus F3E, with Ubuntu 9.04 installed, and despite there are already two users reporting that "lenovo" option works, it doesn't change nothing for me (with "microphone" checkbox either way - selected/not selected).
The F3E has 660-VD codec, and I tried all the options listed there, too, still - didn't help.
Alsa version on the machine - 1.0.18.

Should I try to downgrade to 8.10 ? Because I think both success reports are on 8.10 (based on post dates)? Or install newer/older Alsa ?

I'd be very grateful if someone with such machine shares his (working) configuration, too

EDIT:
So now I can confirm that the line:
Quote:
options snd-hda-intel enable=1 index=0 model=lenovo
works fine with the ASUS F3E, ALC660-VD

Оффлайн grimarr

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
ASUS X55S,
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
Codec: Realtek ALC1200

чтобы срабатывало отключение колонок в
/etc/modprobe.d/alsa-base.conf дописываем
options snd-hda-intel model=lenovo-ms7195-dig  =)

Оффлайн Pingvinator

  • Любитель
  • *
  • Сообщений: 61
    • Просмотр профиля
У меня на ASUS F5N с Ubuntu 8.04 тоже была проблемма со звуком. Правильное решение было сказано ранее: для ASUS надо добавлять : options snd-hda-intel enable=1 index=0 model=lenovo . После этого звук заработал.  Одновременно у меня звук пер и в наушниках и в колонках только тогда, когда загружался ноут с подключенными наушниками. Незнаю по какой причине но несколько раз было и во время просмотра фильмов, ни с того, ни с сего - звук и в динамиках и в наушниках. И решилось очень просто: просто не подумав вытащил и заново воткнул наушники - все стало нормально. Многие советуют на ноут ставить 9.04. Вроде заявлено исправление работы модуля управлением питанием. У меня кстати ноут не перезагружается : останавливается на строке Restarting System - и все. Полный висяк. Сегодня хочу поставить на свой ноут 9.04 - посмотрим.
...  чудна и загадочна эта Ось: ось Microsoft Windows ...

Оффлайн YoS

  • Участник
  • *
  • Сообщений: 243
  • неординарен
    • Просмотр профиля
    • allUBUNTU
У меня кстати ноут не перезагружается : останавливается на строке Restarting System - и все. Полный висяк. Сегодня хочу поставить на свой ноут 9.04 - посмотрим.
у меня такая же хрень, как лечить так и не нашол... на 9.04 обновился... а на 8.10 все было нормально  :-\

 

Страница сгенерирована за 0.191 секунд. Запросов: 24.