Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.  (Прочитано 42250 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн absemetov

  • Автор темы
  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« : 17 Декабрь 2009, 18:58:28 »
DVD привод монтируется автоматически, но он не подключается в ubuntu так же его не видно. После выключения виртуальной машины появляется.

При отключении  DVD привода происходит данная ошибка.
NS_ERROR_FAILURE (0x80004005)
Не удалось отключить CD/DVD Привод хоста 'HL-DT-ST DVDRAM GH20NS10 ' (sr0) от машины XP. Не желаете ли произвести силовое отключение данного устройства?
Could not unmount the currently mounted media/drive (VERR_DEV_IO_ERROR).

Интерфейс:
IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

Оффлайн igorp1024

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #1 : 06 Январь 2010, 16:03:44 »
Та же ерунда на VirtualBox 3.1.12 / Karmic Koala
Workaround: тушим машину и в её свойствах отключаем подмонтированный привод.

Оффлайн as4tik

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Обновился, блин...
« Ответ #2 : 30 Апрель 2010, 16:44:11 »
Вот я классно обновился. Типа с 9.1 на 10.04. Теперь никак не могу ни новую виртуальную машину создать, ни старую запустить с виндой. Старая с треугольником желтым. Ни отключить, ни выключить. Создаю новую виртуалку, а менеджер виртуальных носителей говорит, что один из старых дисков недоступен. Нажимаю отключить, а он мне "не удалось ЗАКРЫТЬ жесткий диск".

Перезагрузка системы не помогает. Пробовал переустанавливать Виртуал бокс.

Есть идеи?

Оффлайн absemetov

  • Автор темы
  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #3 : 30 Апрель 2010, 17:53:33 »
попробуй старые конфиги виртуал бокса скопировать

Оффлайн mifeliz

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #4 : 23 Июнь 2010, 01:46:04 »
как исправить то проблему?

Оффлайн absemetov

  • Автор темы
  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #5 : 23 Июнь 2010, 10:02:45 »
как исправить то проблему?

Что за проблема, версия бокса?

Оффлайн vaha_gan

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #6 : 25 Февраль 2011, 20:49:08 »
Сори за ламерство.... ну все таки кто нить может помочь: Установил виртуал бокс,запустил XP,после перезагрузки виртуала,вот:NS_ERROR_FAILURE (0x80004005) и не заводиться Бокс... :idiot2: полная форма:
Не удалось создать COM-объект VirtualBox.
Работа приложения будет завершена.
Start tag expected, '<' not found.
Location: '/home/vaha/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.
/build/buildd/virtualbox-ose-3.2.8-dfsg/src/VBox/Main/VirtualBoxImpl.cpp[535] (nsresult VirtualBox::init()).


Код ошибки:
NS_ERROR_FAILURE (0x80004005)
Компонент:
VirtualBox
Интерфейс:
IVirtualBox {3f36e024-7fed-4f20-a02c-9158a82b44e6}
Помогите пожалйста ламеру)))) и по подробней...

Оффлайн absemetov

  • Автор темы
  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #7 : 25 Февраль 2011, 20:55:01 »
Сори за ламерство.... ну все таки кто нить может помочь: Установил виртуал бокс,запустил XP,после перезагрузки виртуала,вот:NS_ERROR_FAILURE (0x80004005) и не заводиться Бокс... :idiot2: полная форма:
Не удалось создать COM-объект VirtualBox.
Работа приложения будет завершена.
Start tag expected, '<' not found.
Location: '/home/vaha/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.
/build/buildd/virtualbox-ose-3.2.8-dfsg/src/VBox/Main/VirtualBoxImpl.cpp[535] (nsresult VirtualBox::init()).


Код ошибки:
NS_ERROR_FAILURE (0x80004005)
Компонент:
VirtualBox
Интерфейс:
IVirtualBox {3f36e024-7fed-4f20-a02c-9158a82b44e6}
Помогите пожалйста ламеру)))) и по подробней...
Удали полностью виртуалбокс

Добавь соответ репозиторий
deb http://download.virtualbox.org/virtualbox/debian maverick contrib
deb http://download.virtualbox.org/virtualbox/debian lucid contrib
deb http://download.virtualbox.org/virtualbox/debian karmic contrib
deb http://download.virtualbox.org/virtualbox/debian jaunty contrib
deb http://download.virtualbox.org/virtualbox/debian intrepid contrib
deb http://download.virtualbox.org/virtualbox/debian hardy contrib
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib
deb http://download.virtualbox.org/virtualbox/debian lenny contrib
deb http://download.virtualbox.org/virtualbox/debian etch contrib

Ключ
wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-4.0


Оффлайн Deb111

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #8 : 03 Март 2011, 16:08:19 »
У меня в  Дебиан 5.0(lenny) стоит виртуальная машина версии 3.1.2. До сегодняшнего дня она запускалась отлично. И даже с утра запускалась. А в обед пишет  WinXP недостуна. И текст ошибки :
Start tag expected, '<' not found.
Location: '/home/kris/.VirtualBox/Machines/WinXP/WinXP.xml', line 1 (0), column 1.
/home/vbox/vbox-3.1.2/src/VBox/Main/MachineImpl.cpp[5821] (nsresult Machine::loadSettings(bool)).
Код ошибки:
NS_ERROR_FAILURE (0x80004005)
Компонент:
VirtualBox
Интерфейс:
IVirtualBox {2158464a-f706-414b-a8c4-fb589dfc6b62}
 Как можно это исправить,чтоб машина снова заработала?подскажите.
В VirtualBox у меня 2 машины с виндой  Одна запускается нормально,а вторая  с вышеописанной ошибкой.

Оффлайн absemetov

  • Автор темы
  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #9 : 03 Март 2011, 16:15:50 »
У меня в  Дебиан 5.0(lenny) стоит виртуальная машина версии 3.1.2. До сегодняшнего дня она запускалась отлично. И даже с утра запускалась. А в обед пишет  WinXP недостуна. И текст ошибки :
Start tag expected, '<' not found.
Location: '/home/kris/.VirtualBox/Machines/WinXP/WinXP.xml', line 1 (0), column 1.
/home/vbox/vbox-3.1.2/src/VBox/Main/MachineImpl.cpp[5821] (nsresult Machine::loadSettings(bool)).
Код ошибки:
NS_ERROR_FAILURE (0x80004005)
Компонент:
VirtualBox
Интерфейс:
IVirtualBox {2158464a-f706-414b-a8c4-fb589dfc6b62}
Как можно это исправить,чтоб машина снова заработала?подскажите.
В VirtualBox у меня 2 машины с виндой  Одна запускается нормально,а вторая  с вышеописанной ошибкой.


Попробуй заново создать виртуальную машину

Оффлайн Deb111

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #10 : 04 Март 2011, 10:43:35 »
Nadir, спасибище большое! Получилось!   А у вы можете подсказать ,что это могло быть? машина просто глюкнула или что -то  с  файлом *.vdi ?

Оффлайн absemetov

  • Автор темы
  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #11 : 04 Март 2011, 13:31:23 »
Nadir, спасибище большое! Получилось!   А у вы можете подсказать ,что это могло быть? машина просто глюкнула или что -то  с  файлом *.vdi ?
Точно не могу сказать, скорей свего глюк vb.
Не правильная запись в WinXP.xml

*.vdi здесь не причем, ты же не создавал заново жесткий диск?

« Последнее редактирование: 04 Март 2011, 13:33:18 от Nadir »

Оффлайн Deb111

  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #12 : 09 Март 2011, 15:15:15 »
*.vdi здесь не причем, ты же не создавал заново жесткий диск?

нет,не создавал.

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5072
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #13 : 09 Март 2011, 16:27:39 »
Откатываешься на ту версию где работало, делаешь экспорт машин, потом ставишь нужную версию, регишь образ и создаёш машину
Что то они до сих пор не асилили нормально сделать миграцию, мда печаль

Оффлайн Okolom

  • Новичок
  • *
  • Сообщений: 33
  • ubuntu 10.04 LTS
    • Просмотр профиля
Re: Ошибка NS_ERROR_FAILURE (0x80004005) в Virtual Box.
« Ответ #14 : 06 Январь 2012, 23:25:03 »
Не удалось создать COM-объект VirtualBox.
Работа приложения будет завершена.
Start tag expected, '<' not found.
Location: '/home/maksim/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.
/home/vbox/vbox-4.1.8/src/VBox/Main/src-server/VirtualBoxImpl.cpp[485] (nsresult VirtualBox::init()).

Все делал как написано выше. Удалял и переустанавливал
Все равно не работает. В чем же дело? Раньше все работало

 

Страница сгенерирована за 0.084 секунд. Запросов: 23.