Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: HDMI устройство звука не отображается в списке устройств  (Прочитано 889 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн atormon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Здравствуйте!

У меня такая проблема:

после загрузки системы в списке устройств (в pavucontrol) отображается только 1 устройство звука:

1) hd audio

Но должно отображаться еще high defination audio

Если удалить драйвер NVIDIA и поставить стандартный драйвер nouveau, то отображаются два устройства. Так же при установленном драйвере NVIDIA , если после запуска системы в терминале ввести pulseaudio -k , то появляются два устройства.

Мне нужны 2 выхода: линейный для колонок и HDMI  для связи с телевизором (переключая их при надобности).

После установки системы все работало хорошо , но я решил удалить btrfs : btrfs-tools btrfs-progs из-за того , что он тормозил запуск системы. Понимаю , что сам намутил , но может кто подскажет что можно сделать , чтобы все устройства отображались нормально в pavucontrol.




Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1812
    • Просмотр профиля
Мне нужны 2 выхода: линейный для колонок и HDMI  для связи с телевизором
В настройках экрана второй монитор (это телевизор) присоединён ? Без включения двух мониторов на hdmi ничего не будет.

Оффлайн damix

  • Забанен
  • Активист
  • *
  • Сообщений: 664
    • Просмотр профиля
Так ответ же в самом вопросе
удалить драйвер NVIDIA и поставить стандартный драйвер nouveau

Оффлайн atormon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Цитировать
В настройках экрана второй монитор (это телевизор) присоединён ? Без включения двух мониторов на hdmi ничего не будет.
Вы не поняли , у меня нет проблем с видео. Есть проблемы со звуком. Устройство HDMI не отображается в списке устройств после запуска системы, пока не выполнишь pulseaudio -k . Но пока я не начудил в системе , все отображалось. Конечно можно написать скрипт , запускающийся после запуска системы , но это кривой вариант. Хочется понять , как сделать правильно , где произошел сбой и как можно его исправить.
« Последнее редактирование: 04 Сентября 2021, 22:02:56 от atormon »

Оффлайн Aleksandru

  • Администратор
  • Старожил
  • *
  • Сообщений: 3351
    • Просмотр профиля
пока я не начудил в системе , все отображалось. Хочется понять , как сделать правильно , где произошел сбой и как можно его исправить.
Переустановить систему, и больше не чудить.
Intel Core i5-6400, GeForce GT 1030, ASUS ROG Strix B250G Gaming, 16GB RAM, KINGSTON SV300S37A240G, Digma Mega S3 DGSM3512GS33T 512ГБ.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1812
    • Просмотр профиля
Вы не поняли , у меня нет проблем с видео. Есть проблемы со звуком
Проблемы с аудио по HDMI именно от того (в данном случае), что телевизор не обменивается с системой по EDID автоматом, а только вручную после команды. У меня вместо телевизора ресивер, но он играет туже роль, система его обнаруживает. Если в настройках Экран я вижу только монитор, то звук по HDMI естественно никак не выпустить.

Оффлайн atormon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Вчера я вводил множество команд (разные способы описанные в интернете). И уже отчаялся , решил написать скрипт (pulseaudio -k) и добавить его в автозагрузку. Сегодня утром , отключил скрипт и решил описать эту проблему на другом форуме , прикладывая различные логи от команд. Но когда я полез в настройки звука , то обнаружил что все устройства появились даже без скрипта. Я перезагрузил еще раз и все хорошо. К сожалению , я не знаю , что помогло. Возможно одна из команд сработала правильно , но ей необходимо было провести перезагрузку системы. В общем вопрос закрыт.

P.S. Я нигде не видел столь строгой капчи...

 

Страница сгенерирована за 0.074 секунд. Запросов: 25.