Форум русскоязычного сообщества Ubuntu


Автор Тема: установка libusb (i386) для программатора.  (Прочитано 2030 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Привет.
ОС: Ubuntu 20.04.3 (64-bit)
Сам драйвер есть (программатор SAU510-USB).
Дело в том, что перед установкой драйвера он требует 32-битный libusb-1.0.

Из readme на драйвер:
Установка драйверов эмулятора SAU510 в ОС linux
ВНИМАНИЕ!
   На компьютере должна быть установлена библиотека libusb-1.0
   версии не ниже 1.0.5; если она не установлена - установить.
   Требуется только 32-битная ее версия, даже в x86_64 системах.
   по умолчанию она находится в /usr/local/lib. В случае отсутствия
   libusb-1.0 инсталляционный скрипт прервет установку с соответствующим
   сообщением

На всякий случай выполнил:
sudo apt install libusb-1.0-0 libusb-1.0-0-dev
...
Уже установлен пакет libusb-1.0-0 самой новой версии (2:1.0.23-2build1).
Уже установлен пакет libusb-1.0-0-dev самой новой версии (2:1.0.23-2build1).
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 23 пакетов не обновлено.

Запуск установки (что и следовало ожидать) выдаёт:
den@z:~/workspace_v11/doc/SAU_DRV$ sudo ./install.sh
Depedency error, some required libraries not installed:
libusb-1.0.so.0 => not found
Installation terminated

Как установить нужный libusb?

« Последнее редактирование: 17 Декабря 2021, 11:39:08 от de-nos »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5788
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #1 : 17 Декабря 2021, 11:51:34 »
Не "ломай систему". Ничего не устанавливай.
Подключай нужную тебе библиотеку через LD_LIBRARY_PATH.

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #2 : 17 Декабря 2021, 12:23:49 »
Подключай нужную тебе библиотеку через LD_LIBRARY_PATH.
Можно немного подробнее.
И где взять мне нужную 32-битную libusb?
« Последнее редактирование: 17 Декабря 2021, 12:25:25 от de-nos »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5788
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #3 : 17 Декабря 2021, 13:23:36 »
Цитировать
где взять мне нужную 32-битную libusb?
Вариант "в лоб". Берешь 32битную версию системы, ту-же, что у тебя. В ней найдешь все 32битные библиотеки.
Вариант "универсальный". В репозитории, http://archive.ubuntu.com/ubuntu/pool/main/libu/libusb.

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #4 : 17 Декабря 2021, 13:49:55 »
Вариант "универсальный". В репозитории, http://archive.ubuntu.com/ubuntu/pool/main/libu/libusb.
Попробовал. Только мне версия 1.0 нужна, а не 0.1
http://archive.ubuntu.com/ubuntu/pool/main/libu/libusb-1.0/
Скачивал и запускал:
libusb-1.0-0_1.0.24-3build1_i386.deb
libusb-1.0-0-dev_1.0.24-3build1_i386.deb
При запуске deb, установщик предлагает только удалить библиотеку.
Ну, а установщик драйвера для программатора так же:
libusb-1.0.so.0 => not found

PS: А, с вариантом "влоб" предлагаешь параллельно поставить ещё одну (32)?

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5788
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #5 : 17 Декабря 2021, 14:22:57 »
Цитировать
При запуске deb, установщик предлагает...
Ведь сразу-же сказал:
Цитировать
Не "ломай систему". Ничего не устанавливай.
Просто копирование.
А вообще, начни с поиска про LD_LIBRARY_PATH.

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #6 : 17 Декабря 2021, 18:47:20 »
Просто копирование.
А вообще, начни с поиска про LD_LIBRARY_PATH.
С LD_LIBRARY_PATH понятно. Нужно добавить путь к библиотеке в один из файлов каталога /etc/ld.so.conf.d
Вопрос, где взять саму библиотеку.

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5788
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #7 : 18 Декабря 2021, 07:24:19 »
"Повторение - мать учения."
Цитировать
добавить путь к библиотеке в один из файлов каталога /etc/ld.so.conf.d
Один из возможных вариантов. Другой вариант. Задавать переменную при запуске программы. Например, если программа запускается враппером, то в нем и задавать переменнную. Опять-же, не "ломает систему". Позволяет оперативно менять значение, например при "отладке".
Цитировать
где взять саму библиотеку
Повторяю. "В лоб". Берешь 32битный образ системы и используешь его как источник 32битных библиотек, чтобы не выискивать их в репозиториях. Вполне возможно, что это не единственняя библиотека, которая понадобится.
Собственно, точнее вопрос звучит не "где", а "как". Никаких установок (хотя можно идти и по этому варианту), просто копирование. Деб-пакет у тебя есть, извлекай из него.
На примере Midnight commander:

« Последнее редактирование: 18 Декабря 2021, 07:44:40 от andytux »

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #8 : 18 Декабря 2021, 09:28:09 »
Деб-пакет у тебя есть, извлекай из него.
Извлек в тот же каталог, где он находится в deb: /usr/lib/i386-linux-gnu
Этот каталог уже есть в LD_LIBRARY_PATH (ничего не менял).
den@z:~/workspace_v11/doc/SAU_DRV$ sudo ./install.sh
Depedency error, some required libraries not installed:
./opt/sauris/bin/sau_proxy: /lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by /lib/i386-linux-gnu/libusb-1.0.so.0) libudev.so.1 => not found
Installation terminated
/lib/i386-linux-gnu/libc.so.6 присутствует.
Версия не нравится?

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5788
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #9 : 18 Декабря 2021, 10:46:34 »
Ясно-же сказано:
Цитировать
Depedency error, some required libraries not installed
То, что где-то там присутствует, не означает, что оно "существует" для данной, конкретной программы. Вполне возможно, что программа хочет конкретную версию библиотеки. Это скорее всего потребует, чтобы все GLIBC-библиотеки были этой версии.
Тебе тоже сообщает не об единственной "отсутствующей библиотеке".
Что вообще там делает твой install.sh.
Возможно, нужно погружаться глубже libc.so.6, к ld-linux.so.2.

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #10 : 18 Декабря 2021, 15:46:20 »
Что вообще там делает твой install.sh.
Я не настолько продвинут, чтобы понять, что sh там делает.
https://sauris.de/index.php/ru/zagruzki/sau510-usb-iso-plus-jtag-emulator
Пытаюсь запустить эту:
http://sauris.de/software-documentation/sau_drv-1.0.2.tar.gz
Под винду у народа работает без проблем. Но я принципиально не хочу винду юзать.
Куда смотреть?

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #11 : 21 Декабря 2021, 02:53:09 »
Возможно, нужно погружаться глубже libc.so.6, к ld-linux.so.2.
Не совсем понятно о чём речь. ld-linux.so.2 находится там же (/lib/i386-linux-gnu).
Если есть какие-либо соображения, внимательно слушаю.

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5788
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #12 : 21 Декабря 2021, 05:52:37 »
Слушаешь, но не слышишь. Уже повторял, процитирую еще раз:
Цитировать
То, что где-то там присутствует, не означает, что оно "существует" для данной, конкретной программы.

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5853
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #13 : 21 Декабря 2021, 09:02:43 »
перед установкой драйвера он требует 32-битный libusb-1.0.
sudo dpkg --add-architecture i386
sudo apt update
sudo apt install libusb-1.0-0:i386
« Последнее редактирование: 21 Декабря 2021, 09:04:49 от БТР »

Оффлайн de-nos

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: установка libusb (i386) для программатора.
« Ответ #14 : 21 Декабря 2021, 15:38:04 »
sudo dpkg --add-architecture i386
sudo apt update
sudo apt install libusb-1.0-0:i386
Да, это одно из первых действий, которые я сделал, но результат нулевой.

В общем, скачал libc6_2.34-0ubuntu3_i386.deb и от туда выдернул всё что было.
Установка драйвера программатора прошла до конца. Пока не уверен, что всё нормально (IDE видит но, не прошивает).

Благодарю, andytux и всех кто участвовал.

 

Страница сгенерирована за 0.026 секунд. Запросов: 21.