Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Bluetooth наушники не работают в режиме гарнитуры (HSP/HFP)  (Прочитано 1860 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Здравствуйте! Имеются:
наушники Mi True Wireless Earphones
bluetooth адаптер Buro BU-BT40A
(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)


При попытке выбрать в настройках blueman профиль "Гарнитура (HSP/HFP)" выводит:
Failed to change profile to headset_head_unit

При выборе профиля "Запись высокого качества (передатчик A2DP)":
Failed to change profile to a2dp_source

Единственное, что работает, это "Воспроизведение высокого качества (приёмник A2DP)".

Как оживить профиль "Гарнитура (HSP/HFP)"? Мне нужен микрофон.

На том же ПК на Windows и на смартфоне Android наушники работают в режиме гарнитуры.
« Последнее редактирование: 21 Сентябрь 2021, 19:16:16 от Bill Williamson »

Оффлайн damix

  • Активист
  • *
  • Сообщений: 608
    • Просмотр профиля
Bill Williamson,
bluetoothctl info
pacmd list-cards
lsusb -v

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Bill Williamson,
bluetoothctl info
pacmd list-cards
lsusb -v

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)



Пользователь добавил сообщение 23 Сентябрь 2021, 13:15:02:
lsusb -v
« Последнее редактирование: 23 Сентябрь 2021, 13:15:02 от Bill Williamson »

Оффлайн damix

  • Активист
  • *
  • Сообщений: 608
    • Просмотр профиля
dpkg -l | grep 'ofono'
Если попробовать собрать лог
cp /etc/pulse/* ~/.config/pulse/
echo autospawn = no >> ~/.config/pulse/client.conf
killall pulseaudio

Запустить pulseaudio
LANG=C pulseaudio -vvvv
А потом в другом окне терминала попробовать переключить профиль
pacmd set-card-profile 2 headset_head_unit
Что в этот момент выведет в первом окне? Остановить pulseaudio - Ctrl+C.

А если в файле ~/.config/pulse/default.pa строчку
load-module module-bluetooth-discoverпоправить так
load-module module-bluetooth-discover headset=native
И опять запустить pulseaudio в командной строке и попробовать переключить профиль, вывод как-то меняется?

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
dpkg -l | grep 'ofono'
Вывод пустой.

cp /etc/pulse/* ~/.config/pulse/
cp: не указан -r; пропускается каталог '/etc/pulse/client.conf.d'
Пускай.

echo autospawn = no >> ~/.config/pulse/client.conf
killall pulseaudio

Запустить pulseaudio
Код: [Выделить]
LANG=C pulseaudio -vvvv
Сделал и вывод такой:
(Нажмите, чтобы показать/скрыть)


А потом в другом окне терминала попробовать переключить профиль
Код: [Выделить]
pacmd set-card-profile 2 headset_head_unit
В другой вкладке ввёл:
(Нажмите, чтобы показать/скрыть)


Что в этот момент выведет в первом окне?
Повторил команду на первой вкладке:
(Нажмите, чтобы показать/скрыть)


load-module module-bluetooth-discover headset=native
71 строчка:
(Нажмите, чтобы показать/скрыть)

killall pulseaudio

Запустить pulseaudio
Код: [Выделить]
LANG=C pulseaudio -vvvv
Сделал снова так. Вывод:
(Нажмите, чтобы показать/скрыть)

pacmd set-card-profile 2 headset_head_unit
Снова так. Вывод:
(Нажмите, чтобы показать/скрыть)

Ну и LANG=C pulseaudio -vvvv выдаёт одно и тоже.
« Последнее редактирование: 26 Сентябрь 2021, 23:52:57 от Bill Williamson »

Оффлайн Morisson

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 4785
    • Просмотр профиля
При попытке выбрать в настройках blueman профиль "Гарнитура (HSP/HFP)" выводит
А зачем с gnome вы используете blueman?
На реддит нашел типа решение. Попробуйте.
sudo apt install ubuntu-restricted-extras

Оффлайн Morisson

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 4785
    • Просмотр профиля

Оффлайн damix

  • Активист
  • *
  • Сообщений: 608
    • Просмотр профиля
ls -l /etc/pulse
ls -l ~/.config/pulse/

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
ls -l /etc/pulse
(Нажмите, чтобы показать/скрыть)

ls -l ~/.config/pulse/
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 29 Сентябрь 2021, 17:33:07:
https://www.reddit.com/r/airdots/comments/grl03a/ubuntu_not_recognize_microphone_in_xiaomi_mi_true/
Попробовал ввести sudo apt install ubuntu-restricted-extrasНе помогло. Ошибки те же.

Пользователь добавил сообщение 29 Сентябрь 2021, 21:53:05:
А зачем с gnome вы используете blueman?
Blueman хотя бы вывел какие-то ошибки при переключении.
В настройках системы выбираешь HSP/HFP и никакой реакции. Переходишь на другую вкладку настроек, потом возвращаешься обратно - а там опять a2dp.
« Последнее редактирование: 29 Сентябрь 2021, 21:53:05 от Bill Williamson »

Оффлайн damix

  • Активист
  • *
  • Сообщений: 608
    • Просмотр профиля
Bill Williamson, неправильные я команды дал, в новой Ubuntu поменяли файлы cp -rf /etc/pulse/* ~/.config/pulse/
ls ~/.config/pulse/client.conf.d/*
что выдает?

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
ls ~/.config/pulse/client.conf.d/*
Красным:
/home/username/.config/pulse/client.conf.d/01-enable-autospawn.conf

Оффлайн damix

  • Активист
  • *
  • Сообщений: 608
    • Просмотр профиля
cat /home/username/.config/pulse/client.conf.d/01-enable-autospawn.conf
cat /home/username/.config/pulse/client.conf

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
cat /home/username/.config/pulse/client.conf.d/01-enable-autospawn.conf
cat: /home/username/.config/pulse/client.conf.d/01-enable-autospawn.conf: Нет такого файла или каталогаНо файл там есть. При попытке открыть через Nautilus:
(Нажмите, чтобы показать/скрыть)

cat /home/username/.config/pulse/client.conf
(Нажмите, чтобы показать/скрыть)

Оффлайн damix

  • Активист
  • *
  • Сообщений: 608
    • Просмотр профиля
Bill Williamson, замените в файле /home/username/.config/pulse/client.conf
строчку ; autospawn = yes на autospawn = no затем дайте команду pulseaudio -k звук должен упасть.
Если это так
LANG=C pulseaudio -vvvv
звук должен снова появиться, а терминал выведет стену текста, ее копировать не обязательно. Команда должна не завершиться, а продолжить выполняться, т.е. следующую команду можно будет ввести только в новом окне. Подключите наушники по блютусу и
pacmd set-card-profile 2 headset_head_unit
Тогда в первом окне появится что-то новое, это лог, его надо сюда скопировать. Ну и вывод во втором окне тоже желательно. Потом в первом окне нажать Ctrl+C, звук опять упадет.

А потом тот же самый эксперимент (начиная с LANG=C pulseaudio -vvvv), только перед этим в  ~/.config/pulse/default.pa строчку
load-module module-bluetooth-discoverпоправить так
load-module module-bluetooth-discover headset=native

Оффлайн Bill Williamson

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
autospawn = no
(Нажмите, чтобы показать/скрыть)

звук должен упасть.
Пропадает на доли секунды.

Команда должна не завершиться, а продолжить выполняться
Нет. Получаю завершение с ошибкой после этого:
(Нажмите, чтобы показать/скрыть)

pacmd set-card-profile 2 headset_head_unit
Failed to set card profile to 'headset_head_unit'.
Дальше продолжать не стал, т.к. LANG=C pulseaudio -vvvv не срабатывает как ожидается.

 

Страница сгенерирована за 0.159 секунд. Запросов: 25.