Форум русскоязычного сообщества Ubuntu


Автор Тема: При обработке следующих пакетов произошли ошибки: libstb0:amd64 libfaudio0:amd  (Прочитано 962 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн brizz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Добрый день!
Никак не могу решить проблему вот с этим:
При обновлении пишет:

E: libstb0: 58.8235:пакет libstb0:amd64 не может быть настроен, так как не готов libstb0:i386 (текущее состояние: «half-installed»)
E: libfaudio0: 70.5882:проблемы зависимостей — оставляем не настроенным

В терминале при попытке установить libstb0:i386:

dpkg: ошибка при обработке пакета libfaudio0:amd64 (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libstb0:amd64
 libfaudio0:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
Испробовал много советов решения подобных проблем, но ничего не получается.

Что делать?
« Последнее редактирование: 28 Июль 2021, 18:28:18 от Aleksandru »

Онлайн c47

  • Участник
  • *
  • Сообщений: 156
    • Просмотр профиля
Испробовал много советов решения подобных проблем, но ничего не получается.

Что делать?
Добрый день!
Сказать что пробовал и что выдавала консоль
попробовать
sudo dpkg-reconfigure libstb0 libfaudio0
sudo apt --fix-broken install

Показать вывод
inxi -F
Не кормите тролля

Оффлайн shamanhuev

  • Активист
  • *
  • Сообщений: 363
    • Просмотр профиля
В терминале при попытке установить libstb0:i386:
ошибка при обработке пакета libfaudio0:amd64 (--configure):

Оффлайн brizz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
victor@victor-EG31M-S2:~$ sudo dpkg-reconfigure libstb0 libfaudio0
[sudo] пароль для victor:       
/usr/sbin/dpkg-reconfigure: Пакет libstb0 сломан или установлен не полностью
victor@victor-EG31M-S2:~$ sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 0 B/200 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 0 B.
dpkg: ошибка при обработке пакета libstb0:amd64 (--configure):
 пакет libstb0:amd64 не может быть настроен, так как не готов libstb0:i386 (текущее состояние: «half-installed»)
dpkg: зависимости пакетов не позволяют настроить пакет libfaudio0:amd64:
 libfaudio0:amd64 зависит от libstb0 (>= 0.0~git20180212.15.e6afb9c), однако:
  Пакет libstb0:amd64 пока не настроен.

dpkg: ошибка при обработке пакета libfaudio0:amd64 (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libstb0:amd64
 libfaudio0:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
victor@victor-EG31M-S2:~$ inxi -F
System:
  Host: victor-EG31M-S2 Kernel: 5.4.0-80-generic x86_64 bits: 64
  Desktop: Cinnamon 5.0.5 Distro: Linux Mint 20.2 Uma
Machine:
  Type: Desktop Mobo: Gigabyte model: EG31M-S2 v: x.x
  serial: <superuser/root required> BIOS: Award v: FCd date: 05/25/2009
CPU:
  Topology: Quad Core model: Intel Xeon E5450 bits: 64 type: MCP
  L2 cache: 6144 KiB
  Speed: 2000 MHz min/max: 2000/3000 MHz Core speeds (MHz): 1: 2000 2: 2000
  3: 2000 4: 2000
Graphics:
  Device-1: AMD Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] driver: radeon
  v: kernel
  Display: x11 server: X.Org 1.20.9 driver: ati,radeon
  unloaded: fbdev,modesetting,vesa resolution: 1280x1024~60Hz
  OpenGL: renderer: AMD TAHITI (DRM 2.50.0 5.4.0-80-generic LLVM 11.0.0)
  v: 4.5 Mesa 20.2.6
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio
  driver: snd_hda_intel
  Device-2: AMD Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970]
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-80-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: down mac: 00:1f:d0:9b:63:34
  Device-2: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
  IF: wlx6470021e3d51 state: up mac: 64:70:02:1e:3d:51
Drives:
  Local Storage: total: 1.96 TiB used: 462.16 GiB (23.0%)
  ID-1: /dev/sda vendor: Seagate model: ST3160811AS size: 149.05 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WD20EARX-00PASB0
  size: 1.82 TiB
Partition:
  ID-1: / size: 145.22 GiB used: 30.64 GiB (21.1%) fs: ext4 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 62.0 C mobo: N/A gpu: radeon temp: 49 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 229 Uptime: 4h 46m Memory: 3.84 GiB used: 1.62 GiB (42.3%)
  Shell: bash inxi: 3.0.38
victor@victor-EG31M-S2:~$
« Последнее редактирование: 28 Июль 2021, 18:29:43 от Aleksandru »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2557
    • Просмотр профиля
sudo apt install -fsudo dpkg --configure -asudo apt install --reinstall libgcc1
« Последнее редактирование: 28 Июль 2021, 16:59:37 от Dzhoser »

Оффлайн brizz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
victor@victor-EG31M-S2:~$ sudo apt install -f
[sudo] пароль для victor:       
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 0 B/200 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 0 B.
dpkg: ошибка при обработке пакета libstb0:amd64 (--configure):
 пакет libstb0:amd64 не может быть настроен, так как не готов libstb0:i386 (текущее состояние: «half-installed»)
dpkg: зависимости пакетов не позволяют настроить пакет libfaudio0:amd64:
 libfaudio0:amd64 зависит от libstb0 (>= 0.0~git20180212.15.e6afb9c), однако:
  Пакет libstb0:amd64 пока не настроен.

dpkg: ошибка при обработке пакета libfaudio0:amd64 (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libstb0:amd64
 libfaudio0:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
victor@victor-EG31M-S2:~$ sudo dpkg --configure -a
dpkg: ошибка при обработке пакета libstb0:amd64 (--configure):
 пакет libstb0:amd64 не может быть настроен, так как не готов libstb0:i386 (текущее состояние: «half-installed»)
dpkg: зависимости пакетов не позволяют настроить пакет libfaudio0:amd64:
 libfaudio0:amd64 зависит от libstb0 (>= 0.0~git20180212.15.e6afb9c), однако:
  Пакет libstb0:amd64 пока не настроен.

dpkg: ошибка при обработке пакета libfaudio0:amd64 (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libstb0:amd64
 libfaudio0:amd64
victor@victor-EG31M-S2:~$


Пользователь добавил сообщение 28 Июль 2021, 17:02:43:
Э.... Видимо нужно (проще) переустановить систему?
« Последнее редактирование: 28 Июль 2021, 18:30:17 от Aleksandru »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2557
    • Просмотр профиля
sudo dpkg --add-architecture i386sudo apt update && sudo apt upgrade -ysudo apt autoclean sudo apt install --reinstall libstb0:i386sudo apt install -f
« Последнее редактирование: 28 Июль 2021, 17:13:55 от Dzhoser »

Оффлайн brizz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Я скопировал результат только последней команды

dpkg: ошибка при обработке пакета libfaudio0:amd64 (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libstb0:amd64
 libfaudio0:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
vi
« Последнее редактирование: 28 Июль 2021, 18:30:44 от Aleksandru »

Оффлайн shamanhuev

  • Активист
  • *
  • Сообщений: 363
    • Просмотр профиля
sudo apt autoclean
Пора бы подзабыть эту команду , третье слово надо укоротить до clean

Оффлайн brizz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
victor@victor-EG31M-S2:~$ sudo apt autoclean
[sudo] пароль для victor:       
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
victor@victor-EG31M-S2:~$

А как проверить, убедиться что все получилось? и получилось ли?

Пользователь добавил сообщение 28 Июль 2021, 18:19:08:
Всем спасибо!

Если не сработало - переустановлю линукс.
Если сработало, еще раз большое спасибо!

Тему можно закрыть.
« Последнее редактирование: 28 Июль 2021, 18:31:59 от Aleksandru »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2557
    • Просмотр профиля
Пора бы подзабыть эту команду , третье слово надо укоротить до clean
Поясните

Оффлайн shamanhuev

  • Активист
  • *
  • Сообщений: 363
    • Просмотр профиля
Поясните
Насколько помню , когда то под командой autoclean подразумевалась очистка кэша пакетов. Теперь это делает команда clean.

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2557
    • Просмотр профиля
apt autoclean-это подмножество apt clean

из руководства apt-get

clean
очистка удаляет локальное хранилище извлеченных файлов пакетов. Он удаляет все, кроме файла блокировки, из /var/cache/apt/archives/ и /var/cache/apt/archives/partial/

autoclean

Как и clean, autoclean очищает локальное хранилище извлеченных файлов пакетов. Разница в том, что он удаляет только файлы пакетов, которые больше нельзя загрузить и которые в значительной степени бесполезны.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27728
    • Просмотр профиля
shamanhuev, не надо бредить. Это две разные команды.

Пользователь добавил сообщение 29 Июль 2021, 22:58:44:
brizz,
dpkg --purge libstb0:i386
apt install libstb0
« Последнее редактирование: 29 Июль 2021, 22:58:44 от AnrDaemon »
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн brizz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Спасибо!
Я переустановился.

 

Страница сгенерирована за 0.1 секунд. Запросов: 21.