Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: apache2  (Прочитано 556 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн slaviart

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
apache2
« : 08 Февраля 2009, 00:17:52 »
Как настроить что бы apache нормально воспринимал код находящийся в тэгах <?php ?> но при этом в файле *.html

index.html

<?php
             
echo "Drink Bear";
?>


Оффлайн slaviart

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: apache2
« Ответ #1 : 08 Февраля 2009, 02:27:07 »
up

Оффлайн Glebsan

  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: apache2
« Ответ #2 : 08 Февраля 2009, 09:49:14 »
/etc/apache2/mods-enabled/php5.conf
В строчку AddType application/x-httpd-php .php .phtml .php3
добавляем нужные расширения.

Есть по-моему вариант через .httaccess, но я не знаю как - знает гугл, но можно и так
Comple Promissum

Оффлайн Glebsan

  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: apache2
« Ответ #3 : 08 Февраля 2009, 09:58:37 »
Нашел... В .htaccess добавляем
AddHandler application/x-httpd-php .php .htm .html .phtmlИ конфиг можно не трогать  :coolsmiley:
Comple Promissum

Оффлайн slaviart

  • Автор темы
  • Участник
  • *
  • Сообщений: 101
    • Просмотр профиля
Re: apache2
« Ответ #4 : 08 Февраля 2009, 11:28:59 »
Спасибо большое:)

 

Страница сгенерирована за 0.048 секунд. Запросов: 23.