Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Linux 2.6.28 в Ubuntu  (Прочитано 1764 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Archimonde

  • Автор темы
  • Участник
  • *
  • Сообщений: 111
    • Просмотр профиля
Linux 2.6.28 в Ubuntu
« : 01 Января 2009, 22:29:16 »
Привет всем
На днях собрал новое ядро. Все чудесно работает )) Вопрос то собственно вот какой:
Я создал папку /usr/src/linux-2.6.28. Настроил все, скомпилил. Сделал deb-пакеты. Установил. Можно ли теперь удалять эту папку? А то уж много места она ест ;-)

Оффлайн ende_neu

  • Старожил
  • *
  • Сообщений: 2473
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #1 : 01 Января 2009, 22:34:17 »
Да.

Оффлайн Archimonde

  • Автор темы
  • Участник
  • *
  • Сообщений: 111
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #2 : 01 Января 2009, 22:40:57 »
Спасибо )

Оффлайн Don Kanonji

  • Участник
  • *
  • Сообщений: 139
  • Free your Mind
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #3 : 10 Января 2009, 12:46:55 »
Подниму тему.
Собрал 2.26.8. Собирал вот так - http://blogs.cetki.com/vitek/8161/
При установке пакетов получил вот такую красоту. Вопрос, конечно, дурацкий, но в чем ошибка?
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms
run-parts: executing /etc/kernel/postinst.d/nvidia-common
run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 20
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.28.postinst line 1181.
dpkg: не удалось обработать параметр linux-image-2.6.28 (--install):
 подпроцесс post-installation script возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
 linux-image-2.6.28
Гугление помогло найти немецких убунтоидов, которые посоветовали удалить все это и собрать еще раз, пропатчив при этом.

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #4 : 10 Января 2009, 13:42:23 »
А что мешает поставить концентрированое ядро из пакетов?
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн droid8622

  • Новичок
  • *
  • Сообщений: 30
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #5 : 13 Января 2009, 03:05:24 »
Дааа,круто! Я бы тоже хотел,но боюсь рисковать уже нажитой системой,как понимаю,процесс сложноватый

Оффлайн Deathrose

  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #6 : 13 Января 2009, 11:59:24 »
Подниму тему.
Собрал 2.26.8. Собирал вот так - http://blogs.cetki.com/vitek/8161/
При установке пакетов получил вот такую красоту. Вопрос, конечно, дурацкий, но в чем ошибка?

Гугление помогло найти немецких убунтоидов, которые посоветовали удалить все это и собрать еще раз, пропатчив при этом.

ну так dkms пытается собрать модуль драйвера видюхи..)))

собственно либо отрубать dkms в принципе либо править конфиги в указанной папке..)))

Оффлайн kotnaton

  • Участник
  • *
  • Сообщений: 149
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #7 : 15 Января 2009, 14:20:14 »
Привет всем
На днях собрал новое ядро. Все чудесно работает )) Вопрос то собственно вот какой:
Я создал папку /usr/src/linux-2.6.28. Настроил все, скомпилил. Сделал deb-пакеты. Установил. Можно ли теперь удалять эту папку? А то уж много места она ест ;-)

Опасаюсь, что поздно пишу: лучше сохранить эту папку в неприкосновенности: вам могут эти прекомпилированные сурцы еще понадобиться, например, если захотите ставить новый драйвер... Вот тут вам действительно ОЧЕНЬ СИЛЬНО понадобятся эти вещи...
Цитировать
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
kernel includes at /lib/modules/2.6.28/build/include not found or incomplete
file: /lib/modules/2.6.28/build/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
Это у меня, знаете-ли новый драйвер разошелся: прекомпилят ему, видите-ли, подавайте...
Проверяйте скачанные iso-шники командой: md5sum -c MD5SUMS.txt

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #8 : 15 Января 2009, 15:15:16 »
Как при  сборке GEM отметить ? Как он называется?
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн kotnaton

  • Участник
  • *
  • Сообщений: 149
    • Просмотр профиля
Re: Linux 2.6.28 в Ubuntu
« Ответ #9 : 16 Января 2009, 06:17:36 »
А зачем там что-то отмечать ? :coolsmiley: Все прекрасно работает и так; я стараюсь как можно меньше копаться в menuconfig... Только когда точно знаю, что хочу.
Проверяйте скачанные iso-шники командой: md5sum -c MD5SUMS.txt

 

Страница сгенерирована за 0.073 секунд. Запросов: 23.