Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: сетевой мост работает в одну сторону  (Прочитано 1122 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн meinung

  • Автор темы
  • Активист
  • *
  • Сообщений: 316
  • in nomine patris et fili et spiritus sancti amen.
    • Просмотр профиля
Re: сетевой мост работает в одну сторону
« Ответ #15 : 14 Январь 2012, 07:58:48 »
KT315,после добавления   маршрутов в  таблицы систуация не меняется.   подозрение  есть на  то что   умудрился  что то  накосячить с системой. я  переустановлю все с нуля  и попробую. Дело  в том, что  я  не  могу  со стороны ra0  объединенного  через  мост br0  получить  даже в локальную сеть доступ.  я не  могу посмотреть локальный веб сервер  не  гворя   уже об  веб морде модема. он (мост)  для   этого и делается, чтобы  имелась возможность  подключенным  к  беспроводной  сети   иметь доступ к  устройстам, находящимся в проводной сети (веб  морда модема  к примеру) этого   ничего нету

Пользователь решил продолжить мысль 14 Январь 2012, 10:20:20:
что-то не так  с самим мостом. Как только определяется  мост так все,  сетевая  конфигурация не подхватывается при  включении

Пользователь решил продолжить мысль 14 Январь 2012, 16:34:17:
KT315, посмотрите пожалуйста  файл interfaces. мне  кажется  что  там ошибка, система   запускается очень долго


Пользователь решил продолжить мысль 14 Январь 2012, 21:33:39:
вот  в таком   раскладе  работает   идеально  за  тем редким  случаем,  когда  отпадает   одна из сессий
(Нажмите, чтобы показать/скрыть)
как  только сцепляю в мост ra0  с  eth0  начинается свистопляска   при загрузке  ос   пишет waiting up 60 seconds to network  configuration   ПомОГИТЕ!!!!
« Последнее редактирование: 14 Январь 2012, 21:33:39 от meinung »
just read this flowing manual

Гарри Кашпировский

  • Гость
Re: сетевой мост работает в одну сторону
« Ответ #16 : 14 Январь 2012, 23:29:11 »
waiting up 60 seconds to network  configurationС мостом конфигурацию покажи. Явно там грабли.

Оффлайн meinung

  • Автор темы
  • Активист
  • *
  • Сообщений: 316
  • in nomine patris et fili et spiritus sancti amen.
    • Просмотр профиля
Re: сетевой мост работает в одну сторону
« Ответ #17 : 14 Январь 2012, 23:35:55 »
KT315, с мостом /etc/network/interfaces  в  первом посте.  добавление    локльной  сети в FIR и SEC   не  помогает. тнетрнет работает  и  без  этих записей через провод
just read this flowing manual

Гарри Кашпировский

  • Гость
Re: сетевой мост работает в одну сторону
« Ответ #18 : 14 Январь 2012, 23:51:08 »
Понятно. Если добавлять в мост устройства руками (через brctl) ?
Т.е сначала сконфигурировать беспроводную часть, (кроме IP-адреса) затем добавить eth0 и ra0 в бридж.
А судя по интерфейсес, сначала поднимается мост, а затем конфигурируется радио.
Но это уже из метода, а что если сделать все в обратном порядке. Шаманство, да.
Из-за этого я сразу отказался от SoftAP. Железками надёжнее и удобнее.

Оффлайн meinung

  • Автор темы
  • Активист
  • *
  • Сообщений: 316
  • in nomine patris et fili et spiritus sancti amen.
    • Просмотр профиля
Re: сетевой мост работает в одну сторону
« Ответ #19 : 15 Январь 2012, 00:38:23 »
brctrl    не пробовал.  отпишусь, как  попробую  в приницпе  я  пробовал но не  все виды  шаманства
just read this flowing manual

Оффлайн honeybeer

  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Re: сетевой мост работает в одну сторону
« Ответ #20 : 15 Январь 2012, 01:12:57 »
в hostapd про мост добавили?
interface=ra0
bridge=br0
driver=nl80211
« Последнее редактирование: 15 Январь 2012, 01:15:21 от honeybeer »
ASUS Sandy/Ivy Bridge + PCI = Nobody cares
Ciao mina-san

Оффлайн meinung

  • Автор темы
  • Активист
  • *
  • Сообщений: 316
  • in nomine patris et fili et spiritus sancti amen.
    • Просмотр профиля
Re: сетевой мост работает в одну сторону
« Ответ #21 : 15 Январь 2012, 01:20:20 »
honeybeer, у меня нету hostapd у  меня  ралинковская  игрушка  она в AD-HOC  работает под типа AP  те  при включении  сервера   появляется в списке    сетей  доступных для связи но  в IWconfig  mode AD-HOC
в общем  поставил я мост. но локалку видит только сервак   те 10.117.254.4  остальные   не  видить вот такие  команды на   роутинг отдавал бесполезно
ip r a 10.117.0.0/24 dev br0 src 10.117.254.4 t (FIR/SEC) в обе таблицы
 временный вариант  ударил в голову    таблесами  сделать to-destination

Пользователь решил продолжить мысль 15 Январь 2012, 01:43:56:
не  помогло iptables -t nat -A PREROUTING -p tcp -i ra0 --dport 1717 -j DNAT --to-destination 10.117.254.1:80  :(
« Последнее редактирование: 15 Январь 2012, 03:00:32 от meinung »
just read this flowing manual

 

Страница сгенерирована за 0.039 секунд. Запросов: 21.