Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ubuntu 14.04 не даёт поменять разрешение монитора  (Прочитано 4183 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн swampy_earl

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
    • Просмотр профиля
К сожалению, при попытке загрузить официальный драйвер от AMD происходят какие-то ошибки и сбои... Я полагаю, что его уже просто нет на официальном сайте. Может, у кого-нибудь остался в запасе; в домашнем архиве?  :)

Ребята, может быть всё-таки есть шанс, завести параметр scale на моей системе? Мне он прям жутко необходим!  :)

Конечно, можно попробовать прописать через grub разрешение 800x600 "железно", но это совсем последний вариант. Так-то мне нравится 1024x768, всё хорошо, только курсор маленький и оконтовочка у рабочих окон маленькая, ах да и ещё кнопочки управления "закрыть, свернуть, развернуть" тоже маленькие. За всё это хозяйство как раз отвечает параметр scale, который никак не хочет работать.

Ubuntu 14.04 - клёвая система; и Unity 7 была очень клёвой оболочкой на самом деле. Жаль, что никто сейчас не пытается сделать хороший, крепкий "форк" с таким вот интерфейсом для Ubuntu 20.04.

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4707
    • Просмотр профиля
Цитировать
Unity 7 была очень клёвой оболочкой на самом деле. Жаль, что никто сейчас не пытается сделать хороший, крепкий "форк" с таким вот интерфейсом для Ubuntu 20.04.
Загляни сюда.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3150
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
К сожалению, при попытке загрузить официальный драйвер от AMD происходят какие-то ошибки и сбои... Я полагаю, что его уже просто нет на официальном сайте. Может, у кого-нибудь остался в запасе; в домашнем архиве?
Дружище swampy_earl, не считай себя самым умным и не держи нас всех тут за дураков. Я тебе адресовал уже два комментария выше по поводу официального драйвера АМД. Могу не полениться и в третий раз - вот простая консольная команда, по которой архив с драйвером скачивается с официального сайта АМД без проблем:
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip
Я странен, а не странен кто ж? (С)

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4707
    • Просмотр профиля
Цитировать
кнопочки управления "закрыть, свернуть, развернуть" тоже маленькие
Так ведь можно немного пошалить.

Кнопки - это картинки в каталоге unity. Подменяешь на нужные тебе.
К слову, в 10.04  отмасштабировал с помошью изменения dpi в конфигах.
« Последнее редактирование: 15 Июль 2021, 06:51:31 от andytux »

Оффлайн swampy_earl

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
    • Просмотр профиля
AlexBKost - В первую очередь - спасибо Вам огромное, что выпустили эту статью в своём блоге на kubuntu.ru. Там всё доходчиво и ясно написано; отличная, очень полезная статья. Всё чётко изложено, как "завести" официальный драйвер AMD на старых версиях Ubuntu 2014-2015 года.

Это хорошо! Но я столкнулся с серьёзными проблемами. И конечно, я не пытаюсь никого тут обдурить. Просто, несмотря на 7-летний стаж работы с Ubuntu, я всё ещё новичок, и некоторые вещи сложны для меня.

Итак, проблемы и ошибки, о которых я говорил выше:

1) Система Ubuntu 14.04.6 не приняла пакеты libqtgui4 и xserver-xorg-dev в связи со "столкновением зависимостей". Но я не обратил на это внимания и пошёл дальше.  :)

2) Тот самый патч для "дровишек" не скачивается! Терминал говорит, что его просто нет на сервере. Видимо, Ваш патч был удалён или перемещён. Мне ничего не оставалось делать - я пошёл дальше.  :)

3) Я запустил инсталлятор драйвера crimson, и выбрал процесс кастомного построения пакетов, для Ubuntu/trusty. Пакеты были сгенерированы должным образом. Я их запустил... Но система их не приняла. Причина всё та же - "столкновение зависимостей". А конкретно, с пакетом "xorg-xcore-что-то там"

4) Я выполнил ту же самую процедуру через терминал, как в Вашей статье - тот же самый результат. Ошибка, "столкновение зависимостей".

Наверное, надо было всё-таки пропатчить драйвер. Может быть, у Вас остался этот патч, AlexBKost? Или Вы знаете, где его скачать? Просто по старому адресу "он больше не проживает..." Спасибо за терпение  ;)

andytux - Прикольный способ Вы подсказали, с заменой картинок для кнопок "закрыть, свернуть". Никогда раньше не слышал о таком. Надо будет попробовать, если драйвер не заведётся на моей системе, постараюсь сделать.  :)

По поводу Вашей ссылки на оболочку Unity 7 для современных ОС Ubuntu... К сожалению, это ложный путь. Конечно, ребята которые этим занимаются молодцы, но, во-первых, эта программа вредна для системы Ubuntu 20.04 - у меня начались баги, с тех пор как я скачал её полгода назад. Во-вторых, она всё равно выглядит криво и некрасиво. Видно, что её просто грубо "натянули" на современное графическое окружение, словно текстуру на модель.

Я говорил о другом. Как было бы круто, если бы энтузиасты сделали кастомный билд Ubuntu 20.04 с нативным графическим окружением Mir и полной графической поддержкой Unity 7/8. Ну знаете, как ввыпускали с 2014 по 2017 годы кастомные билды с "гномом 3" вместо "Юнити".

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4707
    • Просмотр профиля
Цитировать
Система Ubuntu 14.04.6
Только сегодня хотел спросить, тебе принципиально 14.04  или любая из четырнадцатых.
До сих-пор мучал 14.04 c "чужим" ядром. С ним не было ни "звука" ни "интернета". А с родным ядром она у меня не грузилась.
Сейчас скачал 14.04.6. Грузится с родным ядром, как минимум есть "звук" и "интернет".
Попутно, в моей 10.04 можно масштабировать через изменение DPI в настройках гнома.
Цитировать
"завести" официальный драйвер AMD на старых версиях Ubuntu 2014-2015 года
На соседнем форуме тема. Человек ставит *бунту на макбук. Тоже "nomodeset", пытается найти поставить драйвер на AMD.

Оффлайн RoDoN

  • Участник
  • *
  • Сообщений: 126
    • Просмотр профиля
    • RoDoN X
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip
Просто по старому адресу "он больше не проживает..."
Все там на месте, просто серт протух, попробуй добавить --no-check-certificate и файл скачается, т.е. выполнить:
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip --no-check-certificate
Lenovo B590 (i3-3110M, 8 Гб, GeForce 720M)

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3150
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
4) Я выполнил ту же самую процедуру через терминал, как в Вашей статье - тот же самый результат. Ошибка, "столкновение зависимостей".

Наверное, надо было всё-таки пропатчить драйвер. Может быть, у Вас остался этот патч, AlexBKost? Или Вы знаете, где его скачать? Просто по старому адресу "он больше не проживает..." Спасибо за терпение 

Та статья была написана под версию *ubuntu 16.04, поэтому там нужно было патчить под новое ядро. У вас 14.04 - здесь ничего не нужно патчить: вот второй раз даю оф-ссылку на установку (не свою) Crimson на 14.04. Тут не идет речи ни про какие патчи.
Я странен, а не странен кто ж? (С)

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4707
    • Просмотр профиля
 Сегодня здравный день!
Итак, вчера я определил, что видеодрайвер в моей железке начинает работать в *бунту 16.04.4 (ядро 4.13.0-36).
Проверяю на Ubuntu 14.04.6 (ядро 4.4.0-142). Запускается, в xrandr ошибка "гамма...", видеовходов нет, скале не работает. В /sys/backlight пусто, соответственно яркость подсветки не регулируется. lshw для дисплея не показывает никакого драйвера.
Добавлял firmware/i915, firmware/intel от *бунту 16.04.4, 16.04.7. Никакого эффекта, с тремя разными ядрами. Вернул родной firmware. Попутно, в файл /etc/gtk-3.0/settings.ini добавлял параметры "gtk-icon-theme-name", "gtk-xft-dpi". Никакого эффекта.
Загружаюсь с ядром 4.13.0-36 - черный экран.
 Загружаюсь с ядром 4.15.0-112 от *бунту 16.04.7. xrandr без ошибки, показывает видеовходы, несколько разрешений, скале сработал. В /sys/backlight есть файл, работает регулировка яркости подсветки. lshw для дисплея показывает драйвер i915.

И никаких патчей, компиляций, зависимостей и прочих сложностей.
 А это Ubuntu 14.04. Загрузилась с ядрами 4.13.0-36, 4.15.0-112, 5.4.0-42 (от lubuntu 18.04.5, но работает нестабильно).
xrandr показывает только одно разрешение. В остальном все как с 14.04.6.

« Последнее редактирование: 23 Июль 2021, 18:02:24 от andytux »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4707
    • Просмотр профиля
Едем дальше...
На скриншоте в "Ответ 20" видно, что в *бунту 16.04.7 "Graphics Intel UHD Graphics 600".
В то время как в *бунту 14.04.6 "Graphics Gallium 0.4 on llwmpipe".
Из *бунту 16.04.7 в *бунту 14.04.6 копирую каталог /usr/lib/x86_64-linux-gnu/dri. Теперь и здесь "Graphics Intel UHD Graphics 600"

Но не все гладко. Исчезли "рамки окон", изображение очень медленно перерисовывается.
На 14.04 еще хуже. Исчезли обе панели унити.
« Последнее редактирование: 24 Июль 2021, 15:02:21 от andytux »

Оффлайн swampy_earl

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
    • Просмотр профиля
andytux - Спасибо, что продолжаете это расследование! Да, у меня как раз такой графический драйвер сейчас на Ubuntu 14.04.6, тот самый Gallium 0.4. Знакомый товарищ.

Я правильно понимаю, что это самый примитивный и самый базовый драйвер для видеокарты?

Я попробовал ради интереса запустить на Ubuntu 14.04.6 известный бенчмарк для 3D-графики под названием Valley. Результат - 1/2 fps в секунду  :)

Такого драйвера вполне хватит для интернета, текстовых задач и просмотра видео. Для сложной графики и даже для эмуляции ретро-консолей наверное уже не подойдёт.

В общем, я пришёл к такому выводу. Единственный способ решить мою проблему - поменять целиком ядро в системе Ubuntu 14.04.6. Получается так...

AlexBKost - ещё раз, огромное Вам спасибо за полезную ссылку!

Я выполнил инструкции, как в этом руководстве. Но система не приняла целый ряд пакетов, а именно: linux-headers-generic, xserver-xorg-dev-lts-trusty, а также lib32gcc1. Причина всё та же - столкновение зависимостей (unmet dependencies).

Соответствующий красный значёк теперь украшает мой системный трей.  :) :)

Соответственно, пакеты скопилированные программой ati-crimson тоже не идут в систему. Столкновение зависимостей.

Я не один такой, понятное дело. Много кто сталкивался с такой проблемой, судя по откликам в интернете.

В общем, я всё перепробовал. Не получается поставить в систему Ubuntu 14.04.6 проприетарный видеодрайвер от ATI Radeon!

На данном этапе, для новичка, я считаю что это невыполнимая задача. Поэтому "я снимаю этот вопрос с повестки дня", так сказать. Попробую другие подходы. Но всё равно, благодарю Вас за поддержку!




Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4707
    • Просмотр профиля
Цитировать
Единственный способ решить мою проблему - поменять целиком ядро в системе Ubuntu 14.04.6
А почему не поменять всю систему на 16.04. Приведу аргументы в ее пользу.
1. Визуально ничем не отличается от 14.04.
2. Программно значительно более развита. Покопавшись сейчас в 14.04, убедился, что все старое сломали, а нового еще почти ничего не сделано. То что есть, намертво приколочено гвоздями.
3. В 16.04 появились профили у компиза. В частности "unity-lowgfx" - с минимумом эффектов.
4. Оглянулся назад: "...Моя видеокарта - AMD Radeon RX 550". Быстренько поискал: "...В основе данной модели процессор семейства Polaris... основе новинки процессор Polaris 12".
   Ни в одной из четырнадцатых *бунт нет firmware polaris. В 16.04.2 появился firmware polaris11, в 16.04.3 появился firmware polaris12.

Оффлайн swampy_earl

  • Автор темы
  • Участник
  • *
  • Сообщений: 222
    • Просмотр профиля
Да, Вы правы. И я чётко понимаю, что Ubuntu 16.04 дейтсвительно лучше во многом, чем версия 14.04. Наверное 16.04 - это самый лучший выпуск с Unity 7, где она доведена буквально до совершенства.

Но всё-таки я привязан к 14-й версии. Наверное потому, что именно с неё и началось моё знакомство с семейством Ubuntu.

Может быть есть какой-то способ перенести драйвера для чипа Polaris? В смысле, перенести их 16.04 на 14.04.  :)

Я так понимаю что Вы один раз попытались это сделать, и почти добились успеха.

 

Страница сгенерирована за 0.054 секунд. Запросов: 21.