Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: не устанавливается virtual box ubuntu 20.04 LTS  (Прочитано 904 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Брукс

  • Автор темы
  • Гость
При установке стандартными командами:
Цитировать
sudo apt install virtualbox virtualbox-ext-pack

в терминале появляется ошибка в конце:

sudo apt install virtualbox virtualbox-ext-pack
[sudo] пароль для name:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  kbuild libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
  module-assistant python-is-python2 python2 python2-minimal python2.7
  python2.7-minimal
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  virtualbox-dkms virtualbox-qt
Предлагаемые пакеты:
  virtualbox-guest-additions-iso
Следующие НОВЫЕ пакеты будут установлены:
  virtualbox virtualbox-dkms virtualbox-ext-pack virtualbox-qt
Обновлено 0 пакетов, установлено 4 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 0 B/43,9 MB архивов.
После данной операции объём занятого дискового пространства возрастёт на 177 MB.
Хотите продолжить? [Д/н] д
Предварительная настройка пакетов …
Выбор ранее не выбранного пакета virtualbox-dkms.
(Чтение базы данных … на данный момент установлено 278572 файла и каталога.)
Подготовка к распаковке …/virtualbox-dkms_6.1.16-dfsg-6~ubuntu1.20.04.1_amd64.de
b …
Распаковывается virtualbox-dkms (6.1.16-dfsg-6~ubuntu1.20.04.1) …
Выбор ранее не выбранного пакета virtualbox.
Подготовка к распаковке …/virtualbox_6.1.16-dfsg-6~ubuntu1.20.04.1_amd64.deb …
Распаковывается virtualbox (6.1.16-dfsg-6~ubuntu1.20.04.1) …
Выбор ранее не выбранного пакета virtualbox-ext-pack.
Подготовка к распаковке …/virtualbox-ext-pack_6.1.16-1~ubuntu1.20.04.1_all.deb …
License has already been accepted.
Распаковывается virtualbox-ext-pack (6.1.16-1~ubuntu1.20.04.1) …
Выбор ранее не выбранного пакета virtualbox-qt.
Подготовка к распаковке …/virtualbox-qt_6.1.16-dfsg-6~ubuntu1.20.04.1_amd64.deb

Распаковывается virtualbox-qt (6.1.16-dfsg-6~ubuntu1.20.04.1) …
Настраивается пакет virtualbox-dkms (6.1.16-dfsg-6~ubuntu1.20.04.1) …
Loading new virtualbox-6.1.16 DKMS files...
Building for 5.11.0-11.1-liquorix-amd64
Building initial module for 5.11.0-11.1-liquorix-amd64
ERROR (dkms apport): kernel package linux-headers-5.11.0-11.1-liquorix-amd64 is not supported
Error! Bad return status for module build on kernel: 5.11.0-11.1-liquorix-amd64 (x86_64).....]
Consult /var/lib/dkms/virtualbox/6.1.16/build/make.log for more information...................]
dpkg: ошибка при обработке пакета virtualbox-dkms (--configure):
installed virtualbox-dkms package post-installation script subprocess returned error exit status 10
dpkg: зависимости пакетов не позволяют настроить пакет virtualbox:
 virtualbox зависит от virtualbox-dkms (>= 6.1.16-dfsg-6~ubuntu1.20.04.1) | virtualbox-source (>= 6.1.16-dfsg-6~ubuntu1.20.04.1) | virtualbox-modules, однако:
  Пакет virtualbox-dkms пока не настроен.
  Пакет virtualbox-source не установлен.
  Пакет virtualbox-modules не установлен.
  Пакет virtualbox-dkms, предоставляющий virtualbox-modules, пока не настроен.

dpkg: ошибка при обработке пакета virtualbox (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет virtualbox-ext-pack:
 virtualbox-ext-pack зависит от virtualbox (>= 6.1.16-dfsg-0~) | virtualbox-6.1, однако:
  ПакетОтчёт apport не записан, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
             Отчёт apport не записан, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                   Отчёт apport не записан, так как достигнуто значение MaxReports
                                                                                   virtualbox пока не настроен.
  Пакет virtualbox-6.1 не установлен.
 virtualbox-ext-pack зависит от virtualbox (<< 6.1.16-dfsg-z) | virtualbox-6.1, однако:
  Пакет virtualbox пока не настроен.
  Пакет virtualbox-6.1 не установлен.

dpkg: ошибка при обработке пакета virtualbox-ext-pack (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет virtualbox-qt:
 virtualbox-qt зависит от virtualbox (= 6.1.16-dfsg-6~ubuntu1.20.04.1), однако:
  Пакет virtualbox пока не настроен.

dpkg: ошибка при обработке пакета virtualbox-qt (--configure):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.24-1ubuntu3) …
Обрабатываются триггеры для mime-support (3.64ubuntu1) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Обрабатываются триггеры для gnome-menus (3.36.0-1ubuntu1) …###..................................]
Обрабатываются триггеры для systemd (245.4-4ubuntu3.5) …
Обрабатываются триггеры для man-db (2.9.1-1) …
Обрабатываются триггеры для shared-mime-info (1.15-1) …
При обработке следующих пакетов произошли ошибки:
 virtualbox-dkms
 virtualbox
 virtualbox-ext-pack
 virtualbox-qt
E: Sub-process /usr/bin/dpkg returned an error code (1)

пробую починить сломанные пакеты через apt install -f и результат абсолютно такой же:
sudo apt install -f
[sudo] пароль для name:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  kbuild libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
  module-assistant python-is-python2 python2 python2-minimal python2.7
  python2.7-minimal
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 4 пакетов.
После данной операции объём занятого дискового пространства возрастёт на 0 B.
Настраивается пакет virtualbox-dkms (6.1.16-dfsg-6~ubuntu1.20.04.1) …
Removing old virtualbox-6.1.16 DKMS files...

------------------------------
Deleting module version: 6.1.16
completely from the DKMS tree.
------------------------------
Done.
Loading new virtualbox-6.1.16 DKMS files...
Building for 5.11.0-11.1-liquorix-amd64
Building initial module for 5.11.0-11.1-liquorix-amd64
ERROR (dkms apport): kernel package linux-headers-5.11.0-11.1-liquorix-amd64 is
not supported
Error! Bad return status for module build on kernel: 5.11.0-11.1-liquorix-amd64
(x86_64)
Consult /var/lib/dkms/virtualbox/6.1.16/build/make.log for more information.
dpkg: ошибка при обработке пакета virtualbox-dkms (--configure):
 installed virtualbox-dkms package post-installation script subprocess returned
error exit status 10
dpkg: зависимости пакетов не позволяют настроить пакет virtualbox:
 virtualbox зависит от virtualbox-dkms (>= 6.1.16-dfsg-6~ubuntu1.20.04.1) | virt
ualbox-source (>= 6.1.16-dfsg-6~ubuntu1.20.04.1) | virtualbox-modules, однако:
  Пакет virtualbox-dkms пока не настроен.
  Пакет virtualbox-source не установлен.
  Пакет virtualbox-modules не установлен.
  Пакет virtualbox-dkms, предоставляющий virtualbox-modules, пока не настроен.

dpkg: ошибка при обработке пакета virtualbox (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет virtualbox-ext-pack:
 virtualbox-ext-pack зависит от virtualbox (>= 6.1.16-dfsg-0~) | virtualbox-6.1,
 однако:
  ПакетОтчёт apport не записан, так как сообщение об ошибке указывает на повторн
ую ошибку от предыдущего отказа.
                                Отчёт apport не записан, так как сообщение об ош
ибке указывает на повторную ошибку от предыдущего отказа.
                                                         Отчёт apport не записан
, так как достигнуто значение MaxReports
                                         virtualbox пока не настроен.
  Пакет virtualbox-6.1 не установлен.
 virtualbox-ext-pack зависит от virtualbox (<< 6.1.16-dfsg-z) | virtualbox-6.1,
однако:
  Пакет virtualbox пока не настроен.
  Пакет virtualbox-6.1 не установлен.

dpkg: ошибка при обработке пакета virtualbox-ext-pack (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет virtualbox-qt:
 virtualbox-qt зависит от virtualbox (= 6.1.16-dfsg-6~ubuntu1.20.04.1), однако:
  Пакет virtualbox пока не настроен.

dpkg: ошибка при обработке пакета virtualbox-qt (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 virtualbox-dkms
 virtualbox
 virtualbox-ext-pack
 virtualbox-qt
E: Sub-process /usr/bin/dpkg returned an error code (1)


этой командой пытается установиться virtual box версии 6.1.16-dfsg-6~ubuntu1.20.04.1

я пробовал установить версии старше через deb файлы с сайта виртуалбокс,но результат тот же
подскажите пожалуйста как быть?

*в биосе виртуализация включена,5.11.0-11.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix 5.11-25ubuntu1~focal (2021-03-30) x86_64 x86_64 x86_64 GNU/Linux
« Последнее редактирование: 06 Апрель 2021, 13:57:06 от Брукс »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5434
    • Просмотр профиля
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #1 : 06 Апрель 2021, 13:36:14 »
в терминале появляется ошибка в конце:
нужен полный вывод выполнения. В логе должно быть указание, какая именно причина вызывает ошибку.

Брукс

  • Автор темы
  • Гость
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #2 : 06 Апрель 2021, 13:58:36 »
обновил

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1273
    • Просмотр профиля
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #3 : 06 Апрель 2021, 14:25:11 »
Может потому что ядро не дефолтное.

Оффлайн c47

  • Участник
  • *
  • Сообщений: 177
    • Просмотр профиля
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #4 : 06 Апрель 2021, 14:43:09 »
я пробовал установить версии старше через deb файлы с сайта виртуалбокс,но результат тот же
на сайте 6.1.18, в репозиториях 6.1.16, попробуй с сайта новые качуть и поставить, я так при переходе с 4.15 на 5.0 победил
Не кормите тролля

Брукс

  • Автор темы
  • Гость
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #5 : 06 Апрель 2021, 15:07:39 »
снес все и поставил версию 6.1.18

при попытке запуска виртуалки ошибка:
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing

'/sbin/vboxconfig'

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

запускаю в терминале sudo /sbin/vboxconfig:
sudo /sbin/vboxconfig
[sudo] пароль для name:
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: Look at /var/log/vbox-setup.log to find out what went wrong.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.  If your system is using EFI Secure Boot you may need to sign the
kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load
them. Please see your Linux system's documentation for more information.

Оффлайн Plastikman

  • Участник
  • *
  • Сообщений: 196
    • Просмотр профиля
    • Free system for free people
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #6 : 06 Апрель 2021, 15:29:33 »
Брукс,
Попробуйте так:
sudo groupadd vboxusers
sudo usermod -a -G vboxusers name
sudo /sbin/vboxconfig
« Последнее редактирование: 06 Апрель 2021, 15:39:51 от Plastikman »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5434
    • Просмотр профиля
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #7 : 06 Апрель 2021, 15:35:05 »
ERROR (dkms apport): kernel package linux-headers-5.11.0-11.1-liquorix-amd64 is not supported

Установленное ядро не поддерживается. Почему не пользуетесь дефолтным?

Брукс

  • Автор темы
  • Гость
Re: не устанавливается virtual box ubuntu 20.04 LTS
« Ответ #8 : 06 Апрель 2021, 16:08:28 »
ставил порт протон,рядом в статье было что с этим ядром система работает лучше я и поставил

получается нужно откатиться на стандартное?

Пользователь добавил сообщение 06 Апрель 2021, 16:26:46:
снес ядро,загрузился со стандартного,все установилось стандартными командами и работает

удалял и ставил его по способу:https://portwine-linux.ru/zen-kernel-on-ubuntu-20-04-and-linux-mint-20/

большое спасибо за помощь
« Последнее редактирование: 06 Апрель 2021, 16:26:46 от Брукс »

 

Страница сгенерирована за 0.123 секунд. Запросов: 25.