Форум русскоязычного сообщества Ubuntu


Автор Тема: Клавиша Shift и Numpad, как сделать, чтобы было как в Windows?  (Прочитано 1028 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pуслан

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Привык выделять, например, до конца строки нажатием Shift+End(на цифровом блоке), но при этом печатается цифра 1. (при выключенном NumLock). Подскажите, где в Ubuntu 20.04 это можно поменять? Через меню не могу в Ubuntu 20.04 даже найти, где меняются настройки клавиатуры..

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2791
    • Просмотр профиля
Привык выделять, например, до конца строки нажатием Shift+End(на цифровом блоке), но при этом печатается цифра 1. (при выключенном NumLock).
- в Ubuntu MATE 20.04 все нормально выделяется и по Shift+End(Home), и по Shift+PgUp(PgDn), возможно проблема в GNOME 3, но думаю скорее всего что-то не так работает конкретно в твоей системе ::)

Оффлайн qpdb

  • Участник
  • *
  • Сообщений: 183
  • xUbuntu 20.04
    • Просмотр профиля
В xUbuntu 20.04 тоже самое всё выделяется …

Т.е. Num Lock не влияет…
« Последнее редактирование: 17 Июль 2021, 18:43:34 от qpdb »

Оффлайн Pуслан

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
но думаю скорее всего что-то не так работает конкретно в твоей системе

С трудом верится, думаю, просто нужно найти, где меняется этот параметр. В Lubuntu 18.04, например, по умолчанию то же, что у меня, и там эта опция меняется в настройках. Также, судя по этому посту https://forum.ubuntu.ru/index.php?topic=271109 , и в Kubuntu 15.04.

все нормально выделяется и по Shift+End(Home)

Вы пробуете с End(Home), которые на цифрах 1 и 7 соответственно? (выше ещё есть другие End и Home)

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2791
    • Просмотр профиля
Вы пробуете с End(Home), которые на цифрах 1 и 7 соответственно? (выше ещё есть другие End и Home)
- пробовал и те которые выше, и те что на цифрах 1 и 7, но при включенном NumLock, а вот сейчас попробовал при выключенном, и таки да, те что на цифрах не работают...

Оффлайн qpdb

  • Участник
  • *
  • Сообщений: 183
  • xUbuntu 20.04
    • Просмотр профиля
Приветствую ещё раз!
Ага, наконец понятно всё с задачей! Не часто просто такие потребности встречаются!

У меня при включённой NumLock, Shift+KP_1(KP_3;KP_7:KP_9) выделения вообще не происходит  :idiot2:, просто курсор перемещается и всё.

А если выключить NumLock, то печатает соответственно 1;3;7;9 т.е. как описано в первом сообщении.

Скорее всего в каком-то конфигурационном фале это зарыто, попробую поискать…
(Нажмите, чтобы показать/скрыть)
⮝⮝Это для ориентации такие могут быть названия клавишей на цифровом блоке…


Пользователь добавил сообщение 18 Июль 2021, 01:20:16:
Пока вот нашёл это, ориентир вроде есть…

https://askubuntu.com/questions/44921/how-to-change-shift-keypad-key-behavior

У меня работает:
setxkbmap -option 'numpad:microsoft'
Интересная штука, вообще, просто никогда не пользовался :idiot2:

Думаю продолжим…

Пользователь добавил сообщение 18 Июль 2021, 06:55:02:
Можно, конечно, через автозапуск запускать
setxkbmap -option 'numpad:microsoft'но это по-моему не очень красиво…  :idiot2:

В xUbuntu у меня это просто добавлено в файл /etc/default/keyboard
(Нажмите, чтобы показать/скрыть)

В xUbuntu практически все настройки клавиатуры можно в этом файле выполнить, имеется такая возможность.

В общем пробуйте, должно получиться.

« Последнее редактирование: 18 Июль 2021, 06:55:02 от qpdb »

Оффлайн Pуслан

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Не часто просто такие потребности встречаются!
Лично я без этого как без рук, т.к. за многие годы привык к этим клавишам..

setxkbmap -option 'numpad:microsoft'
Спасибо, эта команда у меня работает, но до первого перезапуска.

Открыл файл /etc/default/keyboard , дописал в него numpad:microsoft. Перезапускаюсь, не работает почему-то.
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 18 Июль 2021, 12:15:04 от Pуслан »

Оффлайн qpdb

  • Участник
  • *
  • Сообщений: 183
  • xUbuntu 20.04
    • Просмотр профиля
Перезапускаюсь, не работает почему-то.
По идее и не должно было… Было просто поздно и я не чётко изложил в предыдущих сообщениях…

В общем есть три варианта:

1.) На одну сессию setxkbmap -option 'numpad:microsoft' т.е. до перезагрузки, я забыл про это указать, это нормальное поведение так и должно быть…

2.) Эту же команда прописывается в автозапуск, у Вас не xUbuntu, я так понял, потому нет смысла приобщать картинки. Вариант так себе, но работать будет, просто вместо Вас команда будет при старте системы сама запускаться.

3.) Для того, чтобы работал файл /etc/default/keyboard нужно произвести тоже соответствующие настройки. У меня так, а Вам нужно найти аналогичные для своего окружения рабочего стола.


Предлагаю Вам пока автозапуск, а потом нужно будет искать как применить параметр numpad:microsoft для вашего DE… Это может быть не обязательно правка /etc/default/keyboard, возможно есть другие настройки…

2021 Jul 18; 06:39 AM
« Последнее редактирование: 18 Июль 2021, 13:39:48 от qpdb »

Оффлайн Pуслан

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
qpdb, спасибо за ответы. Нашёл решение вопроса, оставлю тут, вдруг пригодится кому. Заодно нужно было установить по аlt+shift смену раскладки, нашёл для этого команду и просто дописал в неё "numpad:microsoft":

gsettings set org.gnome.desktop.input-sources xkb-options "['grp:alt_shift_toggle','numpad:microsoft']"

Работает :)

 

Страница сгенерирована за 0.162 секунд. Запросов: 25.