Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Viber для Linux  (Прочитано 251548 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5905
    • Просмотр профиля
Re: Viber для Linux
« Ответ #540 : 22 Июня 2022, 04:56:11 »
"Рубикон перейдён."
Цитировать
То есть, "моя всё это знает и понимает"...
Теперь и "моя понимает".

Цитировать
система "ПАЛАМАЛАСЯ"
Совершенно верно. Именно это и должно было произойти. О чем подаван был предупрежден парой ответов ранее: "...GLIBC_2.27. И для этого совсем не обязательно ее устанавливать (впрочем как и сам вибер), рискуя "сломать систему"." Но, не поверил или не понял.
Именно поэтому менеджеры пакетов на дают установить другую версию libc.
Для простоты, считать, что заменить в системе libc на другую версию невозможно.

Цитировать
./Viber: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/viber/./lib/libQt5WebEngineCore.so.5)
Что видим отсюда. Что главный виновник Qt5. Ему нужны более новые libc.
Что вибер у тебя в /opt/viber. На это расположение и ориентироваться.
Создаешь примерно такой скрипт:
#!/usr/bin/env sh
SRC='/opt/viber'
LD_LIBRARY_PATH="${SRC}/lib:${LD_LIBRARY_PATH}"
${SRC}/lib/ld-linux-x86-64.so.2 --library-path ${LD_LIBRARY_PATH} ${SRC}/viber
Все нужные библиотеки копируешь в /opt/viber/lib, в том числе и ld-linux-x86-64.so.2. Подкаталог lib создаешь сам, имя может быть любое, просто чтобы не путать с теми файлами, что уже есть в /opt/viber.
Скрипт рассматривай скорее как образец. Не проверял, не гарантирую, что там нет ошибок.
Систему это поломать не должно. В принципе, вообще никак не затрагивает систему, может находится "вне-системы".


Пользователь добавил сообщение 22 Июня 2022, 06:55:32:
Сейчас появилась идея. Для "экспериментальных запусков с персональными библиотеками" сделать пункт в "user menu" MC.
Заодно, увидел одну ошибку в скрипте, исправил.


Пользователь добавил сообщение 22 Июня 2022, 11:32:58:
Начал тестировать новый пункт "user menu".

Запускаю, смотрю вывод, добавляю либы. На скриншоте видно, что загрузчик 32битный. Да, как я и говорил раньше, так можно запустить и 32битную программу, хотя в самой системе ни одной 32битной библиотеки.
Можно это рассматривать, как ответ на вопрос: "куда помещать скрипт?"
В данном случае, весь скрипт находится в "user menu", вернее, в его файле - mc.menu. Другой вариант, в "user menu" может быть только команда запуска скрипта, а сам скрипт в другом месте, например, в /usr/local/bin или /opt.
Для запуска скрипта можно создать десктоп-файл.
« Последнее редактирование: 22 Июня 2022, 11:32:58 от andytux »

Оффлайн Onlininer

  • Модератор форума
  • Активист
  • *
  • Сообщений: 501
    • Просмотр профиля
Re: Viber для Linux
« Ответ #541 : 24 Июня 2022, 15:12:31 »
andytux, Хочу сразу извиниться, что не отвечал, т.к. :( пришлось несколько дней "побегать по врачам". И сказать Вам огромное спасибо, что "возитесь" с нами, пытаясь помочь... Мне надо немного времени почитать про эти скрипты, немного понять как оно работает, синтаксис...я ещё никогда в жизни их не писал...

 

Страница сгенерирована за 0.024 секунд. Запросов: 20.