Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Сканер Epson Perfection V200 Photo под 8.10  (Прочитано 9687 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anatol

  • Активист
  • *
  • Сообщений: 306
    • Просмотр профиля
Re: Сканер Epson Perfection V200 Photo под 8.10
« Ответ #30 : 09 Марта 2009, 16:34:46 »
На сайте AVASYS http://www.avasys.jp/lx-bin2/linux_e/scan/DL1.do появились драйвера и программа Iscan для Ubuntu, инструкция по установке и использованию.
« Последнее редактирование: 23 Апреля 2009, 18:30:51 от anatol »

Оффлайн delmail

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Сканер Epson Perfection V200 Photo под 8.10
« Ответ #31 : 09 Июля 2009, 17:54:13 »
Не запускается сканнер  :-[
iscan выдает Could not send command to scaner
xsane выдает Невозможно открыть устройство
Ubuntu 9.04
стоит:  libsane, sane, sane-utils,xsane, xsane-common
iscan 2.20 , iscan-plugin-gtf670
в dll.conf внесена запись epkowa
в epkowa.conf внесено usb 0x04b8 0x012e
вывод lsusb :
Bus 001 Device 007: ID 04b8:012e Seiko Epson Corp.
вывод scanimage -L
device `v4l:/dev/video0' is a Noname ViewSonic 1.3M, USB2.0 Webcam virtual device   # Это веб-камера монитора, можно закомментировать в dll.conf строчку v4l но это ничего не меняет#
device `epkowa:usb:001:007' is a Epson (unknown model) flatbed scanner
device `epkowa:interpreter:001:007' is a Epson (unknown model) flatbed scanner
выполнено sudo chmod a+r /usr/share/iscan/esfw7A.bin
в результате при запуске xsane или iscan появляется выбор между epkowa:usb:001:007 и epkowa:interpreter:001:007
для xsane это заканчивается невозможностью открыть устройство для iscan Could not send command to scanner
sudo xsane или sudo iscan ошибка не менятеся
переставлял sane и iscan ничего не изменилось
Добавил пользователя в группу sanned
В привилегиях пользователя нет пункта про работу со сканером
Вобщем уже не знаю где копать  :-\



« Последнее редактирование: 09 Июля 2009, 17:56:05 от delmail »

Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Сканер Epson Perfection V200 Photo под 8.10
« Ответ #32 : 09 Июля 2009, 20:53:23 »
Проверить /usr/share/iscan/esfw7A.bin есть ли там действительно  прошивка, пользователь должен присутствовать в группе scaner, прописать  правильный путь к  бинарнику в файле snapscan.conf, если все сделано правильно но,  не работает, проблема в пакетах iscan, тогда берем старые пакеты rpm конвертируем их в deb юзаем и далее все еще раз перепроверяем. Вот https://forum.ubuntu.ru/index.php?topic=21435.0 прочитать не возбраняется, у самого такой сканер -настраивал практически во всех ОС которые пробовал, а самый простой способ установки на gentoo  :)
LMDE

Оффлайн delmail

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Сканер Epson Perfection V200 Photo под 8.10
« Ответ #33 : 10 Июля 2009, 14:23:03 »
Спасибо Leomuz за совет!
Вот что было сделано:
скачаны  rpm пакеты iscan_2.8.0-2_i386.rpm, iscan-plugin-gt-f670-2.0.0-1.c2.i386.rpm
сконвертированы в deb
поправлен snapscan.conf
содана группа scaner
sudo scanimage выдает: (без sudo выдает только device `v4l:/dev/video0' is a Noname ViewSonic 1.3M, USB2.0 Webcam virtual device)
device `v4l:/dev/video0' is a Noname ViewSonic 1.3M, USB2.0 Webcam virtual device
device `epkowa:libusb:002:005' is a Epson Perfection V200 flatbed scanner
проблемы оставались iscan вешался при попытке предпросмотра , xsane выдавал ошибку
Переткнул кабель от сканера в другой порт (в порт на кардридере подключенном  к мат.плате) и все заработало!!!
Думается что плюс ко всему не хватало питания..
iscan и xsane прекрасно сканируют, НО только если запустить через sudo
Как это можно обойти?



Оффлайн leomuz

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Сканер Epson Perfection V200 Photo под 8.10
« Ответ #34 : 10 Июля 2009, 21:53:08 »
Спасибо Leomuz за совет!
Вот что было сделано:
скачаны  rpm пакеты iscan_2.8.0-2_i386.rpm, iscan-plugin-gt-f670-2.0.0-1.c2.i386.rpm
сконвертированы в deb
поправлен snapscan.conf
содана группа scaner
sudo scanimage выдает: (без sudo выдает только device `v4l:/dev/video0' is a Noname ViewSonic 1.3M, USB2.0 Webcam virtual device)
device `v4l:/dev/video0' is a Noname ViewSonic 1.3M, USB2.0 Webcam virtual device
device `epkowa:libusb:002:005' is a Epson Perfection V200 flatbed scanner
проблемы оставались iscan вешался при попытке предпросмотра , xsane выдавал ошибку
Переткнул кабель от сканера в другой порт (в порт на кардридере подключенном  к мат.плате) и все заработало!!!
Думается что плюс ко всему не хватало питания..
iscan и xsane прекрасно сканируют, НО только если запустить через sudo
Как это можно обойти?




Смотрите вывод команды groups юзер должен присутствовать в группе scanner
LMDE

Оффлайн Nekr

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Сканер Epson Perfection V200 Photo под 8.10
« Ответ #35 : 12 Июля 2009, 10:18:14 »
У меня все работает без sudo. Я убрал xsane, sane и всё, что они за собой потянули. Переустановил пакет libsane, поставил iscan-2.14 и iscan-plugin-gt-f670_2.0.0-2_i386.deb. Зашел в Администрирование>Пользователи и группы>Свойства учетной записи и на вкладке "Привилегии пользователя" поставил флажок напротив "Использовать сканеры". После этого все работает.
Аналогично, сканер и система идентичны,  даже не понимаю к чему такие длинные мануалы порой делают (может и сканер такой поддатливый, кто знает)  :)

 

Страница сгенерирована за 0.021 секунд. Запросов: 20.