Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Ошибка: No package 'speech-dispatcher'  (Прочитано 438 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kihl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Ошибка: No package 'speech-dispatcher'
« : 25 Июль 2021, 17:34:43 »
Хелоу! Решил я установить RHVoice (делаю я по описанию ролика https://www.youtube.com/watch?v=5ZtyZTZLCOM ) , когда я дошел до команды scons, мне выдало это:scons: Reading SConscript files ...
Mkdir("build/linux")
scons: *** build: Permission denied
Mkdir("build/linux")
scons: *** build: Permission denied
Georgian language is skipped because of non-free license
Package speech-dispatcher was not found in the pkg-config search path.
Perhaps you should add the directory containing `speech-dispatcher.pc'
to the PKG_CONFIG_PATH environment variable
No package 'speech-dispatcher' found
OSError: 'pkg-config speech-dispatcher --variable=modulebindir' exited 1:
  File "/usr/src/RHVoice/SConstruct", line 373:
    vars=create_user_vars()
  File "/usr/src/RHVoice/SConstruct", line 169:
    vars.Add(PathVariable("spd_module_dir", "Speech dispatcher module directory", get_spd_module_dir(),  PathVariable.PathAccept))
  File "/usr/src/RHVoice/SConstruct", line 96:
    return env.ParseConfig("pkg-config speech-dispatcher --variable=modulebindir", passthru)
  File "/usr/lib/scons/SCons/Environment.py", line 1578:
    return function(self, self.backtick(command))
  File "/usr/lib/scons/SCons/Environment.py", line 589:
    raise OSError("'%s' exited %d" % (command, status))

Как я понял нужен speech-dispatcher. Я пишу sudo apt-get install speech-dispatcher, мне выдаёт, что он скачен. Я решил его удалить и скачать снова не помогло. Можете помочь?
« Последнее редактирование: 25 Июль 2021, 17:42:44 от Kihl »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3149
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Re: Ошибка: No package 'speech-dispatcher'
« Ответ #1 : 25 Июль 2021, 17:57:04 »
Я пишу sudo apt-get install speech-dispatcher, мне выдаёт, что он скачен.
Kihl, команда install предполагает установку пакета. Да, перед этим происходит его скачивание. Но если пакет уже установлен, то и будет сообщение, что он установлен, а не скачан.
Я странен, а не странен кто ж? (С)

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4695
    • Просмотр профиля
Re: Ошибка: No package 'speech-dispatcher'
« Ответ #2 : 25 Июль 2021, 18:17:38 »
Цитировать
я дошел до команды scons
Похоже, этот скунс тебе здорово подосрал.
По rhvoice смотри здесь.
Все просто. Подключаешь репозиторий, ставишь rhvoice.
Speech-dispatcher уже давно есть по умолчанию и настроен, если конечно у тебя не какая-нибудь экзотическая система.

 

Страница сгенерирована за 0.067 секунд. Запросов: 22.