Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Пропадает интернет-соединение WIFI(TP-Link TL WN 722N)  (Прочитано 3048 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pirojok_s_kapustoy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Столкнулся со следующей проблемой: в случайные промежутки времени пропадает интернет-соединение. То есть индикатор вай-фая горит, а интернета просто нет. Даже по команде ip ничего не выдает. Причем в везде показывает, что соединение есть и модем видит все остальные WIFI сети. При попытке переподключения жалуется на то, что пароль от сети неправильный, хотя пароль не меняется и 100 % верный.
lshw -C network(когда проблемы не наблюдается)     
*-network                 
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@1:1
       logical name: wlp0s20f0u1
       serial: c0:4a:00:2b:43:92
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ath9k_htc driverversion=5.17.11-lqx1-1-lqx firmware=1.4 ip=
       link=yes multicast=yes wireless=IEEE 802.11
Дело в том, что проблема происходит абсолютно случайно через разные промежутки времени и встеречалась у меня на на всех популярный Линукс дистрибутивах(Дебиан, Ubuntu, Минт, Манжаро, Федора). Помогает перетыкание самого WIFI адаптера.
Так же при подключении к сети он сеть нумерует:
https://ibb.co/dfNsYht(на фото выполнялось подключение к сети ASUS, а не ASUS1)
Драйвера же для моей ревизии адаптера(V1) нет
Что мне с этим делать?

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3623
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 23.04
    • Просмотр профиля
Что мне с этим делать?
Дружище pirojok_s_kapustoy, я уже не помню сколько раз выкладывал на этом форуме ссылку на решение проблемы с усб адаптером TP-Link WN722N, потому что она как долгоиграющая пластинка. Некоторые пользователи форума меня даже очень благодарили. Вот эта ссылка.
Я странен, а не странен кто ж? (С)

Оффлайн pirojok_s_kapustoy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Я видел эту тему и я добавлял в файл /etc/NetworkManager/NetworkManager.conf дополнительные строчки:
https://ibb.co/yQ9v1nR
Ничего не поменялось
« Последнее редактирование: 02 Июня 2022, 11:16:33 от pirojok_s_kapustoy »

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5906
    • Просмотр профиля
Немного странно. Сейчас посмотрел, в 18.04 и 22.04 файл выглядит так:
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no
То есть, эта строка присутствует уже года четыре.

Оффлайн pirojok_s_kapustoy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
У меня, кстати, файл был совершенно пустой. Вероятно, потому что я уже месяц пользуюсь не-Ubuntu дистрибутивом, но вроде network-manager везде один.... На всякий случай скопирую и вставлю ваш текст. И да, после замены
wifi.scan-rand-mac-address=0
на
wifi.scan-rand-mac-address=no
вроде уже целый день работает почти без сбоев. Однако иногда интернет так ощутимо "проседает", переставая работать, но потом восстанавливается через несколько минут.
« Последнее редактирование: 03 Июня 2022, 20:34:16 от pirojok_s_kapustoy »

Оффлайн pirojok_s_kapustoy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
andytux, ничего не помогает. На следующий день проблема снова проявилась. Модем ни в какую не хочет подключаться к сети: просто в определенный момент отрубает соединение. Причем не подключается ни к какой сети, ни к 2.4 герц, ни к 5 герц, ни к мобильной точке доступа, и ему плевать на и на дополнительные сточки /etc/NetworkManager/NetworkManager.conf, ни на драйвер установленный с официального сайта, ни на драйвер с гитхаба, ни на более старую версию ядра(ставил 4.19). Что с ним делать?

Оффлайн alex_k_

  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Re: Пропадает интернет-соединение WIFI(TP-Link TL WN 722N)
« Ответ #6 : 11 Сентября 2022, 09:47:15 »
Привет всем. Давно тут никого не было. Внесу свои 5 коп.
Имею такой же свисток. Работает нормально, но иногда начинает тормозить просто страшно. Пинги на Я и Гу доходят до десятков сек. Пинганул заодно и роутер - время такое же. Перестартовал свисток - всё пошло. После чего пользуюсь костылем в виде скрипта:
(Нажмите, чтобы показать/скрыть)
этим и спасаюсь.
НО. Иногда работает без проблем и рестартов. Вот и сейчас после последнего обновления всё в порядке. Подождём следующего обновления....


Оффлайн Domitory

  • Активист
  • *
  • Сообщений: 535
    • Просмотр профиля
Re: Пропадает интернет-соединение WIFI(TP-Link TL WN 722N)
« Ответ #7 : 13 Сентября 2022, 12:21:08 »
Модем ни в какую не хочет подключаться к сети: просто в определенный момент отрубает соединение.

Попробуйте поменять номер канала Wi-Fi на самом роутере. Укажите его например 13-тым. У меня такое было.

 

Страница сгенерирована за 0.023 секунд. Запросов: 21.