Форум русскоязычного сообщества Ubuntu


Автор Тема: WI FI не добавляется в сетевой мост  (Прочитано 3734 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nikola_t

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
WI FI не добавляется в сетевой мост
« : 20 Августа 2017, 16:16:51 »
Собрал маленький домашний сервер под 16.04 lts. Вроде всё настроил, и инет раздает и шары, всё хорошо. Но захотелось мне програмную точку доступа Wi Fi.
Всё сделал, всё работает. Но после перезагрузки системы теряется из сетевого моста WiFi карта, клиенты не могут получить настройки. Но фишка в том что если сделать service networking restart, то мост начинает видеть интерфейс, и всё сказочным образом оживает.
Reboot и вафля выпадает из сети. что делать, как быть?



ТС не появлялся на Форуме более полугода по состоянию на 17/07/2019 (последняя явка: 08/04/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 17 Июля 2019, 09:15:30 от zg_nico »

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 18.04 LTS
    • Просмотр профиля
Re: WI FI не добавляется в сетевой мост
« Ответ #1 : 20 Августа 2017, 16:33:01 »
что делать, как быть?

Если не найдёшь причину, то можно просто автоматизировать выдачу твоей команды "service networking restart".
Только наверное нужно сделать:

sudo systemctl enable networking.service
sudo systemctl start networking.service

А потом давать команду:

systemctl restart networking.service
« Последнее редактирование: 20 Августа 2017, 16:36:12 от ecc83 »

Оффлайн Nikola_t

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: WI FI не добавляется в сетевой мост
« Ответ #2 : 20 Августа 2017, 16:46:44 »
(Нажмите, чтобы показать/скрыть)




что делать, как быть?

Если не найдёшь причину,

причину я ищу, но единственное что приходит в голову это какая то проблема на стадии загрузки,


sudo systemctl enable networking.service
sudo systemctl start networking.service

systemctl restart networking.service

Спасибо, но не помогло :(

лог загрузки
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 20 Августа 2017, 23:45:02:
Продолжаю повесть о печальном.
Из лога загрузки я понял что драйвер переименовывает интерфейс в Wlan0, а потом он опять становится почему то wlp3s0.
Методом поиска по диску по фразе "wlan0" выяснил что её содержат в основном логи, и вот эти файлы



Меня интересует только те что для ATHEROS. Кто знает как победить, нужно что бы драйвер не переименовывал его на стадии загрузки в Wlan0.
Либо как вариант присвоить ему постоянное имя Wlan0, и прописать его во всех настройках вместо wlp3s0?


Пользователь добавил сообщение 21 Августа 2017, 11:51:27:

Продолжаю общение в одно лицо  :)
Попробовал переименовать интерфейс по инструкции http://www.liveinternet.ru/users/csh/post321976816/
Интерфейс переименовался, но мост не заработал.
Остаются 2 варианта, версия с заменой драйвера, и скрипт который будет делать перезапуск сети сразу после старта сервера.

Пользователь добавил сообщение 21 Августа 2017, 12:39:57:
В общем добавил в файл /etc/rc.local строчку service networking restart Мост стал добавлять Wi Fi интерфейс в свой состав, но комп стал грузиться чуть дольше.

Если кто знает как победить эту проблему без костыля, буду прям очень признателен.
« Последнее редактирование: 21 Августа 2017, 12:39:57 от Nikola_t »

Оффлайн ich bin

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: WI FI не добавляется в сетевой мост
« Ответ #3 : 31 Декабря 2017, 02:09:31 »
Может быть кому то будет актуально
Подобный вопрос решился путем добавления строки типа "bridge=br0" в hostapd.conf

 

Страница сгенерирована за 0.024 секунд. Запросов: 19.