Форум русскоязычного сообщества Ubuntu


Автор Тема: Отключается вай-фай после некоторого времени использования. Kubuntu 20.04.2 LTS  (Прочитано 1088 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Здравствуйте! Столкнулся со следующей проблемой: Спустя определенное время после включения вай-фай отключается и никак не удается переподключится. Пишет "беспроводной интерфейс (wlp7s0) Не удалось найти беспроводную сеть".

До этого был другой дистрибутив на kde и все работало нормально. В чем может быть проблема?

Оффлайн greenosx

  • Новичок
  • *
  • Сообщений: 32
  • MacOSX Ubuntu 9.10 Win7Prof
    • Просмотр профиля
Добрый! хорошо бы понять, что за wi-fi ?
Дайте, пожалуйста, вывод:

lspci -v

Интересует строчка про сетевую карту. У меня это выглядит так:
   
    Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
   DeviceName: Realtek Wireless LAN + BT
   Subsystem: Hewlett-Packard Company RTL8821CE 802.11ac PCIe Wireless Network Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 151, IOMMU group 11
   I/O ports at 3000 [size=256]
   Memory at 84000000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: <access denied>
   Kernel driver in use: rtl8821ce
   Kernel modules: rtw88_8821ce, 8821ce


Дальше можно будет смотреть

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Дайте, пожалуйста, вывод:

lspci -v

Интересует строчка про сетевую карту. У меня это выглядит так:

Вот:
Network controller: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe
        Subsystem: Foxconn International, Inc. RT5390 Wireless 802.11n 1T/1R PCIe
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at fe900000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: rt2800pci
        Kernel modules: rt2800pci

Оффлайн greenosx

  • Новичок
  • *
  • Сообщений: 32
  • MacOSX Ubuntu 9.10 Win7Prof
    • Просмотр профиля
У Вас весьма проблемная карта RT5390  :-[ Скорее всего драйвер, который сейчас установлен (rt2800pci), не подходит.
Копий поломали и бубнов порвали с этой картой много  :(

Я тут немного покопал, идея в общем следующая: выключить драйвер rt2800pci, установить драйвер rt5390.
Читайте по ссылке, общая идея, думаю, понятна.

http://compizomania.blogspot.com/2012/02/ralink-wireless-network-ubuntu-1110.html


похожая проблема на Debian:

https://www.youtube.com/watch?v=3QY46JReJ1s

Удачи

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Цитата: greenosx
Удачи

Спасибо, попробую и отпишусь!

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Удачи

Прошла одна неделя. Попробовал то, что вы скинули: не помогло. Драйвер rt5390 скачать никак не удается, его попросту не найти. Репозитории устаревшие, а сайта производителя вообще не существует. Покопался на форумах, нашел человека со схожей проблемой, ему там посоветовали следующие команды:
echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci.conf
sudo modprobe -rfv rt2800pci
sudo modprobe -v rt2800pci
 

Сначала думал помогло. Инет стал работать чуточку стабильнее, не отключался. Но прошло пару дней и проблема снова появилась. Короче говоря - не помогло.

Не знаю даже, что делать. Работал на обычном Ubuntu 16.04 и минте 19.3, все было в порядке. Есть другие идеи, что можно сделать?

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4911
    • Просмотр профиля
Какая версия ядра в минте 19.3. Попробовать эту-же версию ядра в *бунту.
Попробовать "живую" *бунту, с версией ядра аналогичной минту. Если заработает, то можно просто скопировать.

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Какая версия ядра в минте 19.3. Попробовать эту-же версию ядра в *бунту.
Попробовать "живую" *бунту, с версией ядра аналогичной минту. Если заработает, то можно просто скопировать.

Можно ли как-то сразу откатить ядро или нужно вручную копировать?

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4911
    • Просмотр профиля
Чего, куда ты катить собрался. Еще ничего не известно.
Какая версия ядра в минте? Какая версия ядра у тебя сейчас используется? Есть-ли еще установленные более старые версии?

« Последнее редактирование: 20 Сентября 2021, 14:46:24 от andytux »

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Какая версия ядра в минте?

5.0. У меня 5.11 сейчас.

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4911
    • Просмотр профиля
5.0 в *бунту 19.04 и 18.04.3. Попробуй запустить в "живую" какую-то из этих систем и посмотри, как там будет работать wifi.
Может быть есть смысл попробовать чистую 20.04, в ней ядро 5.4.

Оффлайн Nikuro

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
5.0 в *бунту 19.04 и 18.04.3. Попробуй запустить в "живую" какую-то из этих систем и посмотри, как там будет работать wifi.
Может быть есть смысл попробовать чистую 20.04, в ней ядро 5.4.

Хорошо, попробую и напишу!

Пользователь добавил сообщение 20 Сентября 2021, 18:26:03:
5.0 в *бунту 19.04 и 18.04.3. Попробуй запустить в "живую" какую-то из этих систем и посмотри, как там будет работать wifi.

Скачал 19.04, проверил, все работает отлично. Каким образом мне теперь откатить ядро до версии 5.0?
« Последнее редактирование: 20 Сентября 2021, 18:26:03 от Nikuro »

Оффлайн Byrger87

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Я тоже считаю, что это карта RT5390 проблемная.

 

Страница сгенерирована за 0.019 секунд. Запросов: 21.