Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ubuntu 20.04.1 и Canon LBP6020  (Прочитано 1429 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Eldignis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Ubuntu 20.04.1 и Canon LBP6020
« : 04 Октябрь 2020, 12:53:27 »
Имеется Canon LBP 6020

Производится установка драйверов с помощью известного скрипта:
https://help.ubuntu.ru/wiki/canon_capt

При этом на системах:
Ubuntu 18.04, Linux Mint 19.3, Linux Mint 20 - все работает без проблем (единственный недостаток в LM 20 не создаётся ярлык на рабочем столе утилиты capstatusui, но это мелочи).

На Ubuntu 20.04 драйвера устанавливаются, принтер регистрируется, но при отправке на печать, печати не происходит.

Куда копать - подскажите.
« Последнее редактирование: 04 Октябрь 2020, 16:19:44 от Eldignis »

Оффлайн Сергий

  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Ubuntu 20.04.1 и Canon LBP6020
« Ответ #1 : 21 Апрель 2021, 10:50:22 »
Ситуация аналогичная только устанавливаю LBP3250. Уже не первый год пользуюсь этой wiki страничкой (при переустановки системы, железо не менялось) всегда всё проходило гладко.

Сегодня скрипт выдал:
Установка общего модуля для драйвера CUPS
dpkg-deb: ошибка: 'cndrvcups-common_3.21-1_amd64.deb' is not a Debian format archive
dpkg: ошибка при обработке архива cndrvcups-common_3.21-1_amd64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
При обработке следующих пакетов произошли ошибки:
 cndrvcups-common_3.21-1_amd64.deb
Ошибка при установке пакета cndrvcups-common_3.21-1_amd64.deb
Нажмите любую клавишу для выхода

На file cndrvcups-common_3.21-1_amd64.deb ответ:
cndrvcups-common_3.21-1_amd64.deb: HTML document, ASCII text, with very long lines

Возможно проблема с wiki-страничкой(скриптом) или Ubunta уже не-та?

Оффлайн Пользователь

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 2644
  • Runtu XFCE 18.04 (64-bit)
    • Просмотр профиля
Re: Ubuntu 20.04.1 и Canon LBP6020
« Ответ #2 : 21 Апрель 2021, 15:46:23 »
cndrvcups-common_3.21-1_amd64.deb: HTML document, ASCII text, with very long lines

На официальном сайте последняя версия драйвера 2,71, похоже скрипт пытается скачать несуществующий файл.

Нужно ждать обновления скрипта или устанавливать драйвер вручную (танцы с бубном).
« Последнее редактирование: 21 Апрель 2021, 15:59:08 от Пользователь »

Оффлайн Сергий

  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Ubuntu 20.04.1 и Canon LBP6020
« Ответ #3 : 22 Апрель 2021, 18:59:38 »
скрипт удачно скачивает 2 пакет:
cndrvcups-capt_2.71-1_amd64.deb
cndrvcups-common_3.21-1_amd64.deb

они оба существуют, но на последний жалуется (возможно битый)

Оффлайн Пользователь

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 2644
  • Runtu XFCE 18.04 (64-bit)
    • Просмотр профиля

Оффлайн Сергий

  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Ubuntu 20.04.1 и Canon LBP6020
« Ответ #5 : 26 Апрель 2021, 13:00:28 »
Спасибо. Сразу не догадался.
(Заменить битые пакеты пришедшие со скриптом на оригинальные с официального сайт)
Совсем расслабился :)

 

Страница сгенерирована за 0.096 секунд. Запросов: 21.