Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Звук пропал  (Прочитано 4765 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Звук пропал
« : 10 Октябрь 2019, 21:41:12 »
На виндах есть.
Включал в BIOS параллельный порт. Выключил, звук не появился. Хотя на виндах звук есть хоть включен LPT, хоть выключен.
Настройки все что вижу в норме.
mplayer, VLC не воспроизводят. Шкала проигрывания идёт, звука нет. Фильмы на Firefox так же.
# lshw -C multimedia
(Нажмите, чтобы показать/скрыть)
Здесь звуковая карта - нижняя (CMI8768). Внутренняя Azalia не используется.

В alsamixer всё на максимум, каналов Mute нет.

# cat /etc/default/speech-dispatcher
(Нажмите, чтобы показать/скрыть)

Софт/железо:
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 10 Октябрь 2019, 22:37:38:

Звук появляется, как с бочки, если включить pavucontrol --tab 5
Отображаются настройки вкладки Advanced категории Audio Volume секции Multimedia раздела Hardware из System Settings. Они те же, но звук появляется как из ...


Пользователь добавил сообщение 10 Октябрь 2019, 23:14:16:

А почему Sink-и в SUSPENDED? Может в этом дело?
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 11 Октябрь 2019, 09:25:58 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Звук пропал
« Ответ #1 : 11 Октябрь 2019, 09:22:21 »
Dexel, а что скажет pacmd list-cards?
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #2 : 11 Октябрь 2019, 15:01:14 »
$ pacmd list-cards
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 11 Октябрь 2019, 18:12:31 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Звук пропал
« Ответ #3 : 11 Октябрь 2019, 18:10:55 »
Dexel, карта C-Media CMI8738 применяется с какой акустикой? Её текущий активный профиль output:analog-stereo+input:analog-mono. Если на самом деле в эту карту воткнуть, скажем, систему 5.1, то вполне себе вероятно что звук пойдет не из того места и не тот, который ожидается услышать на выходе. Доступные выходы: analog-surround-40 и iec958-stereo. Почему могло перескочить - дело десятое.
Можно попробовать как вариант:pacmd set-card-profile 2  output:analog-surround-40
pacmd set-card-profile 2 output:iec958-stereo+input:analog-mono
pacmd set-card-profile 2 output:iec958-stereo+input:analog-stereo
pacmd set-card-profile 2 iec958-stereo+input:iec958-stereo
Изменения вступают в силу незамедлительно. Можно даже включить в фоне плеер, и щелкать профили, покуда звук не появится, - я подобныем образом в свое время с выводом звука через hdmi игрался, работает нормально.
В исходное состояние (в текущее):pacmd set-card-profile 2 output:analog-stereo+input:analog-mono
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #4 : 12 Октябрь 2019, 08:33:20 »
Акустика - стереовыход на усилитель.
На входе - моновский микрофон иногда.

Вот этот включает:pacmd set-card-profile 2  output:analog-surround-40Звук как через pavucontrol, из бочки :(

Alsamixer бездействует, ни Master, ни Center - ничего не работает. Звук идёт мимо него.
 
« Последнее редактирование: 12 Октябрь 2019, 08:45:23 от Dexel »

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1303
    • Просмотр профиля
Re: Звук пропал
« Ответ #5 : 12 Октябрь 2019, 12:39:12 »
Здесь звуковая карта - нижняя (CMI8768). Внутренняя Azalia не используется.
На днях в соседней теме читал, что появился звук после того, как в Биос-е разрешили Azalia.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #6 : 12 Октябрь 2019, 14:04:22 »
Она и разрешена в BIOS, хоть и не используется.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1303
    • Просмотр профиля
Re: Звук пропал
« Ответ #7 : 12 Октябрь 2019, 14:48:39 »
pacmd set-card-profile 2  output:analog-surround-40
Звук как через pavucontrol, из бочки
Вот вы любители через терминал настраивать ? При output:analog-surround и должно быть из бочки, если слушаем стерео, то никаких сурраундов даже и не пробуем, только стерео. Тестируя различные дистрибутивы я ищу выход только в альса микшере запустив deadbeef на воспроизведение. Искать приходится частенько из-за того, что часто вывожу по разному...днём по hdmi на ресивер с акустикой, ночью на цап по оптике или на аналог с матери.

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Звук пропал
« Ответ #8 : 13 Октябрь 2019, 05:54:57 »
Dexel, uname -r
find /boot/ -maxdepth 1 -name vmlinuz*
?

Пользователь добавил сообщение 13 Октябрь 2019, 06:02:35:
vladimirzhuravlev,
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 13 Октябрь 2019, 06:02:35 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #9 : 15 Октябрь 2019, 13:15:05 »
Dexel, uname -r
find /boot/ -maxdepth 1 -name vmlinuz*
?
Вот ядро
# uname -r
4.15.0-66-generic

# find /boot/ -maxdepth 1 -name vmlinuz*
/boot/vmlinuz-4.15.0-65-generic
/boot/vmlinuz-4.15.0-66-generic

pacmd set-card-profile 2  output:analog-surround-40 Звук как через pavucontrol, из бочки
Вот вы любители через терминал настраивать ? При output:analog-surround и должно быть из бочки, если слушаем стерео, то никаких сурраундов даже и не пробуем, только стерео. Тестируя различные дистрибутивы я ищу выход только в альса микшере запустив deadbeef на воспроизведение. Искать приходится частенько из-за того, что часто вывожу по разному...днём по hdmi на ресивер с акустикой, ночью на цап по оптике или на аналог с матери.

Ну и включен у меня профиль стерео аналогового & моновского микрофона - звука нет.
Написано это в самом начале.
« Последнее редактирование: 15 Октябрь 2019, 16:18:38 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Звук пропал
« Ответ #10 : 15 Октябрь 2019, 16:19:14 »
vmlinuz-4.15.0-65-generic
Попробуйте загрузиться с этим ядром. Изменится ли что-нибудь?
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #11 : 16 Октябрь 2019, 12:01:16 »
Картина та же и на других профилях. На текущем звука нет.
Короче тему наверное закрываю, для фильмов и музыки - Win 7.

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5428
    • Просмотр профиля
Re: Звук пропал
« Ответ #12 : 16 Октябрь 2019, 12:37:57 »
Dexel,

BIOS сбрасывали?  из LiveCD звук есть?  если завести нового пользователя, звук есть?

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #13 : 17 Октябрь 2019, 11:31:18 »
BIOS сбрасывал.

С LIVE-DVD звук есть.

$ pacmd list-cards с LIVE-DVD
(Нажмите, чтобы показать/скрыть)
               
На LIVE-DVD устанавливал свой профиль
(Нажмите, чтобы показать/скрыть)
- звук был в норме.

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5428
    • Просмотр профиля
Re: Звук пропал
« Ответ #14 : 17 Октябрь 2019, 12:08:13 »
С LIVE-DVD звук есть.
значит, проблема скорее всего в настройках текущего пользователя. Добавьте в систему нового пользователя и проверьте звук в его профиле - не в Live режиме, а в установленном дистрибутиве.
Перед этим можно попробоватьrm -rf ~/.config/pulseперелогиниться и проверить звук.

 

Страница сгенерирована за 0.096 секунд. Запросов: 25.