Форум русскоязычного сообщества Ubuntu


Автор Тема: Звук пропал  (Прочитано 4779 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #15 : 17 Октябрь 2019, 15:03:06 »
Удалял конфиги пульса и создавал нового юзера через System Settings, - нет звука  >:(

Пользователь добавил сообщение 17 Октябрь 2019, 15:09:48:

Почему бездействует ALSAMIXER?

Пользователь добавил сообщение 17 Октябрь 2019, 15:38:27:

(Нажмите, чтобы показать/скрыть)

И звука нет. Могила исправит.
« Последнее редактирование: 17 Октябрь 2019, 15:39:56 от Dexel »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 647
    • Просмотр профиля
Re: Звук пропал
« Ответ #16 : 17 Октябрь 2019, 16:15:21 »
Dexel, покажите файл /var/log/syslog (полностью!)

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #17 : 17 Октябрь 2019, 18:35:44 »
Что сейчас.

Отключил Azalia в BIOS.

В файле /etc/pulse/default.pa закомментировал строку:load-module module-suspend-on-idleИсточник: https://unix.stackexchange.com/questions/114602/pulseaudio-sink-always-suspended
Теперь SINK-и стали в статус IDLE, были в SUSPEND (в ранних постах писал).

Профиль установил изначальный:pacmd set-card-profile 1 output:analog-stereo+input:analog-mono(Azalia исчезла, потому индекс стал 1)

Звук гадкий, бубнение. Как программная отфильтрация НЧ, не выворачивается даже через эквалайзер VLC.

Пользователь добавил сообщение 17 Октябрь 2019, 18:59:30:

archuser, syslog:
https://drive.google.com/file/d/1MdwlpSyGWVc2Z1J-zWHBRGSy2MIGapeG/view?usp=sharing
« Последнее редактирование: 17 Октябрь 2019, 19:00:02 от Dexel »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 647
    • Просмотр профиля
Re: Звук пропал
« Ответ #18 : 18 Октябрь 2019, 01:26:06 »
Dexel, напрягают вот эти строки в лог-файле:
(Нажмите, чтобы показать/скрыть)
Следуйте рекомендации и попробуйте загрузиться с параметром ядра irqpoll. Как передать параметр ядру рассказано здесь. О результатах отпишитесь.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #19 : 18 Октябрь 2019, 19:57:50 »
Там сообщение что отключено прерывание 20H, за это?
Да вроде то прерывание за звук отвечает.

Загрузился с irqpoll, то же самое :(

(Нажмите, чтобы показать/скрыть)

Того кровавого сообщения об отключении IRQ #20 сейчас нет
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 18 Октябрь 2019, 20:01:35:
* то же самое в смысле звук - одни низы на профиле
pacmd set-card-profile 1 output:analog-stereo+input:analog-mono
« Последнее редактирование: 18 Октябрь 2019, 20:01:35 от Dexel »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 647
    • Просмотр профиля
Re: Звук пропал
« Ответ #20 : 19 Октябрь 2019, 11:50:50 »
Dexel, еще разок продемонстрируйте файл /var/log/syslog.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #21 : 19 Октябрь 2019, 20:18:03 »
syslog в аттачменте

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 647
    • Просмотр профиля
Re: Звук пропал
« Ответ #22 : 20 Октябрь 2019, 17:43:37 »
Dexel, я надеялся, что Вы предоставите лог после того, как попытаетесь воспроизвести какие-нибудь файлы. И еще уточните, какое актуальное ядро используется в системе, и какое задействуется в live-системе. Предоставьте также вывод команды amixer.

Оффлайн Dexel

  • Автор темы
  • Активист
  • *
  • Сообщений: 295
    • Просмотр профиля
Re: Звук пропал
« Ответ #23 : 21 Октябрь 2019, 06:40:05 »
Ядро текущее:
# uname -a
Linux dexel-A780L3C 4.15.0-66-generic #75-Ubuntu SMP Tue Oct 1 05:24:09 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Ядро Live-диска:# uname -a
Linux kubuntu 4.15.0-15-generic #16-Ubuntu SMP Wed Apr 4 13:58:14 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Вывод amixer и syslog после проигрывания на mplayer в аттаче
« Последнее редактирование: 21 Октябрь 2019, 06:58:07 от Dexel »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 647
    • Просмотр профиля
Re: Звук пропал
« Ответ #24 : 22 Октябрь 2019, 13:45:00 »
Dexel, а почему у Вас включен четырехканальный режим, в то время, когда используется двухканальный?:
Цитировать
Simple mixer control 'Four Channel Mode',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
В каком-то документе по вашей карточке читал, что установка данного микшера приводит к проблемам с выводом звука через Rear-выход. Я ожидал увидеть полный лог, а не его часть. Также было бы неплохо продемонстрировать вывод проигрывателя.

 

Страница сгенерирована за 0.048 секунд. Запросов: 21.