Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Как поставить python3.6 в wing ide  (Прочитано 4084 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pen1agramm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Как поставить python3.6 в wing ide
« : 28 Декабря 2017, 23:07:04 »
Доброго времени суток, форумчане. Буквально недавно перешел на Linux. Установил Ubuntu 16.04. Установил Wing Ide 101 5.1. Настало время выбрать версию питона. Как я понял, в моей версии убунто уже есть python 3.5. Но мне захотелось 3.6. С установкой python 3.6 справился, но тут возникла другая проблема. Когда в wing ide в python environment выбираю скаченную мной версию 3.6 по адресу /usr/bin/python3.6 то python shell выдает это:



Trying to import netserver from ['/usr/lib/wingide-101-5/bin/3.6/src/debug/tserver'] Unable to import findmodules Traceback (most recent call last): File «/usr/lib/wingide-101-5/bin/wingdb.py», line 584, in FindNetServerModule import findmodules ModuleNotFoundError: No module named 'findmodules' Trying to import netserver from ['/usr/lib/wingide-101-5/src/debug/tserver'] Unable to import findmodules Traceback (most recent call last): File «/usr/lib/wingide-101-5/bin/wingdb.py», line 584, in FindNetServerModule import findmodules ModuleNotFoundError: No module named 'findmodules' Traceback (most recent call last):

File «/usr/lib/wingide-101-5/bin/wingdb.py», line 787, in main netserver = FindNetServerModule(winghome, user_settings, tmp_log)

File «/usr/lib/wingide-101-5/bin/wingdb.py», line 620, in FindNetServerModule raise ImportError('Could not import netserver')

ImportError: Could not import netserver

wingdb.py: Error: Failed to start the debug server wingdb.py: Error: You may be running an unsupported version of Python wingdb.py: Python version = 3.6.3 (default, Oct 6 2017, 08:44:35) [GCC 5.4.0 20160609] wingdb.py: WINGHOME='/usr/lib/wingide-101-5' Traceback (most recent call last): File «/usr/lib/wingide-101-5/bin/wingdb.py», line 787, in main netserver = FindNetServerModule(winghome, user_settings, tmp_log) File «/usr/lib/wingide-101-5/bin/wingdb.py», line 620, in FindNetServerModule raise ImportError('Could not import netserver') ImportError: Could not import netserver

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File «/usr/lib/wingide-101-5/bin/wingdb.py», line 798, in main sys.exit(-1) SystemExit: -1



Подскажите, пожалуйста, как решить это проблему и начать работать с python3.6 в wing ide?

ТС не появлялся на Форуме более полугода по состоянию на 17/07/2019 (последняя явка: 23/04/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 17 Июля 2019, 09:13:25 от zg_nico »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 659
    • Просмотр профиля
Re: Как поставить python3.6 в wing ide
« Ответ #1 : 29 Декабря 2017, 01:23:15 »
А вы не думали о том, что устанавливая столь древнюю версию среды разработки, Вы напоритесь на банальное отсутствие поддержки со стороны IDE на выбранную вами версию языка python, т.к. сама среда разработки реализована на этом языке?: 
Error: You may be running an unsupported version of Python wingdb.py
Последняя версия данного продукта - Version 6.0.9-1, поддерживаемые версии языка python

 

Страница сгенерирована за 0.069 секунд. Запросов: 23.