Форум русскоязычного сообщества Ubuntu


Автор Тема: При обновлении 10.04 на 10.10 выдает ошибку  (Прочитано 5769 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AOpen751

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
При обновлении 10.04 на 10.10 выдает следующую ошибку:

Не удалось рассчитать обновление системы

An unresolvable problem occurred while calculating the upgrade:
E:Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

Если ничего не помогает, сообщите, пожалуйста, об ошибке, связанной с пакетом "update-manager", и приложите файлы из /var/log/dist-upgrade/ к сообщению.

Как с этим бороться? Подскажите, будьте любезны.


Оффлайн V_Maksim

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #1 : 30 Октябрь 2010, 15:17:23 »
Та же проблема.
Как можно узнать какие пакеты мешают ?

Оффлайн Kwon

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #2 : 04 Ноябрь 2010, 19:25:57 »
У меня тоже самое (((((
Парни, Гуру помогите!!!!! Пожалуйста! ))))

Beldieff

  • Гость

Оффлайн Kwon

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #4 : 07 Ноябрь 2010, 19:29:00 »
Перевод-то понятен! Вопрос в том что с этим делать? Как обновить до 10.10 ?
Никаких пре-релизов не ставил, лишь обновления которые находил Update Manager.

тут '/var/log/dist-upgrade/' в логах  сказано что типа у вас десктопная версия, а не серверная, и поэтому нате вам ошибку!

вот последние строки main.log

2010-10-30 18:41:48,237 DEBUG running doUpdate() (showErrors=True)
2010-10-30 18:46:40,082 DEBUG openCache()
2010-10-30 18:46:40,082 DEBUG failed to SystemUnLock() (E:Not locked)
2010-10-30 18:46:43,294 DEBUG /openCache(), new cache size 32315
2010-10-30 18:46:43,295 DEBUG needServerMode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2010-10-30 18:47:24,086 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'
2010-10-30 18:47:24,086 DEBUG abort called
« Последнее редактирование: 07 Ноябрь 2010, 19:31:45 от Kwon »

Оффлайн Shefango

  • Старожил
  • *
  • Сообщений: 1120
  • "Нет ни Зла, ни Добра. Только Целесообразность"
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #5 : 07 Ноябрь 2010, 22:00:49 »
Опять: "На колу мочало, начинай сначала." Весь форум забит этими хэлпами с кучей восклицательных знаков. Создатели Ubuntu сами НЕ РЕКОМЕНДУЮТ ОБНОВЛЕНИЕ. Вам их рекомендация не указ? Тогда не надо хэлпы засылать. Проще всего поставить систему заново, не форматируя хомяка. Все настройки программ сохранятся.
Ubuntu MATE@G2120/ASRock H61M-DGS/2x2Gb RAM/500Gb,1Tb,1Tb SATA/GF GTХ650/ext4
Runtu XFCE-14.04@Dell Inspirion 3542

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3221
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #6 : 04 Январь 2011, 20:27:54 »
https://forum.ubuntu.ru/index.php?topic=28805.0
ведет на тему
Тема или раздел, которую Вы ищете, отсутствует или недоступна для входа.

http://wow.chg.su/inside/filemgr.php?c=48f2 
скриншот  мини

на других машинах с копией этой же ос сделанной акронисом обновление прошло на отличненько! и всё работает!

Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3221
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #7 : 11 Январь 2011, 17:48:51 »
ап

php 5.2 может мешать обновлению?
мне его ни в коем случае нельзя обновлять из за долбаного zend optimizer а
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4996
  • Все по палатам!
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #8 : 11 Январь 2011, 17:54:26 »
мне его ни в коем случае нельзя обновлять из за долбаного zend optimizer а
Так не обновляйся  :-\
Извините, я все еще учусь

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3221
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #9 : 11 Январь 2011, 19:00:20 »
ну наутилусь виснет ..
и hp печатает либо цветным либо черно белым картриджем
и блютус клава не работает
да к тому же может наконец iptool 1.1.5 заработает под вине.
и two worlds перестанет тормозить аж до 1fps
чем же ещё как не обновлением пытаться решить?

у меня столько надежд на это обновление
может в 6-й раз они наконец всё исправят и все будет идеально как в сказке.

Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4996
  • Все по палатам!
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #10 : 11 Январь 2011, 19:03:33 »
у меня столько надежд на это обновление
может в 6-й раз они наконец всё исправят и все будет идеально как в сказке.
Так может параллельно поставить и посмотреть сначала?
Извините, я все еще учусь

Оффлайн kit_oz

  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #11 : 11 Январь 2011, 19:44:11 »
как панацею не рекомендую за незнанием последствий
но я после вылезания подобного сообщения вручную добавил репозитории маверика, и постепенно отмечая для обновления по 30-40 паектов, плюс прослеживая кто кого удаляет или устанавливает, обновил все доступные пакеты. после ошибку впринципе нашел - у меня она была связана с каким-то модулем X сервера и еще парой пакетов - не могли они поделить зависимости между собой
молчание не всегда доказывает присутствие ума, но доказывает отсутствие глупости

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3221
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #12 : 12 Январь 2011, 13:38:57 »
а какой ppa надо добавить для новых источников?
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн kit_oz

  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #13 : 12 Январь 2011, 19:20:42 »
deb http://ru.archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
молчание не всегда доказывает присутствие ума, но доказывает отсутствие глупости

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3221
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: При обновлении 10.04 на 10.10 выдает ошибку
« Ответ #14 : 13 Январь 2011, 14:05:38 »
deb http://ru.archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
спасибо, добавилось
но менеджер обновлений отвалился с вот таким сообщением
http://wow.chg.su/inside/filemgr.php?c=8106

в нем был всего один пункт - обновится до 10.10.
нажал, вот жду эффекта 6)

если что по крайней мере через синаптик можно отдельно то что нужно обновлять.
kernel то можно обновить без страха потерять ос ?  :)
надеюсь система выживет после обновления :)  пока не рискнул, просто обновил audacious , он ещё за собой 200 программ потянул


Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

 

Страница сгенерирована за 0.217 секунд. Запросов: 22.