Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: EciAdsl еще раз (ADSL USB модемы)  (Прочитано 1186 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alexey931

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
  • Arch Plasma
    • Просмотр профиля
EciAdsl еще раз (ADSL USB модемы)
« : 17 Сентябрь 2007, 12:19:50 »
Доброго времени суток всем!

Сабж является известной головной болью с момента своего появления; обсуждался на форуме неоднократно. Увы, приходится поднимать тему еще раз. Похоже, что те, кому доставалась в точности моя проблема, решив ее, не публиковали резюме...

Описываю свой случай, не сильно отличающийся от многих других:

Модем Xavi X7005Q2, в настоящее время поддерживается явным образом:

http://eciadsl.flashtux.org/modems.php?modem=70

Скачано и поставлено, успешно, по всем признакам, вот это:

 eciadsl-usermode_0.12-1_i386.deb

и вот это:

 eciadsl-synch_bin.tar.bz2

Выполняем

# eciadsl-start

После чего синхронизируемся и доходим до успешного коннекта включительно. Затем следует:

Waiting for tap0

tap0: ERROR While getting interface flags. No such device.

Роясь повсюду, нахожу две зацепки:

http://shamansir.wordpress.com/2007/07/21/ubuntu-704-%D0%9F%D1%8B%D1%85%D1%82%D0%B5%D1%80%D1%81%D0%BA%D0%B8%D0%B9-%D0%90%D0%B2%D0%B0%D0%BD%D0%B3%D0%B0%D1%80%D0%B4-adsl-%D0%BC%D0%BE%D0%B4%D0%B5%D0%BC-d-link/

Тут все очень похоже, но:

# lsusb

Не показывает сигнатуры устройства;

Автор далее пишет:

"это собственно конфигурация PPPoE. Утилита должна найти инет на интерфейсе tap0 и задавать диалогами вопросы и просьбы, среди которых попросят ввести пароль/юзернейм снова, а на все остальные - отвечать разумно, чаще всего – “да” :)."

Утилита (pppoeconf) не показывает ничего (для меня) очевидного. Видит только eth0, который, совершенно справедливо, не подключен; иначе передает меня в руки modconf; там драйверы, драйверы, драйверы - ни одной знакомой буквы. До "вопросов и просьб" дело не доходит. Нахожу там, кстати, реально подключенный планшет Wacom; так я его и по lsusb вижу. Может, то, чего не видит lsusb не увидит и modconf?

В общем, по этой линии не знаю, что делать дальше.


Еще намек здесь:

http://eciadsl.flashtux.org/faq.php

пункт 4.1.1

Тут мне просто, как неопытному пользователю, нужен перевод на русский язык.

Вот такие пироги; помощь требуется остро.


Заранее благодарен, Алексей

Оффлайн Alexey931

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
  • Arch Plasma
    • Просмотр профиля
Re: EciAdsl еще раз (ADSL USB модемы)
« Ответ #1 : 17 Сентябрь 2007, 13:33:48 »
Информация вдогонку:

Содержимое /etc/eciadsl/eciadsl.conf (Питерский Авангард):

VID1=0e60
PID1=0600
VID2=0e60
PID2=0600
MODE=LLC_SNAP_RFC1483_BRIDGED_ETH_NO_FCS
VCI=35
VPI=0
FIRMWARE=/etc/eciadsl/firmware00.bin
SYNCH=/etc/eciadsl/gs7470_synch04.bin
PPPD_USER=ptn
PPPD_PASSWD=
USE_DHCP=no
USE_STATICIP=no
STATICIP=
GATEWAY=
MODEM=Xavi X7005Q2
MODEM_CHIPSET=GS7470
SYNCH_ALTIFACE=5
PPPOECI_ALTIFACE=1
PROVIDER=Other
DNS1=213.158.0.6
DNS2=213.48.193.36


/etc/ppp/pppoe.conf отсутствует. Оно и понятно: pppoeconf меня не обслужил. Но так его об этом попросить надо; хорошо бы знать, как.

Оффлайн Alexey931

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
  • Arch Plasma
    • Просмотр профиля
Re: EciAdsl еще раз (ADSL USB модемы)
« Ответ #2 : 19 Сентябрь 2007, 11:49:58 »
Ладно, сузим вопрос до предела.

Мне надо сгенерить файл /etc/ppp/pppoe.conf. Примерно такой:

ETH='tap0'
USER='ptn'
DEMAND=no
#DEMAND=300
DNSTYPE=SERVER
PEERDNS=yes
DNS1=
DNS2=
DEFAULTROUTE=yes
CONNECT_TIMEOUT=30
CONNECT_POLL=2
ACNAME=
SERVICENAME=
PING="."
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-pppoe.pid"
SYNCHRONOUS=no
#SYNCHRONOUS=yes
CLAMPMSS=1412
#CLAMPMSS=100
#CLAMPMSS=no
LCP_INTERVAL=20
LCP_FAILURE=3
#LCP_FAILURE=30
PPPOE_TIMEOUT=80
FIREWALL=NONE
LINUX_PLUGIN=
PPPOE_EXTRA=""
PPPD_EXTRA=""

Делает это утилита pppoeconf. Как ее уговорить? Возможно, ей надо видеть модем, но как быть, если драйвер проставлен, даже коннект получается, а устройства типа нет?

Оффлайн Alexey931

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
  • Arch Plasma
    • Просмотр профиля
Re: EciAdsl еще раз (ADSL USB модемы)
« Ответ #3 : 20 Сентябрь 2007, 13:05:48 »
Неужто проблема такая уникальная? Или вопрос нестерпимо глупый? Или ответ давно выложен на самом видном месте?

Оффлайн Alexey931

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
  • Arch Plasma
    • Просмотр профиля
Re: EciAdsl еще раз (ADSL USB модемы)
« Ответ #4 : 04 Октябрь 2007, 16:50:53 »
Вот, вялотекущий разговор с производителем драйвера. Впрочем, может, сказано достаточно, просто юзер неопытный :) ? Не мог бы кто объяснить мне, что тут пытаются сказать...



http://eciadsl.flashtux.org/forum/viewtopic.php?t=3341

http://eciadsl.flashtux.org/forum/viewtopic.php?t=3353

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.