Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Отвалился hibernate после копирования / на другой раздел  (Прочитано 1373 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Даня

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Решил увеличить размер /. Не нашел ничего удобнее, как создать новый раздел и туда GPartition скопировать старый раздел /. Удалил старый раздел с /. Отредактировал fstab и файл настроек grub, инсталлировал grub.
Система грузится без проблем, да вот беда - больше не работает hibernate. Теперь вместо него только suspend.

Hibernate запускал через меню K и напрямую скриптом /etc/acpi/hibernate.h

Система Kubuntu fiesty.

Оффлайн Даня

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Лог запуска /etc/acpi/hibernate.sh прилагаю
« Ответ #1 : 27 Сентябрь 2007, 22:28:35 »
Помогите пожалуйста!

:~$ sudo /etc/acpi/hibernate.sh
Password:
RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.eth0.pid with pid 5175
removed stale PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:0c:76:93:07:99
Sending on   LPF/eth0/00:0c:76:93:07:99
Sending on   Socket/fallback
ifdown: interface eth0:avah not configured
SIOCSIFFLAGS: Cannot assign requested address
ifdown: interface ppp0 not configured
ppp0: ОШИБКА при получении флага интерфейса: No such device
 * Shutting down ALSA...                                                 [ OK ]
/etc/acpi/hibernate.sh: line 39: echo: ошибка записи: No such device
Laptop mode disabled, not active.
/etc/acpi/resume.d/17-video-restore.sh: line 5: /var/lib/acpi-support/vbestate: No such file or directory
Function not supported
ifup: interface eth0 already configured
Ignoring unknown interface eth0:avah=eth0:avah.
Ignoring unknown interface ppp0=ppp0.
 * Setting up ALSA...                                                    [ OK ]
/etc/acpi/resume.d/72-acpi-pain.sh: line 22: echo: ошибка записи: No such device
/etc/acpi/resume.d/72-acpi-pain.sh: line 23: echo: ошибка записи: No such device
FATAL: Module acpi_sbs not found.
FATAL: Module acpi_sbs not found

Оффлайн Krusader

  • Любитель
  • *
  • Сообщений: 65
    • Просмотр профиля
У меня аналогичная проблема на десктопе с Ubuntu 8.04 материнкой от асуса и асусовской видеокартой Nvidia 7600.
Вот вывод:

dima@dima-desktop:~$ sudo /etc/acpi/hibernate.sh
[sudo] password for dima:
ifdown: interface vmnet1 not configured
ifdown: interface vmnet8 not configured
 * Shutting down ALSA...                                                 [ OK ]
 * Saving the system clock
/sbin/s2disk: invalid option -- x
Usage: s2disk [options]
  -h, --help            this text
  -f, --config <config>         alternative configuration file.
  -r, --resume_device <resume_device>   device that contains swap area
  -o, --resume_offset <resume_offset>   offset of swap file in resume device.
  -s, --image_size <image_size>      desired size of the image.
Laptop mode disabled, not active.
 * Setting the system clock
ifup: interface eth0 already configured
Ignoring unknown interface vmnet1=vmnet1.
Ignoring unknown interface vmnet8=vmnet8.
 * Setting up ALSA...                                                    [ OK ]
FATAL: Module acpi_sbs not found.
FATAL: Module acpi_sbs not found.


Посоветуйте что-нибудь...

Оффлайн Photon79

  • Новичок
  • *
  • Сообщений: 37
  • Злобный линуксоид
    • Просмотр профиля
Даня
Из лога же ясно видно, что раздел, на который записывается состояние, указан неверно..
AthlonXP 2500+, RAM 768, HDD 240, GF4 MX440 64Mb @ Ubuntu 8.10

Аааааа...  Линеечку сломали..  :(

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.