Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: "Левая" сеть в маршрутах  (Прочитано 533 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн antei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
"Левая" сеть в маршрутах
« : 03 Февраль 2011, 13:08:10 »
Нет работает, но в маршрутах есть левая сеть, хотелось бы разобраться. :idiot2:
Извините если что не так. Ну история следующая: Провайдер интернета предоставляет доступ в нет по PPPoE + Локалку (локалка получает параметры от dhcp).
Через НетворкМенеджер не запустился нет, я его срубил и настроил через pppoeconf DSL подключение. В файле /etc/network/interfaces "отключил" сетевушку написав вместо dhcp manual. Нет поднялся, НО после перезагрузки компа не работает DNS.
Полез в файл /etc/resolv.conf, а там вместо нужных DNS стоят какие то 10.100.1.4 и 10.100.1.5. Я ребутнул сеть командой /etc/init.d/networking restart DNS исправился. Создал я скрипт с предидущей командой и кинул в init.d, нет стал подниматься автоматом.
Настала очередь локалки.(( Ставлю в файле /etc/network/interfaces вместо manual dhcp  и тут начинается.... С отключеной локалкой вывод команды route следующий:
172.16.0.1      *               255.255.255.255 UH    0      0        0 ppp0
default         *               0.0.0.0         U     0      0        0 ppp0
нет при этом работает. Локалка нет.
С отключеным PPPoE маршруты такие:
10.252.1.0      *               255.255.255.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1000   0        0 eth1
default         10.252.1.1      0.0.0.0         UG    0      0        0 eth1
А вот если вместе то:
172.16.0.1      *               255.255.255.255 UH    0      0        0 ppp0
10.252.1.0      *               255.255.255.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1000   0        0 eth1
10.0.0.0        10.100.1.1      255.0.0.0       UG    0      0        0 ppp0
default         *               0.0.0.0         U     0      0        0 ppp0
default         10.252.1.1      0.0.0.0         UG    100    0        0 eth1
Я конечно понимаю, что надо срубить второй дефлоидный маршрут который от локалки, что бы работал и нет и локалка. Вопрос не в этом.
Вопрос ОТКУДА ВЗЯЛСЯ МАРШРУТ 10.0.0.0 со своим шлюзом 10.100.1.1 и DNS 10.100.1.4??? Почему он на интерфейсе ppp0? И почему даже при отключеной локалке (те вместо dhcp написано manual) и нет ни каких левых маршрутов, после перезагрузки компа DNS сбрасывается? Заранее всем спасибо!
« Последнее редактирование: 03 Февраль 2011, 13:38:57 от antei »

Оффлайн scsiman

  • Активист
  • *
  • Сообщений: 335
    • Просмотр профиля
Re: "Левая" сеть в маршрутах
« Ответ #1 : 03 Февраль 2011, 13:21:26 »
И что это за левая сеть?
Dell Studio XPS 16, Ubuntu 14.04 LTS (Home).
HP nx6110, Ubuntu 8.04 LTS => 10.04 LTS (Home).

rapidsp

  • Гость
Re: "Левая" сеть в маршрутах
« Ответ #2 : 03 Февраль 2011, 13:49:40 »
Маршрут в локалку провайдера?

Оффлайн antei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: "Левая" сеть в маршрутах
« Ответ #3 : 03 Февраль 2011, 13:54:06 »
Маршрут в локалку провайдера я так понимаю это: 10.252.1.0      *               255.255.255.0   U     0      0        0 eth1
А 10.0.0.0        10.100.1.1      255.0.0.0       UG    0      0        0 ppp0 это что не понимаю. Почему на ppp0???
IP локалки я получаю из сети 10.252.1.0
« Последнее редактирование: 03 Февраль 2011, 13:56:02 от antei »

Оффлайн antei

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: "Левая" сеть в маршрутах
« Ответ #4 : 25 Февраль 2011, 16:36:50 »
Отследил по логам, что если DHCP получает параметры раньше чем поднимется PPPoE то маршруты нормальные. Если на оборот, то кривые маршруты. Решил проблему, как то криво. В /etc/dhcp3/dhclient.conf закоментил все со словами route и dns.
В итоге неделю работает нормально. Вот только не совсем понимаю чем мне это грозит??

Гарри Кашпировский

  • Гость
Re: "Левая" сеть в маршрутах
« Ответ #5 : 25 Февраль 2011, 20:04:51 »
Неполучением маршрута по умолчанию,  роутинга и адресов DNS-серверов, впрочем, для PPPoE это не имеет никакого значения, а вот то, что DHCP отдает маршрут на 10/8 и определяет устройство, это оччень интересно, я такое впервые вижу. Может все-таки где-то в системе "левый" маршрут записан?
« Последнее редактирование: 25 Февраль 2011, 20:06:32 от KT315 »

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.