Форум русскоязычного сообщества Ubuntu


Автор Тема: [РЕШЕНО] Непонятная ошибка с монтированием.  (Прочитано 3417 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн iexx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • iExx
    • Просмотр профиля
    • My Blog
Добрый день сообщество Ubuntu!

Изначально ставил ubuntu 9.04 года полтора назад, сейчас она уже дообновлялась до 10.10.
После очередного обновления перестала грузиться ubuntu.
Вываливается в консоль:

Filesystem check or mount failed.
Maintenance shell running...
Press CONTROL+D for restart.. (ну что-то около этого).

Погуглил, везде пишут что проблема тривиальная и нужно проверить диски.
проверял fsck рут раздел и home
fsck /dev/sda6
fsck /dev/sda7

/dev/sda5 - swap
/dev/sda6 - /           ext3
/dev/sda7 - /home   ext3

пробовал также e2fsck  с параметрами force, fix. перепробовал разные варианты, проверились нужные разделы, найденные ошибки исправлены.

Интересно что если после вываливания в консоль пробовать примонтировать /dev/sda7 => /home вручную, то раздел монтируется нормально.
sudo mountall тоже все нормально монтирует, но не грузит иксы, пишет, что грузится дефолтовая конфигурация.
После этого я жумкаю Control+Alt+F2, ввожу логин, пасс, далее sudo gdm start  и все грузится нормально.

В логах при первоначальном вываливании в консоль ничего нет (видимо потому что раздел монтируется как read only).

/etc/fstab
proc            /proc           proc    defaults        0       0

#/dev/sda5 swap            swap    defaults 0 0
UUID=4e94e081-c109-409f-bf18-3986d1691fe2 /               ext3    relatime 0 1
UUID=79d9385e-4666-a1c1-7376-382f1afd6261 /home            ext3    defaults,owner,nodev 0 2

#UUID=26F86A4FF86A1D75 /data           ntfs    defaults,nls=utf8,umask=0,gid=46 0       1
#UUID=55D123D9E79ABF54 /windows        ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

#/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

Комментировал swap, cdrom и два ntfs раздела уже для отладки, думал может так сработает.


/etc/mtab:
/dev/sda6 / ext3 rw,relatime,commit=0 0 0
proc /proc proc rw 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
/dev/sda7 /home ext3 rw,nosuid,nodev,commit=0 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/igor/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=igor 0 0





igor@igor-laptop:~$ sudo fdisk -l

Диск /dev/sda: 500.1 ГБ, 500107862016 байт
255 heads, 63 sectors/track, 60801 cylinders
Units = цилиндры of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x38399be8

Устр-во Загр     Начало       Конец       Блоки   Id  Система
/dev/sda1   *           1        2394    19229773+   7  HPFS/NTFS
/dev/sda2            2395       10653    66340417+   5  Расширенный
/dev/sda3           10654       60801   402813810    7  HPFS/NTFS
/dev/sda5            2395        2796     3229033+  82  Linux своп / Solaris
/dev/sda6   *        2797        5443    21261996   83  Linux
/dev/sda7            5444       10653    41849293+  83  Linux


Помогите пожалуйста,
Завтра уже работать нужно :'(
« Последнее редактирование: 05 Апрель 2011, 10:57:36 от iexx »

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #1 : 03 Апрель 2011, 15:13:37 »
proc            /proc           proc    nodev,noexec,nosuid 0       0
.............
/dev/sda5  none            swap    sw              0       0
Проверить UUID на всякий случай.
xUbuntu 12.04

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #2 : 03 Апрель 2011, 16:23:06 »
Похоже, загрузчик слетел. Что там, LILO али GRUB2? Если GRUB(2) - то вот: http://www.supergrubdisk.org/

Оффлайн iexx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • iExx
    • Просмотр профиля
    • My Blog
Re: Непонятная ошибка с монтированием.
« Ответ #3 : 04 Апрель 2011, 00:20:17 »
proc            /proc           proc    nodev,noexec,nosuid 0       0
.............
/dev/sda5  none            swap    sw              0       0
Проверить UUID на всякий случай.


Работать же будет и без свопа имхо, т.е. пробовал и вовсе отрубать его. - результат абсолютно тот же.
У меня как-то раньше случайно своп отмонтировался, Ubuntu все равно загрузилась и я об этом даже не знал, пока тормоза при  загрузке памяти не заметил ;(

Пользователь решил продолжить мысль 04 Апрель 2011, 00:21:42:
Похоже, загрузчик слетел. Что там, LILO али GRUB2? Если GRUB(2) - то вот: http://www.supergrubdisk.org/
Спасибо за чудесный liveCD, правда не помог. Сделал как проверку диска, так и grub-update.
Не помогло ;(

Может ещё какие предположения будут? я уже не знаю что и делать.. :-\

ыскуфь

  • Гость
Re: Непонятная ошибка с монтированием.
« Ответ #4 : 04 Апрель 2011, 00:24:01 »
sudo blkid|grep swapВ ответ примерно такое:
/dev/sdb2: UUID="f438719c-605b-420e-bb8a-1221252a610e" TYPE="swap"затем:
sudo gedit /etc/fstabи туда:
UUID=f438719c-605b-420e-bb8a-1221252a610e none            swap    sw              0       0

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #5 : 04 Апрель 2011, 00:32:17 »
Цитировать
Работать же будет и без свопа имхо
Естественно будет, но из за "мелочей" в fstab может не работать.
Разделы проверил, проблем нет? UUID тоже?
xUbuntu 12.04

Оффлайн iexx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • iExx
    • Просмотр профиля
    • My Blog
Re: Непонятная ошибка с монтированием.
« Ответ #6 : 04 Апрель 2011, 00:34:33 »
sudo blkid|grep swapВ ответ примерно такое:
/dev/sdb2: UUID="f438719c-605b-420e-bb8a-1221252a610e" TYPE="swap"затем:
sudo gedit /etc/fstabи туда:
UUID=f438719c-605b-420e-bb8a-1221252a610e none            swap    sw              0       0
Попробовал и так прописать своп. Все равно вываливается в консоль с той же ошибкой.
Может где  все же будет какой лог?

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #7 : 04 Апрель 2011, 00:39:26 »
UUID всех разделов проверил, корня, хомяка?
 Или вот это -
Цитировать
Интересно что если после вываливания в консоль пробовать примонтировать /dev/sda7 => /home вручную, то раздел монтируется нормально.
ну пропиши в fstab вместо UUID dev/sda7, /dev/sda6 - / 
« Последнее редактирование: 04 Апрель 2011, 00:42:13 от Упс »
xUbuntu 12.04

Оффлайн iexx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • iExx
    • Просмотр профиля
    • My Blog
Re: Непонятная ошибка с монтированием.
« Ответ #8 : 04 Апрель 2011, 00:40:08 »
Цитировать
Работать же будет и без свопа имхо
Естественно будет, но из за "мелочей" в fstab может не работать.
Разделы проверил, проблем нет? UUID тоже?

Разделы проверил, ошибок нет, монтируются вручную без проблем.
UUID вроде ок.

proc            /proc           proc    defaults        0       0

UUID=18f21b72-c1c1-4fa9-a18a-48d8d8cff0ca none swap sw 0 0

UUID=4e94e081-c109-409f-bf18-3986d1691fe2 /               ext3    relatime 0 1
UUID=79d9385e-4666-a1c1-7376-382f1afd6261 /home            ext3    defaults,owner,nodev 0 2

UUID=26F86A4FF86A1D75 /data           ntfs    defaults,nls=utf8,umask=0,gid=46 0       1
UUID=55D123D9E79ABF54 /windows        ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

sudo blkid
/dev/sda1: LABEL="win" UUID="55D123D9E79ABF54" TYPE="ntfs"
/dev/sda3: LABEL="s500-data" UUID="26F86A4FF86A1D75" TYPE="ntfs"
/dev/sda5: UUID="18f21b72-c1c1-4fa9-a18a-48d8d8cff0ca" TYPE="swap"
/dev/sda6: UUID="4e94e081-c109-409f-bf18-3986d1691fe2" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda7: LABEL="linux_home" UUID="79d9385e-4666-a1c1-7376-382f1afd6261" SEC_TYPE="ext2" TYPE="ext3"

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #9 : 04 Апрель 2011, 00:43:30 »
proc            /proc           proc    nodev,noexec,nosuid 0       0
xUbuntu 12.04

ыскуфь

  • Гость
Re: Непонятная ошибка с монтированием.
« Ответ #10 : 04 Апрель 2011, 00:47:35 »
proc            /proc           proc    nodev,noexec,nosuid 0       0

А что тут не так? Ну можно попробовать заменить на:
proc            /proc           proc    defaults        0       0
iexx, такое пробовал?
ubuntu-bug mountall

Оффлайн iexx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • iExx
    • Просмотр профиля
    • My Blog
Re: Непонятная ошибка с монтированием.
« Ответ #11 : 04 Апрель 2011, 01:01:15 »
proc            /proc           proc    nodev,noexec,nosuid 0       0

А что тут не так? Ну можно попробовать заменить на:
proc            /proc           proc    defaults        0       0Так в оригинале и было


iexx, такое пробовал?
ubuntu-bug mountall
сейчас отправлю

Пользователь решил продолжить мысль 04 Апрель 2011, 02:03:07:
UUID всех разделов проверил, корня, хомяка?
 Или вот это -
Цитировать
Интересно что если после вываливания в консоль пробовать примонтировать /dev/sda7 => /home вручную, то раздел монтируется нормально.
ну пропиши в fstab вместо UUID dev/sda7, /dev/sda6 - / 
через /dev/sda(x) тоже пробовал монтировать - не проходит.

Когда вываливается в консоль, то получается, что / примонтирован в read only, а /home не подмонтирован.
хотя если тут же сделать sudo mount /dev/sda6 /home - то монтируется нормально.
sudo mountall тоже срабатывает

Пользователь решил продолжить мысль 04 Апрель 2011, 01:06:17:
Вот читаю
https://tools.bitfolk.com/wiki/Upgrading_to_Ubuntu_10.10
« Последнее редактирование: 04 Апрель 2011, 01:06:17 от iexx »

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #12 : 04 Апрель 2011, 01:20:50 »
Цитировать
Когда вываливается в консоль, то получается, что / примонтирован в read only
Может при обновлении что-то покоцалось в ФС, можно попробовать проверить контрольные суммы установленных пакетов - debsums -s
xUbuntu 12.04

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: Непонятная ошибка с монтированием.
« Ответ #13 : 04 Апрель 2011, 01:29:36 »
А попробуй-ка fstab вообще убрать временно (переименуй в fstab.old). По идее, HAL с девайсами должен сам разобраться.  Хотя, нутром чую, что до HALа тут вообще не доходит, и дело вовсе не в fstab. Что-то неладно если не в самом загрузчике, то с разделами в MBR. Или с физической адресацией (порядком подключения) винтов, если там их более одного. А ещё я не помню, есть ли у ext3 какие-либо ограничения на размещение начала раздела (у меня ext4)?
« Последнее редактирование: 04 Апрель 2011, 01:55:37 от RedBeard »

Оффлайн iexx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
  • iExx
    • Просмотр профиля
    • My Blog
Re: Непонятная ошибка с монтированием.
« Ответ #14 : 04 Апрель 2011, 11:07:29 »
А попробуй-ка fstab вообще убрать временно (переименуй в fstab.old). По идее, HAL с девайсами должен сам разобраться.  Хотя, нутром чую, что до HALа тут вообще не доходит, и дело вовсе не в fstab. Что-то неладно если не в самом загрузчике, то с разделами в MBR. Или с физической адресацией (порядком подключения) винтов, если там их более одного. А ещё я не помню, есть ли у ext3 какие-либо ограничения на размещение начала раздела (у меня ext4)?
пробовал удалять fstab - тоже самое.
Если mountall проходит, а он смотрит fstab, то видимо с fstab все в порядке.
А что можно ещё посмотреть в загрузчике или с MBR?
пробовал update-grub, grub-install.

HDD один установлен.
title           Ubuntu 10.10, kernel 2.6.35-26-generic
uuid            4e94e081-c109-409f-bf18-3986d1691fe2
kernel          /boot/vmlinuz-2.6.35-26-generic root=UUID=4e94e081-c109-409f-bf18-3986d1691fe2 ro nosplash vga=792
initrd          /boot/initrd.img-2.6.35-26-generic
quiet

думал может дело в :
kernel          /boot/vmlinuz-2.6.35-26-generic root=UUID=4e94e081-c109-409f-bf18-3986d1691fe2 ro nosplash vga=792
поменял на:
kernel          /boot/vmlinuz-2.6.35-26-generic root=UUID=4e94e081-c109-409f-bf18-3986d1691fe2 rw nosplash vga=792

 

Страница сгенерирована за 0.056 секунд. Запросов: 22.