Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: При очередном включении вместо загрузки ubuntu появился загрузчик GRUB  (Прочитано 2871 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
всем добрый день!
как видно из названия темы, при очередном включении компьютера вместо загрузки ubuntu появился загрузчик GRUB. непредвиденных перезагрузок/выключений не было. установлена только эта ОС.
Ubuntu 10.10, grub 1.98

загрузчик предлагает:
- ubuntu, with Linux 2.6.35-28 - generic
- ubuntu, with Linux 2.6.35-28 - generic (recovery mode)
- ubuntu, with Linux 2.6.35-22 - generic
- ubuntu, with Linux 2.6.35-22 - generic (recovery mode)
- memory test (memtest 86+)
- memory test (memtest 86+, serial console 115200)

выбираю первый вариант загрузки - появляется такой же чёрный экран, как при grub с множеством цифр и разной инфы и вот таким текстом:

killed
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn`t have requested /sbin/init.
[       1.260065] usb 1-8: new high speed USB device usingehci_hcd and address 4
No init found. Try passing init= bootarg


если выбрать другие варианты, происходит то же самое (не уверн дословно ли там всё так же, но на вид - так же  :) )

сейчас я с live CD. пробовал восстановить GRUB по этой инструкции - https://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub
но ничего не вышло. после команды sudo mount /dev/sda1 /mnt ничего не произошло, на следующие команды так же не было никакой реакции.

надеюсь на вашу помощь, заранее спасибо!

p.s. смотрел темы по восстановлению, но описанные там ситуации были не похожи на эту (как мне показалось), но если я повторился, прошу прощения.

Оффлайн S.Popov

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
А sudo fdisk -l   что показывает

Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
показывает таблицу диска...

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000442ae

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       29637   238053376   83  Linux
/dev/sda2           29637       30402     6142977    5  Extended
/dev/sda5           29637       30402     6142976   82  Linux swap / Solaris

Оффлайн S.Popov

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
А еще раз. Только написание команды проверь

sudo mount /dev/sda1 /mnt


Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
я уже ни раз пробовал. и в ручную писал, и перепроверял, и через copy/paste команды вводил. так что ошибок именно в написании вроде быть не должно.

ещё я одного не понял: в энторнетах пишут, что для GRUB 1 и GRUB 2 разное восстановление; в Ubuntu 10.10 стоит GRUB 2, но у меня написано при включении GRUB 1.98 - это первый или второй уже считается?

Оффлайн gаrret

  • Активист
  • *
  • Сообщений: 833
    • Просмотр профиля
ещё я одного не понял: в энторнетах пишут, что для GRUB 1 и GRUB 2 разное восстановление; в Ubuntu 10.10 стоит GRUB 2, но у меня написано при включении GRUB 1.98 - это первый или второй уже считается?
Это второй.
Считаешь, что я неправ? Аргументируй!

Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
ну, значит я правильную инструкцию использовал.. тем не менее ничего не получилось.

Оффлайн S.Popov

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Лавсиди Убунтовскую используешь? Там есть дисковая утилита. Проверь ей, может с диском чего случилось.

Оффлайн Golan

  • Активист
  • *
  • Сообщений: 703
  • Любитель
    • Просмотр профиля
Что в корневом разделе? Ошибки ваши, говорят что не может найти необходимых папок... Проверьте раздел на ошибки.
Lenovo ThinkPad T500/Runtu 14.04 xfce 4.12/

Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
а как проверить объясните пожалуйста поподробнее?

дисковая утилита не хочет проверять раздел, пишет - Daemon is inhibited

в программе GParted выбираю проверку раздела, но он пишет как бы в задачах "надо проверить на ошибки sda1", но нет никакого индикатора идёт ли проверка или происходит ли вообще что-либо. может, надо ещё подождать.

Оффлайн xuser73

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
После выбора проверки раздела в gparted, необходимо щелкнуть по зеленой галочке или "правка" - "выполнить все операции"
Настоящему коту всегда март.

Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
действительно))
но к сожалению "An error occurred while applying the operations"

в результате вот что:


при закрытии этого окна gparted как при первом открытии - никаких изменений, ни отчёта

Оффлайн Golan

  • Активист
  • *
  • Сообщений: 703
  • Любитель
    • Просмотр профиля
Так gparted спрашивает не смонтирована ли файловая система которую вы хотите проверить.
Она не должна быть смонтирована.
Lenovo ThinkPad T500/Runtu 14.04 xfce 4.12/

Оффлайн botygin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
ммм... ок, а как мне ответить, что не смонтирована и начать проверку? что нажать? :))
да, я совсем новичок))

Оффлайн progmo

  • Участник
  • *
  • Сообщений: 105
    • Просмотр профиля
вчера весь вечер убил на эту же проблему https://forum.ubuntu.ru/index.php?topic=148181.0
решилось проверкой диска на ошибки с лайвСД.
Ubuntu 14.04.2

 

Страница сгенерирована за 0.045 секунд. Запросов: 23.