Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ошибка: Система пакетов повреждена.  (Прочитано 3843 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rapido

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
  • во всём виноваты еноты!
    • Просмотр профиля
Сегодня решила вернуться на опенофис и пошла удалять либерофис через центр приложений, в результате, что-то не так пошло.
При попытке установить обновления появляется ошибка:
Система пакетов повреждена.
Если Вы используете сторонние источники приложений, отключите их, поскольку они являются частым
 источником проблем. После этого выполните в терминале следующую команду: apt-get install -f
(в подробнее - liberoffice-core)
Направившись в консоль и введя apt-get install -f, получаю следующее:
(Нажмите, чтобы показать/скрыть)
не могу не обновиться, не установить программы, удалить либерофисные запчасти тоже не могу.

А ещё, когда я желаю очистить систему встроенной утилитой получаю:
Очистка системы не может быть завершена.Убедитесь, что не запущен какой-либо другой менеджер пакетов, например Synaptic или Менеджер Обновлений.
Хотя ничего такого не запущено.

Заранее спасибо за помощь :-\
hopelessness me..~

Оффлайн shenmue

  • Любитель
  • *
  • Сообщений: 77
  • В APT есть коровья СУПЕРСИЛA
    • Просмотр профиля
    • SEclub
Re: Ошибка: Система пакетов повреждена.
« Ответ #1 : 27 Апреля 2011, 20:20:27 »
у вас запущен фоном уже установщик пакетов.
самое простое это перезапустить Ubuntu
затем поставить ppa-purge это программа для грамотного удаления других источников приложений.
sudo apt-get install ppa-purge

ниже пример как ей пользоватся. она удалит все из указаного источника и сам источник и возвратить все пакеты которые источник заменял.
sudo ppa-purge ppa:gnome3-team/gnome3

здесь ppa:gnome3-team/gnome3 это пример. вам нужно подставить источник либре оффиса.

потом уже
sudo apt-get install -f
Хорошо сформулированная задача – основная часть ее решения.

Оффлайн Rapido

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
  • во всём виноваты еноты!
    • Просмотр профиля
Re: Ошибка: Система пакетов повреждена.
« Ответ #2 : 28 Апреля 2011, 09:54:52 »
ребут не помогает с очисткой системы, всё равно пишет, что что-то запущено и мешает ему. предположительно это всё-таки менеджер обновлений, т.к. в трее кирпич появляется после ребута, оповещающий об обновлениях. Но без понятия как избавиться от этого всего(уже отключила проверку обновлений, но эти обновления пришли до этого и так и напрашиваются, но установить не могу из-за ошибки с зависимостями)

Как я уже писала выше, я не могу ничего установить ни через центр приложений, ни через консоль, т.к. появляется всё та же проблема:
root@ubuntu:~# sudo apt-get install ppa-purge
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
 libreoffice-core : Зависит: libreoffice-common (> 1:3.3.2) но он не будет установлен
 ppa-purge : Зависит: aptitude но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).


Пользователь решил продолжить мысль 28 Апреля 2011, 10:32:33:
Разобралась -
Помогло отключение репов либраофиса
Теперь всё вернулось на круги своя и работает как швейцарские часы.)
« Последнее редактирование: 28 Апреля 2011, 10:32:33 от Rapido »
hopelessness me..~

 

Страница сгенерирована за 0.035 секунд. Запросов: 23.